Closed Bug 795728 Opened 8 years ago Closed 8 years ago

crash in mozilla::layers::ContainerLayer::DefaultComputeEffectiveTransforms

Categories

(Core :: Graphics: Layers, defect)

18 Branch
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 795899
Tracking Status
firefox18 - ---

People

(Reporter: scoobidiver, Assigned: mattwoodrow)

References

Details

(Keywords: crash, regression)

Crash Data

It first appeared in 18.0a1/20120929. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=895f66c4eada&tochange=c09a0c022b2e
It's likely a regression from bug 539356 part 8b.

Signature 	msvcr100.dll@0x8af06 More Reports Search
UUID	6750588f-ca34-4c5d-ae16-4507c2120930
Date Processed	2012-09-30 16:25:03
Uptime	3374
Last Crash	2.4 days before submission
Install Age	56.2 minutes since version was first installed.
Install Time	2012-09-30 15:28:43
Product	Firefox
Version	18.0a1
Build ID	20120930030610
Release Channel	nightly
OS	Windows NT
OS Version	6.1.7601 Service Pack 1
Build Architecture	x86
Build Architecture Info	GenuineIntel family 6 model 42 stepping 7
Crash Reason	EXCEPTION_NONCONTINUABLE_EXCEPTION
Crash Address	0x0
App Notes 	
AdapterVendorID: 0x1002, AdapterDeviceID: 0x6738, AdapterSubsysID: 174b174b, AdapterDriverVersion: 8.961.0.0
D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+ 
EMCheckCompatibility	False
Adapter Vendor ID	0x1002
Adapter Device ID	0x6738
Total Virtual Memory	4294836224
Available Virtual Memory	3577937920
System Memory Use Percentage	10
Available Page File	15975899136
Available Physical Memory	15392985088

Frame 	Module 	Signature 	Source
0 	msvcr100.dll 	msvcr100.dll@0x8af06 	
1 	xul.dll 	mozilla::layers::ContainerLayer::DefaultComputeEffectiveTransforms 	gfx/layers/Layers.cpp:798
2 	xul.dll 	mozilla::layers::ContainerLayerD3D9::ComputeEffectiveTransforms 	gfx/layers/d3d9/ContainerLayerD3D9.h:99
3 	xul.dll 	mozilla::layers::ContainerLayer::ComputeEffectiveTransformsForChildren 	gfx/layers/Layers.cpp:812
4 	xul.dll 	mozilla::layers::ContainerLayer::DefaultComputeEffectiveTransforms 	gfx/layers/Layers.cpp:798
5 	xul.dll 	mozilla::layers::ContainerLayerD3D9::ComputeEffectiveTransforms 	gfx/layers/d3d9/ContainerLayerD3D9.h:99
6 	xul.dll 	mozilla::layers::LayerManagerD3D10::EndTransaction 	gfx/layers/d3d10/LayerManagerD3D10.cpp:365
7 	xul.dll 	mozilla::layers::LayerManagerD3D10::EndEmptyTransaction 	gfx/layers/opengl/LayerManagerOGL.cpp:622
8 	xul.dll 	PresShell::Paint 	layout/base/nsPresShell.cpp:5258
9 	xul.dll 	nsViewManager::Refresh 	view/src/nsViewManager.cpp:368
10 	xul.dll 	nsViewManager::PaintWindow 	view/src/nsViewManager.cpp:704
11 	xul.dll 	nsView::PaintWindow 	view/src/nsView.cpp:1036
12 	xul.dll 	nsWindow::OnPaint 	widget/windows/nsWindowGfx.cpp:534
13 	xul.dll 	nsWindow::ProcessMessage 	widget/windows/nsWindow.cpp:4711
14 	xul.dll 	nsWindow::WindowProcInternal 	widget/windows/nsWindow.cpp:4320
15 	xul.dll 	CallWindowProcCrashProtected 	xpcom/base/nsCrashOnException.cpp:32
16 	xul.dll 	nsWindow::WindowProc 	widget/windows/nsWindow.cpp:4266
17 	user32.dll 	InternalCallWinProc 	
18 	user32.dll 	NtUserGetDC 	
19 	user32.dll 	DispatchClientMessage 	
20 	user32.dll 	__fnDWORD 	
21 	ntdll.dll 	KiUserCallbackDispatcher 	
22 	ntdll.dll 	KiUserApcDispatcher 	
23 	user32.dll 	DispatchMessageW 	
24 	xul.dll 	nsAppShell::ProcessNextNativeEvent 	widget/windows/nsAppShell.cpp:322
25 	xul.dll 	nsBaseAppShell::OnProcessNextEvent 	widget/xpwidgets/nsBaseAppShell.cpp:280
26 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:585
27 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:82
...

More reports at:
https://crash-stats.mozilla.com/report/list?signature=msvcr100.dll%400x8af06
https://crash-stats.mozilla.com/report/list?signature=mozilla%3A%3Alayers%3A%3AContainerLayer%3A%3ADefaultComputeEffectiveTransforms
Looks like this might have something to do with flash.
I'm not able to reproduce this on linux-x64/basic or win7/d3d10.
It's #4 top crasher in today's build.
Keywords: topcrash
Duplicate of this bug: 795889
I'm able to reproduce in nightly on osx
Duplicate of this bug: 797006
Matt, assigning this to you as this is dlbi related, please feel free to reassign if needed.Thanks !
Assignee: nobody → matt.woodrow
On which site?

(In reply to Shane Caraveo (:mixedpuppy) from comment #5)
> I'm able to reproduce in nightly on osx
QA Contact: mozillamarcia.knous
Using the socialapi it happens pretty consistently, a couple of our internal testers are running into this as well.

(In reply to Marcia Knous [:marcia] from comment #8)
> On which site?
> 
> (In reply to Shane Caraveo (:mixedpuppy) from comment #5)
> > I'm able to reproduce in nightly on osx
When I pulled and built from hg yesterday, I was unable to use the build at all due to consistent crashes.  I pulled and built again just before lunch, since then I've been running more than not, but I have had two or three crashes.
There are no STR here.

Suspected fixed by bug 795899.
Depends on: 795899
Keywords: reproducible
Depends on: 711953
Does this still show up in the 10/4 nightly?
(In reply to Chris Jones [:cjones] [:warhammer] from comment #12)
> Does this still show up in the 10/4 nightly?
It has stopped after 18.0a1/20121003 but maybe sooner because the Windows crash signature is shared with bug 795940.
Suspected fixed by bug 795899.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 795899
FWIW, I have not had this crash since mattwoodrow landed some bug I cannot see (probably bug 795899)
Clearing the tracking flag as this is resolved by bug 795899 .
This bug has returned, see bug 803194.  I don't have access to bug 795899 so cannot comment there.
You need to log in before you can comment on or make changes to this bug.