use harfbuzz for all OpenType text shaping on OS X

RESOLVED FIXED in mozilla19

Status

()

Core
Layout: Text
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jfkthame, Assigned: jfkthame)

Tracking

unspecified
mozilla19
All
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Now that harfbuzz supports Indic shaping (at least as well as Apple's Core Text OpenType support, AFAICT), we should use the harfbuzz backend for all OpenType-based shaping on OS X, keeping the Core Text backend only for AAT fonts. This will improve the consistency of our shaping behavior across platforms, and reduce our exposure to potential issues in the "black-box" of Core Text.
Duplicate of this bug: 798782
(Assignee)

Comment 2

5 years ago
Created attachment 669135 [details] [diff] [review]
use harfbuzz for all OpenType font shaping under OS X.
Attachment #669135 - Flags: review?(jdaggett)
(Assignee)

Comment 3

5 years ago
Tryserver seems happy enough with this:
https://tbpl.mozilla.org/?tree=Try&rev=e0f45471d970

Updated

5 years ago
Attachment #669135 - Flags: review?(jdaggett) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/21b01c22ac9e
Assignee: nobody → jfkthame
Target Milestone: --- → mozilla19
https://hg.mozilla.org/mozilla-central/rev/21b01c22ac9e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Blocks: 803483

Updated

5 years ago
Blocks: 766452
(Assignee)

Updated

5 years ago
Depends on: 846617
(Assignee)

Updated

5 years ago
Depends on: 851495
You need to log in before you can comment on or make changes to this bug.