OpenType script support is no longer dependent on OS X version

RESOLVED FIXED in mozilla19

Status

()

Core
Graphics: Text
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: jfkthame, Assigned: jfkthame)

Tracking

unspecified
mozilla19
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Now that we're using harfbuzz for all scripts on OS X, we are no longer dependent on the OS X version to determine which scripts can or cannot be shaped using OpenType layout. So it's time to remove the version-checking from the cmap-masking code in MacOSFontEntry.
(Assignee)

Comment 1

6 years ago
Created attachment 673154 [details] [diff] [review]
patch, remove OS version field from the complex-scripts table
Attachment #673154 - Flags: review?(jdaggett)

Updated

6 years ago
Attachment #673154 - Flags: review?(jdaggett) → review+
(Assignee)

Comment 2

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/0e76a54aab6f
Depends on: 797402
Target Milestone: --- → mozilla19
(Assignee)

Comment 3

6 years ago
Also pushed https://hg.mozilla.org/integration/mozilla-inbound/rev/aa8edb7d1983 to remove the fails-if annotation from Indic-script reftests that now pass on all OS X versions.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 760379
https://hg.mozilla.org/mozilla-central/rev/0e76a54aab6f
https://hg.mozilla.org/mozilla-central/rev/aa8edb7d1983
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.