Gaia homescreen and everything.me don't seem to get along well

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Homescreen
RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: cjones, Unassigned)

Tracking

({dogfood})

Firefox Tracking Flags

(Not tracked)

Details

I hate filing these kinds of "bad stuff seems to happen frequently" kinds of bugs without specific STR, but while dogfooding when out and about tonight, I noticed the homescreen getting "stuck" quite a bit after I messed around with e.me.

An extreme case is bug 798700, but also at other times the homescreen would stop responding and the only way to get it back was to reboot the device.

I think this is one of the most severe dogfooding issues, since it won't be clear to users how to un-stuck the homescreen.
this seems a dupe of 798700. please re-open if that's not the case.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 798700
blocking-basecamp: ? → ---
It might be splitting hairs, but in bug 798700 the homescreen locked up *and* was rendered as a blank white screen.

I also see other lockups that don't result in a misrendered homescreen, just an unresponsive one.  They're probably the same underlying issue, but I'd like to verify them separately in case there are two separate bad things happening.
Status: RESOLVED → REOPENED
Depends on: 798700
Resolution: DUPLICATE → ---
lock up and misrendering of the homescreen, followed by unresponsiveness, + a reboot tends to be OOM issue.

Can you check your logcat while you're doing these steps to repro please?
(In reply to Naoki Hirata :nhirata from comment #3)
> lock up and misrendering of the homescreen, followed by unresponsiveness, +
> a reboot tends to be OOM issue.
> 

Based on what evidence?
similar experience in bug 796822.
having stated that... lessons learned on the need to dig deeper. ( bug 796773 )
Another way to diagnose possible OOMs is to open a terminal and run

$ watch -n 1 'adb shell b2g-procrank'

If you see the "USS" of one of the app processes go up near 100MB and then that process disappear from the process list (accompanied by some sort of visual crash in gaia), then you've almost certainly seen an OOM kill.
Oh sweet!  thanks for the tip!

Updated

5 years ago
Component: Gaia → Gaia::Homescreen
There is not really something that I can reproduce.
And, it looks like in recent pvt build
https://pvtbuilds.mozilla.org/pub/mozilla.org/b2g/nightly/
b2g18 branch looks pretty fine as for now.

Please reopen this if it still happens.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Keywords: qawanted
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.