[clock] Need final alarm sound and update their labels to human readable form

VERIFIED FIXED

Status

Firefox OS
Gaia
P1
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: akeybl, Assigned: rexboy)

Tracking

({late-l10n})

unspecified
late-l10n
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
When selecting a sound for a newly created alarm, the sounds themselves are filenames with underscores and aren't very human readable.
(Reporter)

Updated

6 years ago
Assignee: nobody → iliu
Blocking+, this is not localized and looks quite incomplete.

Ian, how can the l10n team localize the names of the alarms?
blocking-basecamp: ? → +
Priority: -- → P3
(In reply to Dietrich Ayala (:dietrich) from comment #1)
> Blocking+, this is not localized and looks quite incomplete.
> 
> Ian, how can the l10n team localize the names of the alarms?

Because of the media ringtones are not the final version.
I have highlight the issue with Patryk and Kaze before string frozen.
We use the file name to let UX review easily.
I will refine it when we receive final version of ringtone.
Duplicate: Bug 796250 - Clock APP needs the ringtone media.
The Clock app is string frozen, so once you get the final ringtone names, Ian, can you please add the 'late-l10n' keyword to this bug and attach a patch with the r/ flag set to me?  Thanks.
Assignee: iliu → padamczyk
(In reply to Staś Małolepszy :stas from comment #4)
> The Clock app is string frozen, so once you get the final ringtone names,
> Ian, can you please add the 'late-l10n' keyword to this bug and attach a
> patch with the r/ flag set to me?  Thanks.

Thanks for your reminder.
Ok, I will do it when we get the final ringtone names.

Comment 6

6 years ago
Also please convert the mp3 files to ogg. That we can play directly. Less trouble and more open.
(In reply to Andreas Gal :gal from comment #6)
> Also please convert the mp3 files to ogg. That we can play directly. Less
> trouble and more open.

Yes all the final files will be OGG. MP3 was just earlier to test on various devices.
Summary: [clock] alarm sound selections are not human readable, displayed as file names → [clock] Need final alarm sound and update their labels to human readable form
Patryk, please reassign to Ian once you give the file and the names use for the labels to him.
This bug is blocked by bug 800235 because Clock app will not be able to play new ogg ringtones correctly.
Depends on: 800235
(Reporter)

Updated

6 years ago
Duplicate of this bug: 798749
Correct the dependency. This bug is blocked by bug 802044 because Clock app will not be able to play new ogg ringtones correctly.

However, Patryk, you should still supply us with the new files so we can see if the files is affected by bug 802044 (or they *are* the files you are supplying?)
No longer depends on: 800235
Flags: needinfo?(padamczyk)

Updated

6 years ago
Priority: P3 → --
Priority: -- → P1
Added 48khz OGG files are requested. They worked for me on the device. 
https://github.com/mozilla-b2g/gaia/pull/6115
Flags: needinfo?(padamczyk)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(stas)
Resolution: --- → FIXED
Stas you can localize the alarm names now. Perhaps make a new bug?
(In reply to Patryk Adamczyk [:patryk] UX from comment #12)
> Added 48khz OGG files are requested. They worked for me on the device. 
> https://github.com/mozilla-b2g/gaia/pull/6115

\o/

Patryk, please be sure to have the bug number contained in the commit message. We have different policy regarding landing change than free-for-all now.
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) from comment #15)
> (In reply to Patryk Adamczyk [:patryk] UX from comment #12)
> > Added 48khz OGG files are requested. They worked for me on the device. 
> > https://github.com/mozilla-b2g/gaia/pull/6115
> 
> \o/
> 
> Patryk, please be sure to have the bug number contained in the commit
> message. We have different policy regarding landing change than free-for-all
> now.

Its there :)
(In reply to Patryk Adamczyk [:patryk] UX from comment #13)
> Stas you can localize the alarm names now. Perhaps make a new bug?

I think Rex could help to add these strings of alarm names for localization.
So, I assign the issue to him.
Assignee: padamczyk → rexboy
Status: RESOLVED → REOPENED
Flags: needinfo?(stas)
Keywords: late-l10n
Resolution: FIXED → ---
Created attachment 678252 [details]
Added L10n keys for alarm titles.

Added L10n keys for alarm titles.
Also corrected the filename of default ringtone.
Attachment #678252 - Flags: review?(stas)
Attachment #678252 - Flags: review?(iliu)
Comment on attachment 678252 [details]
Added L10n keys for alarm titles.

It works for me.
Thanks for Rex's help.
Attachment #678252 - Flags: review?(iliu) → review+
Merged:

https://github.com/mozilla-b2g/gaia/pull/6163

Thank you!
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Comment on attachment 678252 [details]
Added L10n keys for alarm titles.

Sorry I only get to this now.  A post-factum r+ on the string addition.
Attachment #678252 - Flags: review?(stas) → review+

Comment 22

6 years ago
Verified that the Alarm Clock sound files now have final easily-readable names. 
Tested on Build 20121231070201 on 12/31/12
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.