Last Comment Bug 799749 - Add back the Show Desktop Notifications menuitem for the Social API toolbar menu
: Add back the Show Desktop Notifications menuitem for the Social API toolbar menu
Status: VERIFIED FIXED
[Fx17]
: regression
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: 18 Branch
: All All
: -- normal (vote)
: Firefox 19
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
Mentors:
Depends on:
Blocks: 790112
  Show dependency treegraph
 
Reported: 2012-10-09 15:42 PDT by Jared Wein [:jaws] (please needinfo? me)
Modified: 2012-12-04 15:23 PST (History)
3 users (show)
jaws: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified
+
verified


Attachments
Patch (2.47 KB, patch)
2012-10-09 15:42 PDT, Jared Wein [:jaws] (please needinfo? me)
markh: review+
Details | Diff | Review
Patch for checkin (8.43 KB, patch)
2012-10-09 17:11 PDT, Jared Wein [:jaws] (please needinfo? me)
jaws: review+
gavin.sharp: approval‑mozilla‑aurora+
gavin.sharp: approval‑mozilla‑beta+
Details | Diff | Review

Description Jared Wein [:jaws] (please needinfo? me) 2012-10-09 15:42:03 PDT
Created attachment 669779 [details] [diff] [review]
Patch

The patch for bug 790112 accidentally removed the Show Desktop Notifications toolbar menuitem. This patch adds it back, along with a test to make sure this doesn't happen again.

This affects Firefox 17 and 18 as well, but the patch is minimal and doesn't introduce any strings. The strings weren't removed on accident, just the menuitem.
Comment 1 Mark Hammond [:markh] 2012-10-09 15:49:50 PDT
Comment on attachment 669779 [details] [diff] [review]
Patch

It would be even better if the test checked the menuitems did something :)
Comment 2 Jared Wein [:jaws] (please needinfo? me) 2012-10-09 17:11:43 PDT
Created attachment 669810 [details] [diff] [review]
Patch for checkin

Also fixed the toolbar icons in the other tests. Ok'd by Mark on IRC,
5:08 PM <jaws> markh: ok for me to fix the toolbar icons when i push the menuitem fix?
5:09 PM <markh> fine with me :)
5:10 PM <jaws> i mean the toolbar icons in the tests of course
5:10 PM <jaws> they're currently using 48x48 icons, which doesn't seem right

The tests don't check the "checked" state toggling due to bug 799761.
Comment 3 Jared Wein [:jaws] (please needinfo? me) 2012-10-09 17:15:16 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/88bb0e2f0373
Comment 4 Ed Morley [:emorley] 2012-10-11 07:08:23 PDT
https://hg.mozilla.org/mozilla-central/rev/88bb0e2f0373
Comment 6 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-12-04 15:23:06 PST
Verified fixed across all branches.

Note You need to log in before you can comment on or make changes to this bug.