Last Comment Bug 800614 - Require Python 2.6 to build the tree
: Require Python 2.6 to build the tree
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: mozilla19
Assigned To: Gregory Szorc [:gps]
:
Mentors:
Depends on: 803954
Blocks: 636155 724191 803808 803830 803834 812179 845620
  Show dependency treegraph
 
Reported: 2012-10-11 15:56 PDT by Gregory Szorc [:gps]
Modified: 2013-02-26 17:50 PST (History)
13 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Require Python 2.6 in configure, v1 (3.21 KB, patch)
2012-10-11 15:56 PDT, Gregory Szorc [:gps]
ted: review+
coop: feedback+
Details | Diff | Review

Description Gregory Szorc [:gps] 2012-10-11 15:56:17 PDT
Created attachment 670587 [details] [diff] [review]
Require Python 2.6 in configure, v1

We currently require Python 2.5+ <= 3 to build the tree. This patch bumps it up to Python 2.6+. I'd like to go all the way to Python 2.7, but that is more contentious. I think we should go to 2.6 first, see what breaks and pushback we get then try our luck at 2.7 somewhere down the road.

Bumping minimum Python has been discussed previously at https://groups.google.com/d/topic/mozilla.dev.platform/djN02O03APc/discussion. So, I think we have fulfilled our obligations for public discourse.

Ted gets technical review. Coop should sign off that all of RelEng's builders now run 2.6+ (I think they all now run 2.7).

Try at https://tbpl.mozilla.org/?tree=Try&rev=394b38df6220
Comment 1 Gregory Szorc [:gps] 2012-10-11 16:06:35 PDT
:wlach raised issues in #ateam about now potentially being a bad time because of B2G and aurora foo. I don't think it's a big issue as this only affects the builders, not test runners. Essentially, this only impacts things running configure.

There's a possibility something on m-c will break compatibility with 2.5 and will be backported to aurora. But, if all the aurora builders are running 2.6+, there should be no problem.
Comment 2 Mike Hommey [:glandium] 2012-10-11 16:26:49 PDT
(In reply to Gregory Szorc [:gps] from comment #1)
> There's a possibility something on m-c will break compatibility with 2.5 and
> will be backported to aurora.

Changing the default that configure requires won't change that if the builders are already on 2.7. We very much can have python scripts that only run on 2.7 in the tree with or without any change to configure.
Comment 3 Mike Hommey [:glandium] 2012-10-11 16:27:44 PDT
(In reply to Mike Hommey [:glandium] from comment #2)
> (In reply to Gregory Szorc [:gps] from comment #1)
> > There's a possibility something on m-c will break compatibility with 2.5 and
> > will be backported to aurora.
> 
> Changing the default that configure requires won't change that if the
> builders are already on 2.7. We very much can have python scripts that only
> run on 2.7 in the tree with or without any change to configure.

(and as a matter of fact, we already do, cf. bug 800557 comment 12)
Comment 4 Mike Hommey [:glandium] 2012-10-11 16:30:21 PDT
FWIW, I don't see a compelling reason not to go straight to 2.7. This would, at the very least, allow us to stop using simplejson to use OrderedDict.
Comment 5 Ted Mielczarek [:ted.mielczarek] 2012-10-11 16:54:37 PDT
Comment on attachment 670587 [details] [diff] [review]
Require Python 2.6 in configure, v1

Review of attachment 670587 [details] [diff] [review]:
-----------------------------------------------------------------

As long as this doesn't break our build farm I'm 100% behind this.

::: js/src/configure.in
@@ +1404,5 @@
>  dnl ========================================================
>  case "$host" in
>  *mingw*)
> +    # we need Python 2.6 on Windows
> +    PYTHON_VERSION=2.6

Looks like these lines can just be dropped now (could have previously, apparently, as well).
Comment 6 Gregory Szorc [:gps] 2012-10-11 17:51:21 PDT
Try build seems happy. So, I guess we are waiting on releng confirmation that all the builders are running 2.6+ and this can roll out!
Comment 7 Chris Cooper [:coop] 2012-10-19 11:09:31 PDT
Comment on attachment 670587 [details] [diff] [review]
Require Python 2.6 in configure, v1

Review of attachment 670587 [details] [diff] [review]:
-----------------------------------------------------------------

Builds haven't completed yet, but the new configure checks have passed on all platforms.
Comment 8 Gregory Szorc [:gps] 2012-10-19 11:14:19 PDT
Well, then:

https://hg.mozilla.org/integration/mozilla-inbound/rev/09dc2dc1fc9f
Comment 9 Chris Cooper [:coop] 2012-10-19 14:10:57 PDT
(In reply to Chris Cooper [:coop] from comment #7)
> Builds haven't completed yet, but the new configure checks have passed on
> all platforms.

The builds all completed successfully, I would add.
Comment 10 Ryan VanderMeulen [:RyanVM] 2012-10-19 19:05:04 PDT
https://hg.mozilla.org/mozilla-central/rev/09dc2dc1fc9f
Comment 11 Gregory Szorc [:gps] 2012-10-21 12:27:11 PDT
This needs to be backed out because it broke l10n builds. Trees are closed. I may not be around when they are reopened. If someone beats me to it, please back it out.

  $ hg backout -r 09dc2dc1fc9f -m 'Backout bug 800613 (09dc2dc1fc9f) due to l10n breakage'
Comment 12 Justin Wood (:Callek) 2012-10-21 21:46:58 PDT
Check-in: http://hg.mozilla.org/integration/mozilla-inbound/rev/8d9cff7e5c30 - Justin Wood - Merge backout of Bug 800613
http://hg.mozilla.org/integration/mozilla-inbound/rev/c82226df75bb - Justin Wood - Backout bug 800613 (09dc2dc1fc9f) due to l10n breakage
Comment 13 Gregory Szorc [:gps] 2012-10-22 12:28:00 PDT
Re-landed: https://hg.mozilla.org/integration/mozilla-inbound/rev/1621bf085a37 after Aki's confirmed that Windows l10n builders are now running new Python in bug 803954.

Patch was slightly different because bug 802210 changed a lot of this code. End result should be the same.
Comment 14 Ryan VanderMeulen [:RyanVM] 2012-10-22 19:01:07 PDT
https://hg.mozilla.org/mozilla-central/rev/1621bf085a37

Note You need to log in before you can comment on or make changes to this bug.