Please enable PGO on Win64 as bug #795594 is fixed now

VERIFIED FIXED

Status

Release Engineering
General Automation
--
major
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: Virtual, Assigned: Virtual)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Please enable PGO on Win64 as bug #795594 is fixed now.
Blocks: 795643
Depends on: 795594
Blocks: 795748
No longer blocks: 795643
Created attachment 671192 [details] [diff] [review]
[buildbot-configs] enable Win64 PGO

Based on patch from bug #795748
Attachment #671192 - Flags: review?
Attachment #671192 - Flags: checked-in?
Attachment #671192 - Flags: review? → review?(bugspam.Callek)

Updated

5 years ago
Assignee: nobody → BernesB
Comment on attachment 671192 [details] [diff] [review]
[buildbot-configs] enable Win64 PGO

Review of attachment 671192 [details] [diff] [review]:
-----------------------------------------------------------------

First off, thanks for this (first) patch!

The change looks correct in that it does what this bug wants to do (enable PGO on win64 on every tree that has PGO)

The concern I have, and why I'm f?-ing to :roc is that it looks like in order to have successful win64 PGO on aurora we need Bug 795594 approved/landed there. Of which I have no idea on the risk on that bug, so would like him and relman to make that call.

If we can't enable PGO properly on aurora due to risk in that patch, we'll need to tweak what we land to disable it on the 18 train.
Attachment #671192 - Flags: review?(bugspam.Callek)
Attachment #671192 - Flags: review+
Attachment #671192 - Flags: feedback?(roc)
Thank you very much!
Firstly I'm not programmer, but this patch looks very easy to do, so I decided that I will create it to get PGO Win64 builds back and lift some burden from you guys. I only need to modify the patch from bug #795748. The first part of patch was only reverting a made changes and the second part of patch was deleted, because it probably only added info about on which platform we build PGO build, so we won't to get that reverted as I deduce and understand it correctly.
Comment on attachment 671192 [details] [diff] [review]
[buildbot-configs] enable Win64 PGO

Review of attachment 671192 [details] [diff] [review]:
-----------------------------------------------------------------

We may as well get the bug 795594 patch on Aurora.
Attachment #671192 - Flags: feedback?(roc) → feedback+
(In reply to Virtual_ManPL [:Virtual] from comment #3)
> ...  I only need to modify the patch from bug #795748. The
> first part of patch was only reverting a made changes and the second part of
> patch was deleted, because it probably only added info about on which
> platform we build PGO build, so we won't to get that reverted as I deduce
> and understand it correctly.

We should revert that second hunk too, which was
 +BRANCHES['try']['pgo_platforms'] = ('linux', 'linux64', 'win32', 'win64')
in config.py. We'll get that from the default anyway (the first hunk), and leaving the line in is likely to cause confusion later (eg we change the default again, everyone goes 'huh?? why has try got this line here').
Created attachment 671268 [details] [diff] [review]
[buildbot-configs] enable Win64 PGO v2 (completly undo patch from bug #795748)

Corrected patch as Nick Thomas suggested.
Attachment #671192 - Attachment is obsolete: true
Attachment #671192 - Flags: checked-in?
Attachment #671268 - Flags: review?(bugspam.Callek)

Updated

5 years ago
Attachment #671268 - Flags: review?(bugspam.Callek) → review+
FYI - Patch for bug #795594 was also pushed to aurora ( https://bugzilla.mozilla.org/show_bug.cgi?id=795594#c39 ) and landed there ( https://bugzilla.mozilla.org/show_bug.cgi?id=795594#c40 ).

Comment 8

5 years ago
check in?
Attachment #671268 - Flags: feedback?(roc)
Attachment #671268 - Flags: feedback?(roc) → feedback+
To check all is well I've pushed to try
  https://tbpl.mozilla.org/?tree=Try&rev=4b82c4f065ff
Sometimes the RelEng infra differs developer's machines so this is worth checking prior to deployment.

If that's green and someone verifies the build starts OK then the next step is to land the change in buildbot-configs on the default branch. Then it'll get picked up by the next code deployment to the buildbot masters.

Updated

5 years ago
Status: UNCONFIRMED → ASSIGNED
Component: Release Engineering → Release Engineering: Automation (General)
Ever confirmed: true
QA Contact: catlee
Builds are in http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/nthomas@mozilla.com-4b82c4f065ff/try-win64/. Please test the zip/installer out.
LGTM


Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:19.0) Gecko/19.0 Firefox/19.0
buildID: 20121018183205

Source
Built from http://hg.mozilla.org/try/rev/4b82c4f065ff

Comment 12

5 years ago
(In reply to Nick Thomas [:nthomas] from comment #10)
> Builds are in
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/nthomas@mozilla.
> com-4b82c4f065ff/try-win64/. Please test the zip/installer out.

Works fine for me.

Comment 13

5 years ago
What's the progress on this right now? It's been a while...
You can push this patch to the 'default' branch of buildbot-configs, and it will get deployed sometime this week.

Please include this bug number and r=Callek in your commit message.
I will be glad if someone with privileges can push this patch ;)
Comment on attachment 671268 [details] [diff] [review]
[buildbot-configs] enable Win64 PGO v2 (completly undo patch from bug #795748)

http://hg.mozilla.org/build/buildbot-configs/rev/b0be95c1e5d1
Attachment #671268 - Flags: checked-in+
In production.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Thank you very much! :)
Status: RESOLVED → VERIFIED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.