Closed Bug 803518 Opened 7 years ago Closed 7 years ago

Garbage of context menu on Edit Bookmarks Panel

Categories

(Core :: Widget: Win32, defect)

17 Branch
x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox17 - ---

People

(Reporter: alice0775, Assigned: tnikkel)

References

Details

(Keywords: regression)

Attachments

(1 file)

Build Identifier:
http://hg.mozilla.org/releases/mozilla-beta/rev/2ba4becf6e35
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20121017073013

Steps to reproduce:
1. Make sure Windows Visual Style is "Aero Basic" or "Windows Classic"
   Disabled "Show shadow under windows" in the "performance options" of "visual effects" 
2. Start Firefox
3. Bookmarks This Page (Ctrl+D)
4. Right click on Tags Field
5. Click on Name Field

Actual results:
Garbage of context menu is left

Expected results:
Should clean up


Regression window
Good:
http://hg.mozilla.org/releases/mozilla-aurora/rev/3440e0b0cdb3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120925042009
Bad:
http://hg.mozilla.org/releases/mozilla-aurora/rev/f946a4984ba9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120926042010
Pushlog:
http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=3440e0b0cdb3&tochange=f946a4984ba9
Attached image screenshot
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 802456
I think this is not a duplocation because the regression winddow is completely difference.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
This is interesting, I wonder what in that range caused this. Not immediately obvious.
Corrected Regression window
Good:
http://hg.mozilla.org/releases/mozilla-aurora/rev/50e5a53ed557
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120924042009
Bad:
http://hg.mozilla.org/releases/mozilla-aurora/rev/3440e0b0cdb3
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120925042009
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=6694b77fb670&tochange=2657b58d787c
Blocks: 789482
Keywords: regression
(In reply to Timothy Nikkel (:tn) from comment #4)
> This is interesting, I wonder what in that range caused this. Not
> immediately obvious.

Yes , the range of ccomment#0 is wrong,
However,the range of  comment #5 is right,
And this is regression of bug 789482.
Wonderful, thank you, that is very helpful.
Does it still happen in a build with bug 802316? (not yet in the latest nightly)
(In reply to Timothy Nikkel (:tn) from comment #8)
> Does it still happen in a build with bug 802316? (not yet in the latest
> nightly)

This only happen in Firefox 17.0beta
This problem does not happen in Aurora18.0a2 and Nightly19.0a1.
(In reply to Alice0775 White from comment #9)
> This only happen in Firefox 17.0beta
> This problem does not happen in Aurora18.0a2 and Nightly19.0a1.

Oh, then do we know what fixed it? Maybe we can uplift that or something.
Bug 793065
This seemed to be fixed by Bug 793065 or Bug 610713

Fixed window(m-c)
Bad:
http://hg.mozilla.org/mozilla-central/rev/83d38854c21e
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121007121533
Fixed:
http://hg.mozilla.org/mozilla-central/rev/24cf40690042
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121008010834
Fixed pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=83d38854c21e&tochange=24cf40690042


Fixed window(m-c)
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/65b95ed309b9
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121007175634
Fixed:
http://hg.mozilla.org/integration/mozilla-inbound/rev/7c119b50e7aa
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121007183935
Fixed pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=65b95ed309b9&tochange=7c119b50e7aa


(pls ignore comment #11)
Assignee: nobody → tnikkel
The patch in bug 802456 should fix this.
Depends on: 802456
Should be fixed by bug 802456 now. Please reopen if not.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
we're already tracking 802456, untracking here.
You need to log in before you can comment on or make changes to this bug.