The default bug view has changed. See this FAQ.

filterHeader.label label in filterListDialog no longer wraps after bug 450302

RESOLVED FIXED in Thunderbird 19.0

Status

Thunderbird
Filters
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: aceman, Assigned: aceman)

Tracking

({polish})

17 Branch
Thunderbird 19.0
polish
Bug Flags:
in-testsuite -

Thunderbird Tracking Flags

(thunderbird17 fixed, thunderbird18 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

1001 bytes, patch
Magnus Melin
: review+
aceman
: ui-review+
Details | Diff | Splinter Review
(Assignee)

Description

5 years ago
In bug 450302 this change was made to the label containing &filterHeader.label; :
-        <label control="filterTree">&filterHeader.label;</label>
+        <hbox>
+          <label id="filterListLabel" control="filterList" value="&filterHeader.label;" crop="end" flex="1"></label>
+          <label id="countBox"/>
+        </hbox>

Thus, it no longer wraps if the dialog is too small. That is also exaggerated by the fact that the countBox label occupies the same grid cell and may force the filterHeader.label to be cropped if there are many filters (i.e. the countbox label has a long string).
(Assignee)

Comment 1

5 years ago
Created attachment 673638 [details] [diff] [review]
patch
Attachment #673638 - Flags: ui-review?(bwinton)
Attachment #673638 - Flags: feedback?(axelg)
(Assignee)

Comment 2

5 years ago
This may have a bigger impact on languages that have that string longer than the en-US locale.
Severity: minor → normal
Status: NEW → ASSIGNED
Version: unspecified → 17
Comment on attachment 673638 [details] [diff] [review]
patch

I'm going to say ui-r-, because the current patch pushes the "3 items" out past the edge of the list, as https://dl.dropbox.com/u/2301433/Screenshots/ItemsShown.png shows.  (It should be where the "0 items" is, because it's the number of items in the list, not the number of buttons… ;)

So ui-r-, but feel free to give it a ui-r=me with that fixed.

Thanks,
Blake.
Attachment #673638 - Flags: ui-review?(bwinton) → ui-review-
(Assignee)

Comment 4

5 years ago
Created attachment 673993 [details] [diff] [review]
patch v2

OK, fixed that.
Attachment #673638 - Attachment is obsolete: true
Attachment #673638 - Flags: feedback?(axelg)
Attachment #673993 - Flags: ui-review+
Attachment #673993 - Flags: review?(mkmelin+mozilla)

Comment 5

5 years ago
Comment on attachment 673993 [details] [diff] [review]
patch v2

Review of attachment 673993 [details] [diff] [review]:
-----------------------------------------------------------------

r=mkmelin
Attachment #673993 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Comment 6

5 years ago
Archaeopteryx do you see this as a problem in any locale you can look at? Should it be nominated for TB17?
Flags: needinfo?(archaeopteryx)
MXR shows the following translations (but don't trust mxr being up to date, see bug 803810):
http://mxr.mozilla.org/l10n-mozilla-aurora/search?string=filterHeader.label

Longest translation:
/nso/mail/chrome/messenger/FilterListDialog.dtd (View Hg log or Hg annotations)

    line 18 -- <!ENTITY filterHeader.label "Difilthara tše kgonagaditšwego di sepetšwa ka tsela ya othomethiki ka tatelano yeo e laetšwago ka fase.">

Gets shortened at: "[...] othomethiki..."

So maybe every fifth translation (I didn't count) translation doesn't show this by default. If you care about polish bugs, uplifting an idea is an option and makes localizers happy. If you don't want to change beta, it's in a resizeable dialog, so the user can work around this.
Flags: needinfo?(archaeopteryx)
(Assignee)

Comment 8

5 years ago
I think about nominating only because this got broken in TB17, it wrapped fine before. So if we fix it in TB17, it will never get exposed. If we do not fix it in 17, it will be an unnecessary regression until the next release a year after that.
https://hg.mozilla.org/comm-central/rev/451f5e07043e
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 19.0
(In reply to :aceman from comment #8)
> I think about nominating only because this got broken in TB17, it wrapped
> fine before. So if we fix it in TB17, it will never get exposed. If we do
> not fix it in 17, it will be an unnecessary regression until the next
> release a year after that.

That's a very good reason for nominating.
(Assignee)

Comment 11

5 years ago
Comment on attachment 673993 [details] [diff] [review]
patch v2

[Approval Request Comment]
Regression caused by (bug #): bug 450302
User impact if declined: comment 8
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky): Should be none.
Attachment #673993 - Flags: approval-comm-beta?
Attachment #673993 - Flags: approval-comm-aurora?
Attachment #673993 - Flags: approval-comm-beta?
Attachment #673993 - Flags: approval-comm-beta+
Attachment #673993 - Flags: approval-comm-aurora?
Attachment #673993 - Flags: approval-comm-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/f55fcf3d913f
https://hg.mozilla.org/releases/comm-beta/rev/bc4161c7ee5c
status-thunderbird17: --- → fixed
status-thunderbird18: --- → fixed
You need to log in before you can comment on or make changes to this bug.