Last Comment Bug 804235 - move and remove social toolbarbutton
: move and remove social toolbarbutton
Status: RESOLVED DUPLICATE of bug 935640
[1.5]
: uiwanted
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Jennifer Morrow [:Boriss] (UX)
:
Mentors:
Depends on:
Blocks: 804283 811112 940214
  Show dependency treegraph
 
Reported: 2012-10-22 11:07 PDT by Jonathan Protzenko [:protz]
Modified: 2013-11-22 09:00 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Jonathan Protzenko [:protz] 2012-10-22 11:07:43 PDT
This on Aurora. I just gave the Social API a try, and I can't find a way to remove the Facebook buttons that were added to my toolbar. Right-clicking and showing the customize window, dragging these buttons into the window (normal procedure to remove them) doesn't work. The Facebook site does not have any hint as to how to undo the procedure, and the various announcements don't seem to list a page that would hold the solution.

Thanks,

jonathan
Comment 1 Jonathan Protzenko [:protz] 2012-10-22 11:19:52 PDT
Also, hitting "restore default set" does not remove the various Facebook buttons.
Comment 2 Jonathan Protzenko [:protz] 2012-10-22 12:38:23 PDT
Per discussion with Shane, I just failed to figure out that there was a menu item under Tools that would allow me to disable it (I'm running with the menu bar disabled). However, I'm leaving this bug open, as the usual way of removing items from a toolbar should work there.
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-25 11:39:40 PDT

*** This bug has been marked as a duplicate of bug 803344 ***
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-25 11:46:14 PDT
Ah, I didn't notice your summary change. Disabling the functionality when you remove the toolbar button might be a bit confusing, since you might want the sidebar but not the button. Somehow making the toolbar button customizable is something worth investigating, though.
Comment 5 Jonathan Protzenko [:protz] 2012-10-25 11:57:24 PDT
Well I think it should perform the disabling. At least, it should do something; right now, it just does nothing, which is very confusing. What do you think?
Comment 6 Underpass 2012-11-04 01:25:30 PDT
IMHO it should be possible to move the group of buttons elsewhere in the Toobar (I would be even happy to be able to drag then in the Addons Bar).
Please tell me if I have to open a different bug for this.

Thanks.
Comment 7 Shane Caraveo (:mixedpuppy) 2012-12-28 18:28:56 PST
Lets get some ux input here.
Comment 8 Mike Conley (:mconley) - (needinfo me!) 2013-11-22 07:03:42 PST
From the looks of things, this is being taken care of in bug 940820, so marking this as a dupe.

If I'm wrong about this, please re-open.

*** This bug has been marked as a duplicate of bug 940820 ***
Comment 9 Shane Caraveo (:mixedpuppy) 2013-11-22 09:00:50 PST
actually, bug 935640 removes the toolbar button discussed in this bug and is what will resolve this issue.

*** This bug has been marked as a duplicate of bug 935640 ***

Note You need to log in before you can comment on or make changes to this bug.