Implement touch friendly spell correction

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
7 years ago
4 months ago

People

(Reporter: jimm, Unassigned)

Tracking

({parity-ie})

Details

(Whiteboard: [story])

(Reporter)

Description

7 years ago
Spell correction should use touch friendly context menus to display suggestions when entering text into text areas and inputs.
(Reporter)

Updated

7 years ago
Blocks: 801144
Whiteboard: parity-ie, metro-mvp → parity-ie, metro-mvp, LOE:?
Whiteboard: parity-ie, metro-mvp, LOE:? → [parity-ie][metro-mvp][LOE:?]
(Reporter)

Updated

7 years ago
Whiteboard: [parity-ie][metro-mvp][LOE:?] → [parity-ie][metro-mvp-]
Blocks: 831982
No longer blocks: 801144
Summary: Implement touch friendly spell correction → Work - Implement touch friendly spell correction
Whiteboard: [parity-ie][metro-mvp-] → feature=work [parity-ie]
Blocks: metrov1onhold
No longer blocks: 831982
Summary: Work - Implement touch friendly spell correction → Story - Implement touch friendly spell correction
Whiteboard: feature=work [parity-ie] → [parity-ie] feature=story c=tbd u=tbd p=tbd
Blocks: metrov1planning
No longer blocks: metrov1onhold
Blocks: metrobacklog
No longer blocks: metrov1planning
(Reporter)

Updated

6 years ago
Duplicate of this bug: 896488
(Reporter)

Updated

6 years ago
Duplicate of this bug: 897605
I know this is marked for V2, but I personally think having this in V1 would be very beneficial. "Spell Check" is a pretty commonly used feature in all instances (facebook, twitter, linkedin, community forums, commenting on blogs, IM Chats etc..)

I think the user experience will diminish a bit if a user has to switch over to the desktop environment to double check if something is spelled correctly (or she/he can do a Google search to use the "did you mean this" feature but most basic users are not that advanced)
I think basic spell checking used to work, and I think this was to make it more touch friendly. Jim do you recall?
(Reporter)

Comment 5

5 years ago
The red underline feature should be working. If not, I think it's a bug.
Flags: needinfo?(kamiljoz)
Yup, basic spell check is working and will highlight a word red if it's spelled incorrectly. What I meant in comment #3 is adding the other part of the feature so users can fix the spelling on the spot rather than using another source to find the correct spelling.

Let's say a user is using Facebook/Twitter/Email and decides to post a status/email someone. He/She writes their status/email and notices that there's a few words underlined red. The user doesn't know how to spell some of those word so rather than just right clicking on the word and having a few options, the user will have to figure out another way to find the correct spelling which is really inconvenient.
Flags: needinfo?(kamiljoz)
Summary: Story - Implement touch friendly spell correction → Implement touch friendly spell correction
Whiteboard: [parity-ie] feature=story c=tbd u=tbd p=tbd → [parity-ie] [story]
(Reporter)

Updated

5 years ago
Component: Input → Metro Operations
Product: Firefox for Metro → Tracking
Version: Trunk → ---
OS: Windows 8 Metro → Windows 8.1
Mass bug change to replace various 'parity' whiteboard flags with the new canonical keywords. (See bug 1443764 comment 13.)
Keywords: parity-ie
Whiteboard: [parity-ie] [story] → [story]
We never shipped the metro support, closing!
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WONTFIX

Updated

4 months ago
Product: Tracking → Tracking Graveyard
You need to log in before you can comment on or make changes to this bug.