Regression: Invalidation issues with about:apps and add-ons-manager

VERIFIED FIXED in Firefox 20

Status

()

defect
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: aaronmt, Assigned: cwiiis)

Tracking

({regression, reproducible})

unspecified
Firefox 22
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox18 affected, firefox19 affected, firefox20 verified, firefox21 verified, firefox22 verified, fennec20+)

Details

Attachments

(11 attachments)

Reporter

Description

7 years ago
See screenshot.

STR (new profile)

1) Visit about:apps
Reporter

Comment 1

7 years ago
I think this is a drawing issue actually. If I pinch in, I see the container expand. In console I see

D/GeckoLayerClient( 2307): Aborting draw due to resolution change
E/GeckoConsole( 2307): [JavaScript Error: "TypeError: this._mLastPinchPoint is undefined" {file: "chrome://browser/content/browser.js" line: 3757}]
Reporter

Updated

7 years ago
Component: Web Apps → Graphics, Panning and Zooming
QA Contact: aaron.train
Keywords: regression
Reporter

Comment 2

7 years ago
Tiles regression?
Reporter

Updated

7 years ago
Assignee: nobody → chrislord.net
When looking at this Chris you could try disabling the tile store to rule out that the tile is getting harvested incorrectly.
I can't reproduce this with a current m-c tip build:
changeset:   112302:358c9830d166
tag:         tip
parent:      112283:50cd5f7339f6
parent:      112301:60c78a559a84
user:        Ed Morley <emorley@mozilla.com>
date:        Mon Nov 05 15:23:36 2012 +0000
summary:     Merge last PGO-green changeset of mozilla-inbound to mozilla-central

Aaron can you confirm that the bug is still there? Maybe it's specific to some dimensions?
Reporter

Comment 6

7 years ago
I can still reproduce this on Nightly (11/05), a slight pinch-zoom in reveals it.

--
Samsung Galaxy Nexus (Android 4.1.2)
Samsung Galaxy Note II (Android 4.1.1)
Assignee

Comment 7

7 years ago
Not pleased with this patch, but it seems necessary and fixes a lot of invalidation issues for me on my patch queue. Not 100% sure this will fix this, so I could really do with some QA help here.
Attachment #679213 - Flags: review?(bgirard)
Assignee

Updated

7 years ago
Duplicate of this bug: 808562
Comment on attachment 679213 [details] [diff] [review]
Fix incorrect progressive draw cancelling

Review of attachment 679213 [details] [diff] [review]:
-----------------------------------------------------------------

I have no problem prevent a painting abort if we're not sure. Aborting should only be done if we're sure.
Attachment #679213 - Flags: review?(bgirard) → review+
Assignee

Comment 10

7 years ago
Pushed to inbound: https://hg.mozilla.org/integration/mozilla-inbound/rev/119b681073b4

Not marking this as leave-open, but please reopen if this bug persists. I don't expect it will, but you never know...
Status: NEW → ASSIGNED
Reporter

Comment 11

7 years ago
Nice. I'll tour Nightly with this fix looking at some of issues I saw on tomorrow's m-c build.
https://hg.mozilla.org/mozilla-central/rev/119b681073b4
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Reporter

Comment 13

7 years ago
This still isn't fixed for me on my Galaxy Nexus using the 11/08 Nightly. I still see what you get in the two screenshots attached.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I'm going to investigate and confirm/reject that this bug is caused by aborting.
I can reproduce this bug by rotating the phone.
Reporter

Comment 16

7 years ago
Another way to reproduce; install Ad-Block Plus, head to the Add-ons Manager and expand it's options and rotate the browser. The entire Add-ons Manager becomes white.
Reporter

Updated

7 years ago
Keywords: reproducible
Summary: Regression: Empty about:apps → Regression: Empty about:apps and invalidation issues in add-ons-manager
Reporter

Updated

7 years ago
Summary: Regression: Empty about:apps and invalidation issues in add-ons-manager → Regression: Invalidation issues with about:apps and add-ons-manager
I was able to confirm today that it's not caused by progressive painting. I tried to run mozregression but I'm missing python modules and installed a bunch of stuff with no success.

It would be a great help if we can find the regression window.
Reporter

Updated

7 years ago
tracking-fennec: --- → ?
Reporter

Updated

7 years ago
Status: REOPENED → ASSIGNED
Reporter

Updated

7 years ago
QA Contact: aaron.train
Reporter

Updated

7 years ago
Duplicate of this bug: 811304
Reporter

Comment 19

7 years ago
Add-ons Manager in 11/14 (left is what I see going in, and right is what I get after a pinch zoom, or a rotation)
tracking-fennec: ? → 19+
There is the same regression range as for bug 795438:

The last Good build: 10/25

Bad build: 10/26

The exact regression-range is: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8a6b6b5f3e55&tochange=044f1370c2b8
Since it's the same issue as bug 795438 marking as blocking bug 783368.
Blocks: 783368
Reporter

Comment 22

7 years ago
Marking as Aurora/Nightly affected now.
Reporter

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → WORKSFORME

Comment 23

7 years ago
Posted image screenshots
This is reproducible on Firefox 18 Beta 5 both on phones and tablet.

Devices: Galaxy Nexus (4.1.1) and Asus EEE Transformers (4.0.3)

Comment 24

7 years ago
(In reply to Ioana Chiorean from comment #23)
> Created attachment 694300 [details]
> screenshots
> 
> This is reproducible on Firefox 18 Beta 5 both on phones and tablet.
> 
> Devices: Galaxy Nexus (4.1.1) and Asus EEE Transformers (4.0.3)

Due to this, I will reopen the bug . Set to flag for 18 to WONTFIX if will not be pushed to beta too. 

Note: Not reproducible on Nightly (2012-12-19) nor on Aurora (2012-12-19)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
qawanted to retest on trunk
Keywords: qawanted
Reporter

Comment 26

7 years ago
(In reply to Brad Lassey [:blassey] from comment #25)
> qawanted to retest on trunk

Look above. Fixed on trunk/aurora, broken on beta.
Keywords: qawanted
Reporter

Comment 27

7 years ago
This is still an issue for some apparently; dupe (bug 803073). Can we get a check here as this is tracking For Beta (mozilla-19).
Reporter

Updated

7 years ago
Duplicate of this bug: 803073

Comment 29

7 years ago
Hi,

is there an update to this?
Can we help with testing?
Reporter

Comment 30

7 years ago
I need to check if this is still an issue.
Addin QA wanted to flag the re-testing Aaron mentions above.
Keywords: qawanted

Comment 32

6 years ago
Posted image Screenshot

Comment 33

6 years ago
This is an issue in all tabs not just about:addons, see screenshot

Comment 34

6 years ago
I'm not able to reproduce this issue on Firefox 19 Beta 5 on Asus EEE Transformers (4.0.3) 
But this issue occurs on Samsung Galaxy S2, on latest nightly(2013-02-08), see screenshot

Comment 35

6 years ago
This is still reproducing badly

Comment 36

6 years ago
Issues on Firefox 20 Beta 1 on Acer Iconia( Android  3.2.1), see screenshot
recent comments shows its reproducing on Fx20 beta 1 builds.
Keywords: qawanted
Reporter

Comment 38

6 years ago
Some of this might have flared up due to bug 842389 which will be backed out and requiring a re-spin of Firefox 20 Beta 1

Comment 39

6 years ago
Hi,

this problem persists on my device.
Can anyone replicate?
I think this was fixed by bug 850396. Can we retest the current beta?
tracking-fennec: 19+ → 20+
Reporter

Comment 41

6 years ago
Re-tested my original devices as filed, (Note/Galaxy Nexus) w/current Fx20; this seems fixed for me. Andreea, can you check your devices as you tested in this bug?
Flags: needinfo?(andreea.pod)
Assignee

Comment 42

6 years ago
I've noticed that sometimes the image can take a while to load, but I've not noticed any invalidation issues on this page.

Comment 43

6 years ago
Using build Firefox 20 beta 6 on Acer Iconia A500 and Galaxy SII I am not able to reproduce the issues. Seems fixed.
Flags: needinfo?(andreea.pod)
Reporter

Comment 44

6 years ago
Marking fixed via bug 850396
Status: REOPENED → RESOLVED
Closed: 7 years ago6 years ago
Resolution: --- → FIXED

Comment 45

6 years ago
Posted image Screenshot

Comment 46

6 years ago
Hi,

same issue on my device (Galaxy Note)
See attached screenshot.

Can I provide any useful info to help identify the problem?
Assignee

Comment 47

6 years ago
(In reply to bug.zilla from comment #46)
> Hi,
> 
> same issue on my device (Galaxy Note)
> See attached screenshot.
> 
> Can I provide any useful info to help identify the problem?

This is more likely to be bug 852526, which is fixed - try again after tomorrow's Nightly build :)

Updated

6 years ago
Depends on: 850396
Target Milestone: Firefox 19 → Firefox 22

Comment 48

6 years ago
I'm still able to reproduce this on Firefox for Android 20 Beta 6(2013-03-21) on Samsung Galaxy S II (Android 4.0.3). I will test it next week on Firefox for Android 20 Beta 7.

Comment 49

6 years ago
Hi,

still an issue on my Galaxy Note.
Affects all tabs, not just about:addons.
Assignee

Comment 50

6 years ago
(In reply to bug.zilla from comment #49)
> Hi,
> 
> still an issue on my Galaxy Note.
> Affects all tabs, not just about:addons.

Multiple different bugs have been conflated here, but I don't believe there to be any major issues here anymore. If you have problems, please open a new bug with a detailed description and steps to reproduce. I think there are people on the team who have access to Galaxy Notes, so we should be able to help you. Thanks!
I don't see this issue anymore on Firefox for Android 23.0a1(2013-04-09), Firefox for Android 22.0a2(2013-04-09) and Firefox for Android 21.0b1 using Samsung Galaxy Note (Android 4.0.4).
You need to log in before you can comment on or make changes to this bug.