Closed Bug 807631 Opened 7 years ago Closed 7 years ago

Receiving multi-part SMS doesn't work.

Categories

(Core :: DOM: Device Interfaces, defect, P1, critical)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED FIXED
mozilla19
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: armenzg, Assigned: gwagner)

References

Details

(4 keywords, Whiteboard: [dogfooding-blocker])

Attachments

(1 file)

Two days ago I missed 4-6 test messages and today I just missed one.

I have an app called Rogers One that allows me to receive text messages through my computer regardless of the state of my phone.
update.boot2gecko.org was down this morning. Could it be related?
this should be fixed by bug 807463.  update to a > 11-1 stable build to reconfirm.
Status: NEW → RESOLVED
blocking-basecamp: ? → ---
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 807463
This is not related from reading the bug.
With the build of 10-24 I have NOT receiving text messages as times.

If you want I can re-open every time I hit it.

Does someone know who the SMS expert is? I would like to know if there is a way to debug this on my side.

I know that the phone was receiving something because I could hear it cause noise on the speakers of my computer.

In other words, this is an intermittent orange. Things like this was what the LG phone of my wife do (miss text messages) and made me get her another one.
If our phones do the same in the long term people might want to move on.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I also noticed this during testing for bug 807463 and blamed it on ATT because last week I received a few of my test messages 3 days later. 

mrbkap was working on a debug flag for RIL that can be enabled but I don't know if the setting made it to the stable builds yet.

Let's leave this bug open and try to get some more information here.
Ok I can confirm this bug now. I sent multiple SMS to my unagi and I never received messages.

Afterwards I put the SIM in my android phone and after sending a new SMS I reveived my 10 pending messages.

The first SMS that didn't go through was an overlong SMS that was probably divided into 2 messages.
It seems that after not receiving such an overlong message you can never receive messages again.
Severity: normal → critical
blocking-basecamp: --- → ?
Component: Gaia → General
Takes out core phone functionality, can't be used as a primary phone after this.
Blocks: 807908
blocking-basecamp: ? → +
Whiteboard: [dogfooding-blocker]
Blocks: 775997
The debug output when the message doesn't go through:


I/Gecko   (  106): RIL Worker: Received 688 bytes.
I/Gecko   (  106): RIL Worker: Already read 0
I/Gecko   (  106): RIL Worker: New incoming parcel of size 684
I/Gecko   (  106): RIL Worker: Parcel (size 684): 1,0,0,0,235,3,0,0,78,1,0,0,48,0,55,0,57,0,49,0,50,0,49,0,56,0,48,0,57,0,53,0,56,0,55,0,50,0,57,0,70,0,53,0,52,0,52,0,48,0,66,0,57,0,49,0,54,0,49,0,48,0,53,0,54,0,56,0,57,0,50,0,53,0,49,0,70,0,52,0,48,0,48,0,48,0,48,0,50,0,49,0,49,0,49,0,50,0,48,0,50,0,49,0,50,0,49,0,56,0,51,0,56,0,65,0,65,0,48,0,48,0,53,0,48,0,48,0,48,0,51,0,48,0,49,0,48,0,50,0,48,0,49,0,56,0,50,0,54,0,54,0,66,0,52,0,49,0,65,0,54,0,68,0,51,0,69,0,65,0,66,0,69,0,66,0,55,0,53,0,70,0,65,0,49,0,57,0,55,0,68,0,65,0,69,0,68,0,55,0,69,0,57,0,69,0,53,0,55,0,66,0,70,0,67,0,50,0,69,0,65,0,70,0,65,0,55,0,68,0,49,0,69,0,54,0,66,0,51,0,53,0,65,0,55,0,68,0,50,0,54,0,57,0,70,0,68,0,49,0,54,0,65,0,66,0,65,0,57,0,57,0,56,0,67,0,52,0,54,0,68,0,51,0,67,0,68,0,54,0,56,0,55,0,52,0,53,0,68,0,48,0,67,0,66,0,50,0,65,0,66,0,68,0,53,0,50,0,48,0,51,0,66,0,51,0,65,0,52,0,70,0,65,0,70,0,69,0,55,0,67,0,66,0,70,0,51,0,55,0,51,0,53,0,68,0,54,0,48,0,66,0,66,0,68,0,68,0,54,0,54,0,51,0,50,0,57,0,57,0,48,0,68,0,68,0,55,0,66,0,65,0,68,0,53,0,48,0,
I/Gecko   (  106): RIL Worker: We have at least one complete parcel.
I/ONCRPC  (  110): oncrpc_proxy_handle_cmd_rpc_call: Dispatching xid: b2
I/Gecko   (  106): RIL Worker: Unsolicited response for request type 1003
I/Gecko   (  106): RIL Worker: Handling parcel as UNSOLICITED_RESPONSE_NEW_SMS
I/Gecko   (  106): RIL Worker: Got new SMS, length 334
I/Gecko   (  106): RIL Worker: PDU: Going to read address: 12
I/Gecko   (  106): RIL Worker: PDU: read dcs: 0
I/Gecko   (  106): RIL Worker: PDU: message encoding is 0 bit.
I/Gecko   (  106): RIL Worker: Reading 160 bytes of user data.
I/Gecko   (  106): RIL Worker: Read UDH length: 5
I/Gecko   (  106): RIL Worker: Read UDH id: 0, length: 3
I/Gecko   (  106): RIL Worker: After header, 153 septets left of user data
I/Gecko   (  106): RIL Worker: Got new SMS: {"SMSC":"+12085978925","mti":0,"udhi":64,"sender":"+16508629154","recipient":null,"pid":0,"epid":0,"dcs":0,"mwi":null,"replace":false,"header":{"length":5,"langIndex":0,"langShiftIndex":0,"segmentRef":1,"segmentMaxSeq":2,"segmentSeq":1},"body":"Afhjhfgjuutghguutewqwruihfgjjgdghjtfdhhtfhhub vjj vhytuyesgu$67732268-75$&hgGjjhgdt hygwhjkbvgdfdaqrhkiutfcjjuygh&& -7535567 6543hhdhii gdgjuitrwrujhgfhh","data":null,"timestamp":1351883558000,"status":null,"scts":null,"dt":null,"encoding":0,"messageClass":"normal"}
I/Gecko   (  106): RIL Worker: Got segment no.1 of a multipart SMS: {"SMSC":"+12085978925","mti":0,"udhi":64,"sender":"+16508629154","recipient":null,"pid":0,"epid":0,"dcs":0,"mwi":null,"replace":false,"header":{"length":5,"langIndex":0,"langShiftIndex":0,"segmentRef":1,"segmentMaxSeq":2,"segmentSeq":1},"data":null,"timestamp":1351883558000,"status":null,"scts":null,"dt":null,"encoding":0,"messageClass":"normal","segmentMaxSeq":2,"receivedSegments":1,"segments":[null,"Afhjhfgjuutghguutewqwruihfgjjgdghjtfdhhtfhhub vjj vhytuyesgu$67732268-75$&hgGjjhgdt hygwhjkbvgdfdaqrhkiutfcjjuygh&& -7535567 6543hhdhii gdgjuitrwrujhgfhh"]}
I/Gecko   (  106): RIL Worker: Parcel handling threw TypeError: message is null
I/Gecko   (  106): _processSmsDeliver@resource://gre/modules/ril_worker.js:3869
I/Gecko   (  106): UNSOLICITED_RESPONSE_NEW_SMS@resource://gre/modules/ril_worker.js:4996
I/Gecko   (  106): handleParcel@resource://gre/modules/ril_worker.js:4120
I/Gecko   (  106): processParcel@resource://gre/modules/ril_worker.js:589
I/Gecko   (  106): processIncoming@resource://gre/modules/ril_worker.js:541
I/Gecko   (  106): onRILMessage@resource://gre/modules/ril_worker.js:7562
I/Gecko   (  106): 
I/Gecko   (  106): RIL Worker: Next parcel size unknown, going to sleep.
I guess this is the problem:
"segments":[null,"Afhjhfgjuutghguu
Can we write a deviceapi test for this or does qemu not understand multipart SMS?
(In reply to Gregor Wagner [:gwagner] from comment #4)
> mrbkap was working on a debug flag for RIL that can be enabled but I don't
> know if the setting made it to the stable builds yet.

Well, I was working on a debug flag for wifi.
Based upon a quick look at other SMS bugs, it looks like Vicamo may be a good owner for this one. Or are you planning on implementing the fix Gregor?

This is a P1/Critical bug, so we'd like to get a fix landed asap.
Priority: -- → P1
(In reply to Alex Keybl [:akeybl] from comment #11)
> Based upon a quick look at other SMS bugs, it looks like Vicamo may be a
> good owner for this one. Or are you planning on implementing the fix Gregor?
> 
> This is a P1/Critical bug, so we'd like to get a fix landed asap.

I am currently debugging. I will reassign to Vicamo of I can't find the bug today.
Assignee: nobody → anygregor
Attached patch patchSplinter Review
That fixes the problem with receiving. stupid strict mode :)

I still see a problem. I don't see a notification for overlong messages but at least they show up in the message thread and I can receive following messages.
Attachment #677884 - Flags: review?(philipp)
Attachment #677884 - Flags: review?(philipp) → review+
adding smoketest keyword so its also on the radar.
Keywords: smoketest
Summary: I sometimes do not receive text messages → Receiving multi-part SMS doesn't work.
Component: General → DOM: Device Interfaces
OS: Mac OS X → Gonk (Firefox OS)
Product: Boot2Gecko → Core
Hardware: x86 → ARM
Version: unspecified → Trunk
FWIW, if this bug is about sending long SMS messages, and then trying to send follow up messages that dont come through, i still havent been able to reproduce the problem yet.

Environment:  2 Unagi phones on 11-1 nightly build, using ATT Sim card

screen 1: http://i.imgur.com/drZah.png  (long text that was received into 2 parts)
screen 2: http://i.imgur.com/SCmco.png (side by side of both phone dialogs afterwards)
https://hg.mozilla.org/mozilla-central/rev/7bf38352bbc6

Should this have a test?
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Flags: in-testsuite?
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
(In reply to Ryan VanderMeulen from comment #18)
> https://hg.mozilla.org/mozilla-central/rev/7bf38352bbc6
> 
> Should this have a test?

Ah forgot to link the followup bug.
Depends on: 808195
Until this fix reaches dogfooders I found out that resetting the phone unborks the messaging app.
(In reply to Armen Zambrano G. [:armenzg] from comment #20)
> Until this fix reaches dogfooders I found out that resetting the phone
> unborks the messaging app.

This is not correct. Resetting the phone does not fix the issue.

When will an update be issued and include this change? I currently cannot use my b2g phone since I can't receive any messages.
Duplicate of this bug: 798173
You need to log in before you can comment on or make changes to this bug.