Notification panels should only open on click, not on mousedown

RESOLVED WONTFIX

Status

()

Firefox
SocialAPI
RESOLVED WONTFIX
6 years ago
5 years ago

People

(Reporter: jaws, Assigned: mixedpuppy)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][mentor=jaws][lang=js])

Attachments

(1 attachment, 1 obsolete attachment)

As seen here, http://hg.mozilla.org/mozilla-central/annotate/71b2ea41dff7/browser/base/content/browser-social.js#l824, the listener currently uses the 'mousedown' event. It should use 'click', which gives users a chance to cancel (mouse away), and also matches the interaction behavior of facebook.

Comment 1

6 years ago
Hi, this seems to be a good first bug for me, can I have this? Thanks :)
Sure, let me know if you have any questions :)
Assignee: nobody → liuweiran.nus
Status: NEW → ASSIGNED

Comment 3

6 years ago
Thanks:) Do I need to build anything for solving this bug? Currently I only have thunderbird with lightning and seamonkey

(In reply to Jared Wein [:jaws] from comment #2)
> Sure, let me know if you have any questions :)
You'll want to build the browser to test you changes. I'm "jaws" in #introduction on irc.mozilla.org. Message me and I can help you get a build up and running.

Comment 5

6 years ago
Ok
(In reply to Jared Wein [:jaws] from comment #4)
> You'll want to build the browser to test you changes. I'm "jaws" in
> #introduction on irc.mozilla.org. Message me and I can help you get a build
> up and running.

Comment 6

6 years ago
hi Jared,
I'm not sure I understand what the problem is. Can you provide the steps to reproduce this bug? thanks

Comment 7

6 years ago
Created attachment 682027 [details] [diff] [review]
make listener to be active when mouse click
Attachment #682027 - Flags: review?(jaws)

Comment 8

6 years ago
I just change the listener to be active when "click".
I am not sure it works, but just a try.
Comment on attachment 682027 [details] [diff] [review]
make listener to be active when mouse click

Review of attachment 682027 [details] [diff] [review]:
-----------------------------------------------------------------

This correctly changes this to act on clicks instead of mousedown, but the button now flickers between the :active state and the "open" state.

When the button is pressed, it is considered active, and shows as pressed in. When the mouse button is released, the panel opens and the button gets the "open" attribute. Between the pressing and releasing of the mouse button, the button shows the hovered state, so there is a short flicker of the hovered state when the button gets clicked.

We should fix that before checking this in. I'm not sure off the top of my head how to fix this, but if you want to play around with some of the code in browser-social.js and /browser/themes/winstripe/browser.css you may find a way to fix this.
Attachment #682027 - Flags: review?(jaws) → feedback+
The "downloads" button (which also displays a panel) also seems to have this flashing - although it is very hard to be sure as it is very subtle.  It also doesn't seem to have any special css to mitigate it.

Jaws - can you confirm you see the same flashing on that button, and if so, consider whether we can land this as-is and create a new bug for all such buttons?
Flags: needinfo?(jaws)
I can't reproduce the flashing on the downloads button with today's Nightly build.

I'd rather see us just land a patch that fixes this the right way the first time, since changing it with the goal of changing it again will just cause unnecessary churn.
Flags: needinfo?(jaws)

Comment 12

5 years ago
Is it too much of a stretch for this bug to say that a second click should roll up the flyout? I don't see another bug on that but it's clearly an inconsistency.
(In reply to Asa Dotzler [:asa] from comment #12)
> Is it too much of a stretch for this bug to say that a second click should
> roll up the flyout? I don't see another bug on that but it's clearly an
> inconsistency.

I think it's reasonable to include that as part of this bug.
Liu, could you confirm that you're still working on this?
Flags: needinfo?(liuweiran.nus)

Comment 15

5 years ago
Sorry for being silent for such a long time. I was busy for my academic things.
I have no new updates for this bug yet, but since I've finished my semester, I can 
continue to work on this soon.

(In reply to Josh Matthews [:jdm] (on vacation until 5/7) from comment #14)
> Liu, could you confirm that you're still working on this?
Flags: needinfo?(liuweiran.nus)
(Assignee)

Updated

5 years ago
Blocks: 877642
(Assignee)

Comment 16

5 years ago
Created attachment 830921 [details] [diff] [review]
fix click to open handler

This fixes the flickering on osx, but needs a quick verification on windows.
Assignee: liuweiran.nus → mixedpuppy
Attachment #682027 - Attachment is obsolete: true
Attachment #830921 - Flags: review?(mhammond)
(Assignee)

Updated

5 years ago
Duplicate of this bug: 877642
Comment on attachment 830921 [details] [diff] [review]
fix click to open handler

Review of attachment 830921 [details] [diff] [review]:
-----------------------------------------------------------------

looks fine, pending a check it still works correctly on Windows.
Attachment #830921 - Flags: review?(mhammond) → review+
(Assignee)

Comment 19

5 years ago
I've verified on win7 that the button works correctly without flickering.
(Assignee)

Comment 20

5 years ago
I'm going to wontfix this in favor of bug 936712 which makes this a non-issue.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 21

5 years ago
I meant, wontfix in favor of bug 935640
You need to log in before you can comment on or make changes to this bug.