Be less chatty when the build fails

RESOLVED FIXED in mozilla19

Status

enhancement
RESOLVED FIXED
7 years ago
a year ago

People

(Reporter: Ehsan, Assigned: gps)

Tracking

Trunk
mozilla19

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Here's what mach currently shows:

Error running mach:

    ['build']

The error occured in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

Exception: Process executed with non-0 exit code: [u'/usr/bin/make', u'-f', u'client.mk', u'-s']

  File "/Users/ehsanakhgari/moz/mozilla-central/python/mozbuild/mach/commands/build.py", line 48, in build
    log=False, print_directory=False)
  File "/Users/ehsanakhgari/moz/mozilla-central/python/mozbuild/mozbuild/base.py", line 242, in _run_make
    fn(**params)
  File "/Users/ehsanakhgari/moz/mozilla-central/python/mozbuild/mozbuild/base.py", line 265, in _run_command_in_srcdir
    self.run_process(cwd=self.topsrcdir, **args)
  File "/Users/ehsanakhgari/moz/mozilla-central/python/mach/mach/mixin/process.py", line 100, in run_process
    raise Exception('Process executed with non-0 exit code: %s' % args)

We should be able to be a little bit more concise here.  :-)
(Assignee)

Comment 1

7 years ago
I fixed this with the patch on bug 803400. If you want to contribute a fix before I land that, go right ahead!
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> I fixed this with the patch on bug 803400. If you want to contribute a fix
> before I land that, go right ahead!

No, I'll wait! ;-)
(Assignee)

Comment 3

7 years ago
I decided to implement this sooner than bug 803400 because it is affecting first-time tree builders who use mach. I'd like to get a fix in the tree ASAP.
Assignee: nobody → gps
Status: NEW → ASSIGNED
Attachment #678424 - Flags: review?(jhammel)
(Assignee)

Comment 4

7 years ago
This requires the refactoring work from bug 808346 to apply cleanly.
Depends on: 808346

Comment 5

7 years ago
(In reply to Gregory Szorc [:gps] from comment #4)
> This requires the refactoring work from bug 808346 to apply cleanly.

Should I not review until this bug is fixed?
(Assignee)

Comment 6

7 years ago
You could probably do the review now. This just won't apply cleanly because of moved files.

Comment 7

7 years ago
Assuming this isn't platform specific o_O
OS: Mac OS X → All
Hardware: x86 → All

Updated

7 years ago
Attachment #678424 - Flags: review?(jhammel) → review+
(Assignee)

Comment 8

7 years ago
https://hg.mozilla.org/mozilla-central/rev/e57bd488af4c
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
(Assignee)

Updated

7 years ago
Duplicate of this bug: 803319

Updated

a year ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.