Closed Bug 808403 Opened 7 years ago Closed 7 years ago

Firefox theme/design does not match native Windows 8 (Win8) Desktop appearance

Categories

(Firefox :: Theme, enhancement, P2)

All
Windows 8
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 728139

People

(Reporter: hansschmucker, Unassigned)

References

Details

(4 keywords)

Attachments

(8 files, 1 obsolete file)

Attached image FFWin8a.png
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID: 20121103040205

Steps to reproduce:

Run Firefox on Windows 8 Professional final. This does NOT concern the metro environment, just the desktop.


Actual results:

The default theme works, but the appearance of many widgets differs significantly from the ones used in native applications, especially Windows Explorer (Internet Explorer 10 has the same issues, so it's probably best to ignore it as far as development of a native-looking theme is concerned).


Expected results:

Firefox widgets should look identical to ones in standard applications, most notably Windows Explorer (which is probably the application that defines the look of a "standard" Windows application most) and the layout should likewise be adjusted.

I've attached a mockup that incorporates all the design elements that are present in Windows Explorer, with minimal changes to the layout. The title is displayed in the title bar again and the app-button has moved to the tab-bar, as have the toolbar buttons. The pinned tabs have moved to the title bar and the favicons (which have no place in Windows8's design, but are too valuable to remove) are drawn with 30% opacity.

What remains is finding a place for the close-tab buttons... they should probably only be visible on mouse over.
Severity: normal → major
Component: Untriaged → Theme
Priority: -- → P2
Hardware: x86_64 → All
Depends on: 728139
Summary: Firefox theme does not match native Windows 8 (Win8) Desktop appearance → Firefox theme/design does not match native Windows 8 (Win8) Desktop appearance
This may be covered by some of our theme work.
Severity: major → enhancement
Is there a meta bug for that, I really couldn't find one.
Well, in the meantime I've created a little userstyle (userChrome.css) for my own purposes that adopts the tab-bar for Win8. Nothing fancy, but maybe it's enough to compare the approach to the one taken by Internet Explorer (which seems to revolve around "ignore any other UI concept we're using elsewhere").

I'll attach a screenshot and the css in a second. This does NOT affect the layout, meaning that you will still need to move the stuff around manually (I'm using "Moveable Firefox Button 1.4" to put the app button into the tab bar... the buttons on the right are simply moved from the navbar with a flex space separating it from the tabs).
Depends on: 808341
Depends on: 578780
You might want to take a look at bug 738491 where the austrailis tab work is happening.
Your work looks awesome. Rounded curves with the release of Windows 8 are a little outdated now. As the Windows 8 are installed in more and more computers rounded now looks very outdated.
Given that Firefox has unified the look across all platforms, I'm not sure this bug is appropriate. There should certainly be some effort put into flattening the look and feel of Firefox on Windows 8, but I don't believe the key here is to follow the design principles/mimic Explorer as closely as suggested. Firefox has it's own brand and identity and maintaining that if far more profitable to consumers and the customer as a whole.

There are changes in the design specification for Australis that haven't been taken into consideration for the above mockups as of yet. First and foremost, is that the Application button is swapped for a menu button at the far right of the navigation bar.

Australis have been clever in garnering the best user experiences from users on the many different platforms that Firefox serves and bringing them front and centre. While some of these user experience may be contrary to the platform, evidence supports the fact that users prefer gradual change over sudden change.

As the adoption rate for Windows 8 grows, Mozilla will undoubtedly revisit the user experience to bring it more in line that of the platform. But right now, the Windows priority is that of the largest platform version and giving the majority of Windows users a native and comfortable user experience takes precedent.
It's not UI that needs adjustment, it's GUI. Basically make *everything* flat, change color scheme a bit and to start using system's hover styling.
I wasn't even aware of Australis when I first created the mockups, but I still think that there's a severe conflict between the Australis curves and the Windows-8 rectangles. But it's better to compare both approaches side-by-side, so I've created a mockup that effectively applies Windows-8 coloring and widget-design to the Australis design. I still think that global-settings belong on the left, not to the right (where context-sensitive items usually live) but that's a discussion for another day.
Forgot to include the add-tab button
Attachment #682829 - Attachment is obsolete: true
The same mockup, with Australis-layout, but Windows-8 styles tabs. To me it looks like the perfect compromise.
See Also: → australis-tabs-win
Note to anyone following this bug. Progress has stalled since I'm not getting feedback from anybody. When and if this bug is revived, feel free to drop me a line directly at hansschmucker@gmail.com
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 728139
No longer depends on: 578780, 728139, 808341
You need to log in before you can comment on or make changes to this bug.