Windows 8 menu highlight inconsistent in Firefox Menu

RESOLVED WONTFIX

Status

()

Firefox
Theme
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: Leman Bennett [Omega], Unassigned)

Tracking

19 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID: 20121103030715

Steps to reproduce:

Testing in Windows 8 RTM.

Hovering over certain items in the Firefox Menu produces the Windows 7 highlight instead of the Windows 8 highlight.
(Reporter)

Updated

5 years ago
Component: Untriaged → Menus

Updated

5 years ago
Component: Menus → Theme

Comment 1

5 years ago
Not the same bug, but related to Bug #770257. Is there a meta Windows 8 DESKTOP appearance bug that such issues should block?

Comment 2

5 years ago
Whoops, Bug #808403 is what I meant
(Reporter)

Comment 3

5 years ago
No clue about a meta bug. But I don't have edit privileges so I cannot make one.

Comment 4

5 years ago
Created attachment 679313 [details]
UserChrome.css implementing new menu-bar

Obviously, the window frame colors are just grey, simply because the system colors are not available via CSS. This is meant to be combined with the stuff from Bug #808403

Updated

5 years ago
Blocks: 808403

Comment 5

5 years ago
I confirm this issue. The Firefox Menu seems to use a mix of native menu items and custom menu items (with an arrow on the right). The custom menu items (with an arrow on the right) uses a Windows 7 style highlight (a light blue gradient) instead of a flat highlight. Contrariwise, items without the arrow use the native flat highlight.

Updated

5 years ago
Blocks: 728139

Updated

5 years ago
No longer blocks: 808403

Updated

5 years ago
Duplicate of this bug: 849584

Updated

4 years ago
Duplicate of this bug: 911555
This menu is being removed in bug 863753.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.