Closed Bug 728139 Opened 8 years ago Closed 4 years ago

Support Windows 8 'Aero Lite' theme/visual style/Automatic Windows Color

Categories

(Firefox :: Theme, defect)

x86
Windows 8
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: divjot94, Unassigned)

References

Details

Attachments

(1 file)

Windows 8 now supports a new theme "Aero Lite" instead of Aero Basic. Firefox fails to understand the visual style and treats it just like other 3rd party themes. 

Further , with Aero Lite Enabled , different colors of window borders are formed which again require a nice contrast toolbar gradient. Somehow we should work out how to use their coloring mechanism and make dynamic gradients for toolbars(?)
Most everything looks correct in the latest consumer preview using a nightly build. Our tabs probably need a different background gradient, but menus, windows border, form controls, all look right. 

Have you had a chance to play with the latest win8 release bogas04?
installing it now... (after a long wait) . Will report soon.
Clearly issues which I have demonstrated in the attachment (with tab gradient etc) are still present , which is what the bug deals with.
(In reply to bogas04 from comment #3)
> Clearly issues which I have demonstrated in the attachment (with tab
> gradient etc) are still present , which is what the bug deals with.

Other than the gray tab gradient, what other issues are you seeing?

Note when a new os is released we normally tweak our theme so that it meshes with the new os. I'm trying to figure out if you are reporting an actual bug here, or simply requesting that the theme be updated.
(In reply to Jim Mathies [:jimm] from comment #4)
> (In reply to bogas04 from comment #3)
> > Clearly issues which I have demonstrated in the attachment (with tab
> > gradient etc) are still present , which is what the bug deals with.
> 
> Other than the gray tab gradient, what other issues are you seeing?
> 
> Note when a new os is released we normally tweak our theme so that it meshes
> with the new os. I'm trying to figure out if you are reporting an actual bug
> here, or simply requesting that the theme be updated.

Yeah m requesting to update theme and identify when a user uses new aero basic theme n provide UI accordingly. There r no bugs or glitches that i am facing other than those mentioned in the attachment (incompatibility of tab gradient , problem with in content ui)

Thanks
After trying this http://trunc.it/kbhtu user style (ignore the style) the normal Aero gradients for the browser seem to match with Win8's AeroBasic theme a lot. Can we like enable the normal theme (blue gradient) for all visual styles to avoid incompatibilities with all sorts of visual styles and maintain consistency on Windows platform ? (I admit its out of scope of this bug report)
Is this still an issue with Aero no longer really existing in the RTM Windows 8?
No it is not anymore, but FF is broke for High Contrast themes etc in RTM (Nightly)
bogas04, can you please file a new bug with some of the themes you are seeing issues with ?
Blocks: 808403
Duplicate of this bug: 808403
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
No longer blocks: 808403
I do remember when we made the back/forward buttons on Vista be blue instead of green to match the OS better; if we were so obsessed with making Firefox look as native as possible, why didn't we do this? Given that this ended up becoming the default theme of 8, I do think that we should at least tweak the theme a bit with some Windows 8-only stylings, in particular:

1. Reduce the level of gradients and rounded rectangles used
2. Make the toolbar solid white or an off-grey
3. Make the Firefox button solid colored with no border or gradient
4. In general, make it flatter
(In reply to Wes Kocher (:KWierso) from comment #7)
> Is this still an issue with Aero no longer really existing in the RTM
> Windows 8?

(In reply to bogas04 from comment #8)
> No it is not anymore, but FF is broke for High Contrast themes etc in RTM
> (Nightly)

(In reply to bhavana bajaj [:bajaj] from comment #9)
> bogas04, can you please file a new bug with some of the themes you are
> seeing issues with ?

Considering the lack of response, the fact that the Firefox menu is gone, and that there's a tracker for high contrast mode issues with a lot of usefully formulated blocking bugs (bug 1016556), resolving this as WFM.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.