Closed Bug 809401 Opened 7 years ago Closed 7 years ago

Horoscopo app doesn't scroll properly as an App

Categories

(Firefox for Android :: Web Apps (PWAs), defect, P2)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 20
Tracking Status
firefox19 --- verified
firefox20 --- verified

People

(Reporter: eviljeff, Assigned: wesj)

References

()

Details

Attachments

(1 file)

The horoscopes in the Horoscopo app don't scroll properly as an App, but the same content does when loaded directly within the browser.

review page for those who can access:
https://marketplace.mozilla.org/reviewers/apps/review/horoscopo
(otherwise manifest is in the URL)
Flags: needinfo?(wjohnston)
Priority: -- → P2
James, please take a look.
I can reproduce this. The app is using an overflowing div for most of its scrolling (which we're actually pretty good at now). Strangely, its somehow broken in the app, but not in normal Fennec. I suspect it has something to do with the fact I turned off bouncy overscroll in Webapps.
Flags: needinfo?(wjohnston)
Attached patch PatchSplinter Review
This disables our resetting of the scroll position for subscrollers.
Assignee: nobody → wjohnston
Attachment #690651 - Flags: review?(bugmail.mozilla)
Comment on attachment 690651 [details] [diff] [review]
Patch

Review of attachment 690651 [details] [diff] [review]:
-----------------------------------------------------------------

Makes sense.
Attachment #690651 - Flags: review?(bugmail.mozilla) → review+
Beautiful little app by the way!
https://hg.mozilla.org/mozilla-central/rev/e1245c60df42
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20
(In reply to Ed Morley [UTC+0; email:edmorley@moco] from comment #8)
> https://hg.mozilla.org/mozilla-central/rev/e1245c60df42

Any chance we can get this on the other branches?  Aurora at least.
Comment on attachment 690651 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 783553
User impact if declined: Can't scroll overflow elements in webapps
Testing completed (on m-c, etc.): Landed on mc last week
Risk to taking this patch (and alternatives if risky): This is pretty low risk. A Webapp only feature. Since we're pushing for webapps on Aurora, makes sense to me to push it there.
String or UUID changes made by this patch: None.
Attachment #690651 - Flags: approval-mozilla-aurora?
Attachment #690651 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Back in. This had nothing to do with the test failures. I'll look into the other ones. Thanks for catching them.

https://hg.mozilla.org/releases/mozilla-aurora/rev/7c1c3d33b320
verified on the latest Aurora with the Horoscopo app.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 816891
Verified on Firefox Mobile 20 beta 5 and Aurora 21.0a2 2013-03-14 using the LG Nexus 4 (Android 4.2.2)
You need to log in before you can comment on or make changes to this bug.