[System] Timezone is not set automatically

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
6 years ago
11 months ago

People

(Reporter: cjones, Unassigned)

Tracking

({polish})

unspecified
polish
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:-, tracking-b2g:backlog)

Details

(Whiteboard: interaction, UX-P2)

That seems odd to me since (i) we should be able to guess the timezone 99.9% accurately for the v1 target markets based on locale; (ii) failing that, we'll set the timezone using NITZ.

I don't recall any phone I've used before asking me to manually set a time zone.
Is this in the spec?  Why?
Flags: needinfo?(clee)

Comment 2

6 years ago
Apparently NITZ doesn't work all over the world. If we can set it automatically it will autofill and the experience will be reassuring and overall nice. If not, we give the user the option to change it, just like date and time.

What's the drawback of having it?
I suggested NITZ as a fallback from detecting timezone based on locale.

First-run is our first impression on the user.  If we're making them do unnecessary things, we're not making a good first impression.  Like I said, I've never had a phone that asked me to do this.

Comment 4

6 years ago
Time zone cannot be inferred from locale. The US and Brazil have several time zones, for example. If that fails and NITZ isn't available, what's left?

If it can be inferred or obtained and the user sees it, it's a better experience, i.e. reassurance on a setting that would otherwise be hidden, set or not.
We discussed this offline, and I think we violently agree :).  But following up here for completeness.

(In reply to Rafael Rebolleda [:rafaelrebolleda] from comment #4)
> Time zone cannot be inferred from locale. The US and Brazil have several
> time zones, for example. If that fails and NITZ isn't available, what's left?
> 

Yep, it can fail.  The US is a much harder problem than Brazil, but I was careful to say "v1 target markets" in comment 0 ;).  If auto-config fails, my thought was that users can manually change the configuration after first-run in the Settings app.
The FRE's "Date & Time" screen initially shows my time zone is GMT+00:00, but if I press the "Change" button, it somehow deduces my actual time zone is GMT-08:00. Why can't the initial screen deduce my time zone, too?
Summary: First-run includes configuration of time zone → [FRE] First-run includes configuration of time zone
Component: Gaia → Gaia::System::First Time Experience
This is a problem that is not in FTU App itself, the problem is that we cant ensure that NITZ it's gonna work. Even if FTU does not exists, you are gonna have the same problem in Settings App. Im gonna rename the bug.
Component: Gaia::First Time Experience → Gaia::System
Summary: [FRE] First-run includes configuration of time zone → [System] Timezone is not set automatically
While it is much easier on the user for this to be autoselected, I don't think we should block on it.
blocking-basecamp: --- → -
Flags: needinfo?(clee)
Keywords: polish
We should do our best to present a reasonably accurate (+/1 timezone) automatically generated (locale-based and/or NITZ) estimate to the user, and then—knowing that there may be accuracy issues—allow them to manually edit it within the FTE.

As a user, I would rather see a timezone that's reasonably accurate than something that simpy defaults to GMT-0.
Bugzilla ate my comment. Meant to say:

. . . should do our best to present a reasonably accurate (plus or minus 1 timezone) automatically geneated . . .

Comment 11

6 years ago
When does nitz fail? Do we have evidence for that?
(In reply to Andreas Gal :gal from comment #11)
> When does nitz fail? Do we have evidence for that?

NITZ fails if:

 - There is no SIM Card in the device. We can check this in the FTE.
 - The operator which the SIM Card is linked does not support NITZ (e.g. Movistar in Spain does not support it). Don't know if this exposed to apps.
 - If there is an error when retrieving NITZ data. Not sure if this progressed either.
(In reply to Daniel Coloma:dcoloma from comment #12)
> (In reply to Andreas Gal :gal from comment #11)
> > When does nitz fail? Do we have evidence for that?
> 
> NITZ fails if:
> 
>  - There is no SIM Card in the device. We can check this in the FTE.
>  - The operator which the SIM Card is linked does not support NITZ (e.g.
> Movistar in Spain does not support it). Don't know if this exposed to apps.
>  - If there is an error when retrieving NITZ data. Not sure if this
> progressed either.

If NITZ fails, can we fallback to a default specified by the MNO? That should be accurate to within 1-2 timezones for the vast majority of users, who can then edit manually, if needed.
(In reply to Josh Carpenter [:jcarpenter] from comment #13)
> (In reply to Daniel Coloma:dcoloma from comment #12)
> > (In reply to Andreas Gal :gal from comment #11)
> > > When does nitz fail? Do we have evidence for that?
> > 
> > NITZ fails if:
> > 
> >  - There is no SIM Card in the device. We can check this in the FTE.
> >  - The operator which the SIM Card is linked does not support NITZ (e.g.
> > Movistar in Spain does not support it). Don't know if this exposed to apps.
> >  - If there is an error when retrieving NITZ data. Not sure if this
> > progressed either.
> 
> If NITZ fails, can we fallback to a default specified by the MNO? That
> should be accurate to within 1-2 timezones for the vast majority of users,
> who can then edit manually, if needed.

The only issue I see is that in some cases the same device can be sold in multiple countries (e.g. some OEMs makes exactly the same device to be sold in different LatAm countries) but IIRC that provides a range of 3 hours...
cjones: would it make sense as a fall back to check geolocation before locale?

tchung ran into an issue this morning where he was an hour behind, however after checking the timezone from setting from automatic to manual it turned out that he was just on the wrong timezone.

I think we also need something to show what the automatic setting is showing in terms of the timezone.  I'll file a separate bug for that.
bug 827301 filed for showing timezone when settings is set automatically

Updated

6 years ago
Whiteboard: interaction, UX-P2

Comment 17

6 years ago
Here is a pull request that looks up the current timezone based on location. The FTE should be extended to turn on GPS and get the current location if possible. The database is 8MB but compresses well and contains all cities > 1000 population. We could use > 5000 if we want to shrink that. This returns the timezone in the closest city. In parallel we should also use NTP (turn on data modem briefly). I would love to see this for 1.2.

https://github.com/mozilla-b2g/gaia/pull/9940

Updated

6 years ago
Assignee: nobody → rlu
Refresh this bug.

Bruce, who is the responsible product people to backlog this feature request?
Assignee: rlu → nobody
Flags: needinfo?(bhuang)
Backlog for now.
Blocks: 908549
blocking-b2g: --- → backlog
Flags: needinfo?(bhuang)
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
Duplicate of this bug: 1176755
No longer blocks: 1209892
Depends on: 1209892
:freesamael - since landing of the bug 1208808 I feel like the basic time/date/timezone operations are consistent within the system and among the apps.

The one thing I still see impacting user experience is that we seem to do poor job discovering the right timezone for the user in FTE.

I tested with aries (with AT&T simcard) and without (Flame-kk with no simcard), connected both to wifi and they both shower New York (which is the default I think?) for my auto-guessed timezone despite me being in San Francisco.

Is this the right bug to track this problem?

Comment 22

11 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.