Update libsoundtouch to current version

RESOLVED FIXED in mozilla19

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: jacek, Assigned: jacek)

Tracking

Trunk
mozilla19
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

7 years ago
Posted patch fix v1.0Splinter Review
There was a problem with libsoundtouch compilation on mingw-w64 GCC due to casts losing precision. I've fixed it upstream and prepared a patch updating sources in m-c.

Updating is a bit ugly, because the source code uses auto-props for files (to include stuff like last change date). The problem is that dates include timezones, so even untouched files are different in my SVN checkout. For creating this patch, I used git-svn checkout of SoundTouch. Since git-svn doesn't support auto-props (I believe it's also possible to disable in plain SVN), this will skip those comments. If we follow this practice in future updates, this will save us from useless changes.

I've also changed moz-libsoundtouch.patch, which didn't apply clearly due to other SoundTouch changes.

Try commit:
https://tbpl.mozilla.org/?tree=Try&rev=4a06ecbb4b39
Attachment #680044 - Flags: review?(paul)
Comment on attachment 680044 [details] [diff] [review]
fix v1.0

Review of attachment 680044 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #680044 - Flags: review?(paul) → review+
Assignee

Comment 2

7 years ago
Thanks for review, pushed to m-i:

https://hg.mozilla.org/integration/mozilla-inbound/rev/51533e35127d
https://hg.mozilla.org/mozilla-central/rev/51533e35127d
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
Depends on: 814532
Depends on: 814708
Depends on: 815106
You need to log in before you can comment on or make changes to this bug.