Closed Bug 810475 Opened 8 years ago Closed 8 years ago

[Trusted UI] Opening trusted UI, switching to a different app, switching back to app with trusted UI - cannot finish payment or cancel payment

Categories

(Firefox OS Graveyard :: Gaia::System, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+)

VERIFIED FIXED
blocking-basecamp +

People

(Reporter: jsmith, Assigned: alberto.pastor)

References

Details

Build:

Device - Unagi

Hashes

  <project name="gaia" path="gaia" remote="b2g" revision="319123f39aacfc98387390e1f173035f1870bacd"/>
  <project name="releases-mozilla-aurora" path="gecko" remote="mozilla" revision="48017631bc649ce43791db461d3a549ec51a27e3"/>

Steps:

1. Launch two apps - one that will make the mozPay call and one that does not
2. In the app with the mozPay call - call mozPay
3. After the trusted UI finishes loading, go to the task switcher and switch to the the app without the mozPay call
4. Exit back to the homescreen
5. Return to the app with the mozPay call active
6. Try to finish the payment or cancel the payment

Expected:

We should be able to either finish off the payment or cancel the payment.

Actual:

Trying to finish off the payment or cancel the payment results in nothing happening. Clicking the pay or cancel buttons on the mock payment provider does nothing in these scenarios.
blocking-basecamp: --- → ?
No longer blocks: basecamp-payments, basecamp-id
Gaia Triage : blocking +, P1.  Functional breakage.
blocking-basecamp: ? → +
Priority: -- → P1
Alberto, I have seen you touching Trusted UI last week, so I believe you will be a good owner for this bug :)
Assignee: nobody → alberto.pastor
Keywords: qawanted
QA Contact: jsmith
Re-tested, can't reproduce this anymore. Probably fixed by the animations bug. Closing.
Status: NEW → RESOLVED
Closed: 8 years ago
Keywords: qawanted
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
As requested by Caitlin, I've checked again that this is indeed successfully working. FTR I've tested with the mock payment provider.
(In reply to Fernando Jiménez Moreno [:ferjm] (PTO until 8th January 2013) from comment #4)
> As requested by Caitlin, I've checked again that this is indeed successfully
> working. FTR I've tested with the mock payment provider.

We really should get more information on that issue that happened. I've seen bugs happen where they worked fine with the mock payment provider, but failed with some other web content.

What I want to know is:

* Build Date?
* Device Type or Desktop Build?
* What part of the payment provider flow did they try to reproduce this?

Caitlin - I need more info here when you get the chance. If something is going wrong here that only happens with webpay, then there could be a bug here. But I don't think I've got enough information yet to make that call.
Flags: needinfo?(cgalimidi)
Jason - I don't have more details to offer on this. It will come up again during payments E2E testing for Marketplace however. If you are not having any issue with this during payments then by all means close out.
Flags: needinfo?(cgalimidi)
You need to log in before you can comment on or make changes to this bug.