Bug 794530 (basecamp-payments)

[meta] Implement new client side payment provider flow

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: ladamski, Unassigned)

Tracking

({meta})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Our move to a new payment provider requires refactoring of client and server flows.  This bug tracks those changes.

Updated

6 years ago
Blocks: 775802

Updated

6 years ago
Keywords: meta
(Reporter)

Comment 1

6 years ago
See https://mana.mozilla.org/wiki/display/MARKET/Marketplace+Home for data flows and supporting info.
(Reporter)

Updated

6 years ago
Depends on: 794552
making bug 775802 a dep (not a blocker) because that covers everything that the Marketplace needs to do to make payments work. There are other Gaia and identity pieces which will go on this tracker.
No longer blocks: 775802
Depends on: 775802
No longer depends on: 794677
No longer depends on: 794651

Comment 4

6 years ago
Lucas, we will be following this too.

We haven't permissions to access https://mana.mozilla.org/wiki/display/MARKET/Marketplace+Home, but everything will be at https://wiki.mozilla.org/Apps/ID_and_Payments, right? Otherwise, we will need permissions to access the first link.

Thanks
(In reply to David Lozano from comment #4)
> We haven't permissions to access
> https://mana.mozilla.org/wiki/display/MARKET/Marketplace+Home

that was just for the sequence flow which had partner details. I removed the details and posted it publicly on the wiki
(Reporter)

Updated

6 years ago
Depends on: 795492

Updated

6 years ago
Depends on: 793329

Updated

6 years ago
No longer depends on: 793329

Updated

6 years ago
Depends on: 797927

Updated

6 years ago
Depends on: 797930

Updated

6 years ago
Depends on: 804485

Updated

6 years ago
Depends on: 806425

Updated

6 years ago
No longer depends on: 795492

Updated

6 years ago
No longer depends on: 797927

Updated

6 years ago
No longer depends on: 797930

Updated

6 years ago
Depends on: 801561
Did some refactoring of the tracking bugs. This one I'm treating as tracking any work required on the client side for payment provider flow. Let's use bug 775802 for the marketplace work, so that people don't get confused.
Blocks: 775802
No longer depends on: 775802

Updated

6 years ago
Summary: [meta] Implement new payment provider flow → [meta] Implement new client side payment provider flow

Updated

6 years ago
Depends on: 793329

Updated

6 years ago
Depends on: 803455

Updated

6 years ago
Depends on: 767818

Updated

6 years ago
Depends on: 805123

Updated

6 years ago
Depends on: 800511

Updated

6 years ago
No longer depends on: 800511

Updated

6 years ago
Depends on: 805130

Updated

6 years ago
Depends on: 804080

Updated

6 years ago
Depends on: 800511

Updated

6 years ago
No longer depends on: 806425

Updated

6 years ago
Depends on: 777023
No longer depends on: 808798

Updated

6 years ago
Depends on: 806425
Depends on: 809219
OS: Mac OS X → All
Hardware: x86 → All

Updated

6 years ago
Depends on: 810449

Updated

6 years ago
Depends on: 810475

Updated

6 years ago
Depends on: 809714

Updated

6 years ago
No longer depends on: 810449

Updated

6 years ago
No longer depends on: 810475

Updated

6 years ago
No longer depends on: 806425

Updated

6 years ago
No longer depends on: 804485

Updated

6 years ago
No longer depends on: 809714

Updated

6 years ago
No longer depends on: 803455

Updated

6 years ago
No longer depends on: 794552

Updated

6 years ago
No longer depends on: 777023

Updated

6 years ago
No longer depends on: 809219
Closing this bug as fixed - at this point, the client-side implementation for mozPay is finished and validated (although there's always a change of regressions, but this webapi I'm not expecting to regress due to low code churn). Trustworthy UI is being tracked separately against bug 801561, although the work is pretty much done there implementation-wise with some followups.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Depends on: 815148

Updated

6 years ago
Depends on: 826520

Updated

6 years ago
Depends on: 829170

Updated

6 years ago
No longer depends on: 829170

Updated

6 years ago
Depends on: 813811

Updated

6 years ago
Depends on: 818317

Updated

6 years ago
Depends on: 832951

Updated

6 years ago
Depends on: 831524

Updated

6 years ago
No longer depends on: 818317
You need to log in before you can comment on or make changes to this bug.