Closed Bug 812830 Opened 7 years ago Closed 7 years ago

Create Gecko build config for B2G which builds multilocale gecko repacks

Categories

(Firefox Build System :: General, defect, P1)

x86_64
Linux
defect

Tracking

(blocking-basecamp:+)

RESOLVED DUPLICATE of bug 796051
B2G C2 (20nov-10dec)
blocking-basecamp +

People

(Reporter: stas, Assigned: Pike)

References

Details

For localized Firefox OS builds (i.e., all of them)  we'll need a way to build/repack Gecko with several locales enabled.  This should be similar to what we're doing for Fennec.  Hopefully, we can reuse the same code, too.
This is going to be purely build system work AFAICT.
Component: Release Engineering → Build Config
Product: mozilla.org → Core
Version: other → Trunk
FWIW, Fennec doesn't do repack. It does multilang builds directly.
Fennec's multilocale builds are also a pile of hacks.  I'd like to avoid that if we can.
Sorry, we can't avoid that. If you have a proposal on how to do multi-locale geckos without the hacks you're concerned about, that'd probably benefit both.
Depends on: 796051
This bug blocks bug 808326, which is basecamp+.

Dietrich - Are you tracking this work?
Sounds like Stas, Axel, Khuey and Joduinn need to figure out the right way forward for multi-locale builds.

And per Axel's comment, sounds like we must use what we've got, unless Kyle has a new solution already developed and ready to go.
Is there an owner or ETA for this? If RelEng is to hit the Dec. 10 deadline for all of the multilocale builds, we need a working build system by early next week in order to iron out issues on the automation side. We can move a bit faster if we know what the build system interface will look like ahead of time.
Blocks a blocker, so blocking-basecamp+. Also has l10n impact, so milestoning for C2.

Sending email about ownership now.
blocking-basecamp: --- → +
Target Milestone: --- → B2G C2 (20nov-10dec)
Who should own this?
Flags: needinfo?(l10n)
Axel, we decided during triage it was best to assign to you to find someone to do this.
Assignee: nobody → l10n
Flags: needinfo?(l10n)
Setting priority based on triage discussions.  Feel free to decrease priority if you disagree.
Priority: -- → P1
I think this is actually covered in bug 796051, resolving DUPE.
Status: NEW → RESOLVED
Closed: 7 years ago
No longer depends on: 796051
Resolution: --- → DUPLICATE
Duplicate of bug: 796051
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.