Closed Bug 812834 Opened 7 years ago Closed 7 years ago

Set up nightly multilocale B2G desktop builds for dev testing

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(blocking-basecamp:+)

RESOLVED DUPLICATE of bug 812836
B2G C2 (20nov-10dec)
blocking-basecamp +

People

(Reporter: stas, Assigned: bhearsum)

References

Details

This is similar to bug 812833, but for desktop, not unagi.

When we currently create B2G builds, we simply use the locales that are present in git:  en-US, ar, fr, zh-TW.

I'd like to change this.

1. Let's build with en-US, ar, fr, zh-TW, es, pt-BR
2. For all five non en-US locales above, let's use the most up-to-date translations from http://hg.mozilla.org/gaia-l10n instead of the files which landed in git.

gaia locales: en-US, ar, fr, zh-TW, es, pt-BR
gecko locales: all Fennec locales
Assignee: nobody → bhearsum
The current nightly desktop builds (the en-US ones) are MercurialBuildFactory based. Here's my rough outline of what we need to do here:
* Adjust those builders to clone the l10n repos before calling 'make -f client.mk build'. Not sure how to implement this yet, because the existing multilocale support we have in MBF is called after the build step.
* Pass something to the build system to indicate that we want a multilocale build. This might be in the mozconfig, it might be an environment variable. Hopefully this can be the name of or symbolic name of one of the languages.json files. This Makefile may have to be adjusted to pass that along to Gaia's build system, depending how bug 812829 is implemented:
https://mxr.mozilla.org/mozilla-central/source/b2g/gaia/Makefile.in#39
* Pass something to the build system to indicate which directory the l10n repos will be in. Again, this may have to be forwarded in b2g/gaia/Makefile.in.

After those things, we should end up with a multilocale desktop build. Still not sure where we're going to alter the existing nightly desktop build for this or add a new one.
Note: We'll be modifying the existing RelEng desktop builds to include these these 6 locales. This was acked by Dietrich and Stas in e-mail.
Depends on: 815189
blocking-basecamp: --- → +
Target Milestone: --- → B2G C2 (20nov-10dec)
Setup of these is completely tracked in bug 812836.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 812836
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.