Closed Bug 808326 Opened 8 years ago Closed 8 years ago

[Browser] Offline page mentions “B2G”

Categories

(Firefox OS Graveyard :: General, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed, firefox20 fixed)

RESOLVED FIXED
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed
firefox20 --- fixed

People

(Reporter: nbp, Assigned: fabrice)

References

Details

(5 keywords)

Attachments

(3 files, 1 obsolete file)

STR:
1. Shutdown all connections (data, wifi). [also happens when no networks are reachable]
2. Open the browser.
3. Type "example.com" in the address bar [if not in your cache]

The following error page appear:

«
  Offline mode

  This document cannot be displayed while offline. To go online, uncheck Work Offline from the File menu

  Try again B2G will attenpt to open a connection and reload the page.
»

2 issues:
- Remove the mention of “File menu”.
- Replace B2G by Firefox OS.


Phone:
Platform 18.0a2
Build identifier 20121101155320
Git: 2012-11-01 09:44:34 https://github.com/mozilla-b2g/gaia/commit/0894302377ec0f
(In reply to Nicolas B. Pierron [:pierron] [:nbp] from comment #0)
> 2 issues:
> - Remove the mention of “File menu”.
> - Replace B2G by Firefox OS.

and
- It need to be localize (as well as the address bar message “Problem loading page”)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 803756
Gaia Triage : reopening this bug.  It's not a full dup.  B2G still is stated, the File Menu has been removed.  Branding issue, so marking +.

Please fix the branding issue portion (Firefox OS)
Status: RESOLVED → REOPENED
blocking-basecamp: ? → +
Priority: -- → P3
Resolution: DUPLICATE → ---
Cc'ing Axel because this might change with bug 796051.

We're pulling in the brand strings from brand.dtd:
http://mxr.mozilla.org/mozilla-central/source/b2g/locales/en-US/chrome/overrides/netError.dtd

Will an officially branded build be built with "Firefox OS" as the brandname? If so, this should be resolved by that.
Summary: [Browser] Offline page mention “B2G” and “File menu”. → [Browser] Offline page mentions “B2G”
Keywords: l12y
Moving this outside of the Gaia component because these error messages are handled by Gecko.
Component: Gaia::Browser → General
Flags: needinfo?(l10n)
Flags: needinfo?(l10n) → needinfo?(stas)
This will be fixed by bug 812830 which is about setting up the multilocale Gecko repacks with the right branding.
Depends on: 812830
Flags: needinfo?(stas)
Who should own this?
Flags: needinfo?(l10n)
Not sure who's owning this, we'll need a patch that's probably consistent with bug 811328 which changed branding within gaia itself. Stas might have some follow ups to that still, though, in particular on localizable vs non-localizable branding parts.

Note, we don't have infrastructure/code to modify branding within appstrings.properties for any of our products right now.
Flags: needinfo?(l10n)
Vivien was talking about having a constant for the product name earlier in the week, would this come under that work Vivien?
Flags: needinfo?(21)
(In reply to Ben Francis [:benfrancis] from comment #9)
> Vivien was talking about having a constant for the product name earlier in
> the week, would this come under that work Vivien?

Not really. This one is Gecko part and the variables in Gaia can not affect Gecko.
Flags: needinfo?(21)
Is there no-one on this bug that knows how to fix this? :(

Axel: Can you at least point us in the direction for where a fix would live?
It's not clear what the fix is, really. There are so many branding variants flying around, but they're not really crisp on how bad we can go for options that don't involve calling the browser app Firefox.

Next step is to make both the official and the non-official branding be called Mozilla Firefox in b2g/branding, IMHO. Then we'll be up-to-par with the Firefox-branded appstrings that we use.
Attached patch patch (obsolete) — Splinter Review
Simple patch to change the official string to "Firefox OS" instead of B2G. With that and --enable-official-branding in my mozconfig, I get the correct error pages.
Attached image Without branding
Attached image With branding
(In reply to Fabrice Desré [:fabrice] from comment #14)
> Created attachment 687124 [details]
> Without branding

This shows that we can hardly avoid calling the thing Firefox, as half the string there is from appstrings. I suggest we just be consistent and use "Firefox" here as well.

Also, we're branding the browser here, not the phone. thus I suggest to use "Firefox" instead of "Firefox OS"
Axel's comment makes good sense. This is the browser. Unless anyone strongly objects, let's go with Firefox.

Fabrice - Can you wrap this one up?
Assignee: nobody → fabrice
Attached patch patchSplinter Review
Using Firefox both for the unofficial and official branding strings.
Attachment #687122 - Attachment is obsolete: true
Attachment #687278 - Flags: review?(l10n)
Comment on attachment 687278 [details] [diff] [review]
patch

Review of attachment 687278 [details] [diff] [review]:
-----------------------------------------------------------------

I think we should add the logoTrademark for unofficial as we're using Firefox, r=me with that.

::: b2g/branding/unofficial/locales/en-US/brand.dtd
@@ +7,2 @@
>  <!ENTITY  vendorShortName "Mozilla">
>  <!ENTITY  logoTrademark   "">

Can you add the logoTrademark here, too?
Attachment #687278 - Flags: review?(l10n) → review+
https://hg.mozilla.org/mozilla-central/rev/6bb1e540c73f
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 815927
Blocks: 818907
You need to log in before you can comment on or make changes to this bug.