Last Comment Bug 812977 - Copy review for the bucket 2 string freeze
: Copy review for the bucket 2 string freeze
Status: RESOLVED FIXED
QARegressExclude
: l12y
Product: Firefox OS
Classification: Client Software
Component: Gaia (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks: 802572 806066 806067 809370 811686 812983 862590
  Show dependency treegraph
 
Reported: 2012-11-18 23:07 PST by Staś Małolepszy :stas
Modified: 2013-04-16 16:20 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+


Attachments
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6485/files (373 bytes, text/html)
2012-11-19 00:48 PST, Staś Małolepszy :stas
fabien: review+
Details

Description Staś Małolepszy :stas 2012-11-18 23:07:36 PST
Let's review the en-US strings for consistency, wording, style and grammar before we string-freeze for Bucket 2.
Comment 1 Staś Małolepszy :stas 2012-11-19 00:48:25 PST
Created attachment 683012 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6485/files

Pointer to Github pull-request
Comment 2 Staś Małolepszy :stas 2012-11-19 00:57:41 PST
Comment on attachment 683012 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6485/files

Kazé, the changes only touch .properties files.   I didn't change the string values in the HTML code.  It's mostly because I'd like to remove them entirely (bug 812993) so that would be a pointless exercise.
Comment 3 Scoobidiver (away) 2012-11-20 01:44:43 PST
Certain changes impact all locales (localizers wont' be warned of these changes as string labels are unchanged):
* Punctuation:
apps ⊃ dialer.properties ⊃ ussd-server-error
apps ⊃ settings.properties ⊃ shortStatus-connected
apps ⊃ settings.properties ⊃ shortStatus-connectingfailed
apps ⊃ settings.properties ⊃ shortStatus-disconnected
apps ⊃ costcontrol.properties ⊃ topup-confirmation-message
apps ⊃ costcontrol.properties ⊃ balance-error-message
apps ⊃ costcontrol.properties ⊃ application-error-message
apps ⊃ costcontrol.properties ⊃ top-up-in-progress
apps ⊃ costcontrol.properties ⊃ on-topup-not-confirmed-title
apps ⊃ email.properties ⊃ settings-password-empty
apps ⊃ settings.properties ⊃ fullStatus-connected
apps ⊃ settings.properties ⊃ fullStatus-connectingfailed
apps ⊃ settings.properties ⊃ fullStatus-disconnected
apps ⊃ settings.properties ⊃ shortStatus-connected
apps ⊃ settings.properties ⊃ shortStatus-connectingfailed
apps ⊃ settings.properties ⊃ shortStatus-disconnected
apps ⊃ settings.properties ⊃ fullStatus-wps-canceled
apps ⊃ settings.properties ⊃ fullStatus-wps-timedout
apps ⊃ settings.properties ⊃ fullStatus-wps-failed
apps ⊃ settings.properties ⊃ fullStatus-wps-overlapped
apps ⊃ settings.properties ⊃ retry-when-online
apps ⊃ system.properties ⊃ sdcard-in-use
* First letter upper case:
apps ⊃ contacts.properties ⊃ no-contacts
apps ⊃ contacts.properties ⊃ start-adding
apps ⊃ settings.properties ⊃ shortStatus-connecting
apps ⊃ settings.properties ⊃ security
apps ⊃ settings.properties ⊃ securityNone
apps ⊃ settings.properties ⊃ securityOpen
apps ⊃ settings.properties ⊃ password
apps ⊃ email.properties ⊃ envelope-cc
apps ⊃ email.properties ⊃ envelope-bcc
apps ⊃ email.properties ⊃ message-search-cancel-accessible
apps ⊃ settings.properties ⊃ error
apps ⊃ settings.properties ⊃ fullStatus-initializing
apps ⊃ settings.properties ⊃ fullStatus-connecting
apps ⊃ settings.properties ⊃ fullStatus-associated
apps ⊃ settings.properties ⊃ shortStatus-connecting
apps ⊃ settings.properties ⊃ shortStatus-associated
apps ⊃ settings.properties ⊃ securedBy
apps ⊃ settings.properties ⊃ security
apps ⊃ settings.properties ⊃ securityNone
apps ⊃ settings.properties ⊃ securityOpen
apps ⊃ settings.properties ⊃ linkSpeed
apps ⊃ settings.properties ⊃ signalStrength
apps ⊃ settings.properties ⊃ signalLevel0
apps ⊃ settings.properties ⊃ signalLevel1
apps ⊃ settings.properties ⊃ signalLevel2
apps ⊃ settings.properties ⊃ signalLevel3
apps ⊃ settings.properties ⊃ signalLevel4
apps ⊃ settings.properties ⊃ showPassword
apps ⊃ settings.properties ⊃ operator-status-connecting
apps ⊃ settings.properties ⊃ operator-status-connectingfailed
apps ⊃ settings.properties ⊃ operator-status-connected
apps ⊃ system.properties ⊃ confirm
* Other upper case:
apps ⊃ email.properties ⊃ dialog-button-ok
apps ⊃ email.properties ⊃ forward-header-cc
* Phrasing:
apps ⊃ settings.properties ⊃ doNotTrack-dd1
apps ⊃ sms.properties ⊃ deleteThreads-confirmation
Comment 4 Fabien Cazenave [:kaze] 2012-11-20 05:40:50 PST
Comment on attachment 683012 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6485/files

nice work, merging
Comment 5 Fabien Cazenave [:kaze] 2012-11-20 05:41:27 PST
err, cannot merge — the patch has bitrotten. Staś, would you rebase it please?
Comment 6 Staś Małolepszy :stas 2012-11-20 07:34:19 PST
Comment on attachment 683012 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6485/files

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined:  Inconsistent strings in the UI, 
Testing completed: on a desktop build everything works
Risk to taking this patch (and alternatives if risky): it's l10n-only, almost none
Comment 7 Vivien Nicolas (:vingtetun) (:21) - (NOT reading bugmails, needinfo? please) 2012-11-20 08:50:19 PST
This bug blocks some blockers. blocking+.
Comment 8 Staś Małolepszy :stas 2012-11-20 09:46:33 PST
Thanks!

A shout-out to Matej who found time in Singapore to go through all the Gaia apps and create this patch.  I just created the pull request and made a few minor tweaks :)
Comment 9 Josh Carpenter [:jcarpenter] 2012-11-23 09:13:13 PST
\ o /

Note You need to log in before you can comment on or make changes to this bug.