[Cost Control]: Cost Control widget is load eagerly at the startup of the system.

RESOLVED FIXED in B2G C2 (20nov-10dec)

Status

Firefox OS
Gaia
P3
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: salva, Assigned: salva)

Tracking

unspecified
B2G C2 (20nov-10dec)
x86_64
Linux

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

Repro:
1- Restart the device
2- Connect the device via USB
3- Use adb to open a shell in the device
4- Issue the command b2g-ps

Expected: No Cost Control is started during start-up, only when needed (CC application launched or widget shown)

Sample output:

Application      USER     PID   PPID  VSIZE  RSS     WCHAN    PC         NAME
b2g              root      3275  1     180612 60244 ffffffff 400f8330 S /system/b2g/b2g
Messages         app_0     3344  3275  57132  18684 ffffffff 40e1cb88 R /system/b2g/plugin-container
Homescreen       app_0     3453  3275  71648  25632 ffffffff 400d7594 R /system/b2g/plugin-container
(Preallocated a  app_0     3518  3275  38156  7716  ffffffff 400d1d86 R /system/b2g/plugin-container

Actual: Cost Control application is being launched during the start-up.

Sample output:

Application      USER     PID   PPID  VSIZE  RSS     WCHAN    PC         NAME
b2g              root      3275  1     180612 60244 ffffffff 400f8330 S /system/b2g/b2g
Messages         app_0     3344  3275  57132  18684 ffffffff 40e1cb88 R /system/b2g/plugin-container
Cost Control     app_0     3392  3275  65916  26320 ffffffff 400c6330 S /system/b2g/plugin-container
Homescreen       app_0     3453  3275  71648  25632 ffffffff 400d7594 R /system/b2g/plugin-container
(Preallocated a  app_0     3518  3275  38156  7716  ffffffff 400d1d86 R /system/b2g/plugin-container
Summary: [Cost Control]: Cost Control widget is load at the eagerly at the startup of the system. → [Cost Control]: Cost Control widget is load eagerly at the startup of the system.
Created attachment 683234 [details]
Removes the call to _ensureWidget that caused to open the widget at startup
Attachment #683234 - Flags: review?(francisco.jordano)
Attachment #683234 - Flags: review?(francisco.jordano) → review+
Attachment #683234 - Flags: approval-gaia-master+
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 810442
blocking-basecamp: ? → +
Priority: -- → P3

Comment 3

5 years ago
Cost Control is present as startup:

Actual Results:

mlevin@QAnalystsL55 ~
$ adb shell
root@android:/ # b2g-ps
b2g-ps
APPLICATION      USER     PID   PPID  VSIZE  RSS     WCHAN    PC         NAME
b2g              root      107   1     193932 70432 ffffffff 40099330 S /system/b2g/b2g
Cost Control     app_331   331   107   59268  21592 ffffffff 400c4330 S /system/b2g/plugin-container
Homescreen       app_395   395   107   73052  25268 ffffffff 40061330 S /system/b2g/plugin-container
(Preallocated a  app_419   419   107   55736  17348 ffffffff 4006b330 S /system/b2g/plugin-container
root@android:/ #
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Please file a followup bug for the issue you discovered and link them as dependencies. Don't reopen - it makes tracking blocking bugs a pain.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Blocks: 830011
Target Milestone: --- → B2G C2 (20nov-10dec)
You need to log in before you can comment on or make changes to this bug.