JSVAL_TO_OBJECT called on string in TimeZoneSettingObserver

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: jgilbert, Assigned: jgilbert)

Tracking

unspecified
All
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed, firefox20 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
This asserts and crashes in DEBUG builds, and should not be done. I am told JSStrings are not JSObjects.
(Assignee)

Updated

5 years ago
Depends on: 811414
(Assignee)

Comment 1

5 years ago
Created attachment 683282 [details] [diff] [review]
patch

Add an overload for JSAutoCompartment for JSString and use it.
Attachment #683282 - Flags: review?(bobbyholley+bmo)
Comment on attachment 683282 [details] [diff] [review]
patch

Seems fine to me, but bouncing to luke just in case.
Attachment #683282 - Flags: review?(bobbyholley+bmo) → review?(luke)
Duplicate of this bug: 813281

Updated

5 years ago
Attachment #683282 - Flags: review?(luke) → review+
(Assignee)

Updated

5 years ago
Blocks: 716859
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/26544b27ef13
Assignee: nobody → jgilbert
Status: NEW → ASSIGNED

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/26544b27ef13
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
blocking-basecamp: --- → ?

Comment 6

5 years ago
Basecamp blocking which needs to be merged into Aurora and Beta.
blocking-basecamp: ? → +
You need to log in before you can comment on or make changes to this bug.