Thunderbird 17.0 crashed with QuickText addon by EMET with DEP mitgation while entering address in mail creation window

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
critical
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: Peter Ohlerich, Unassigned)

Tracking

({crash})

17 Branch
x86_64
Windows 7
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [addon:QuickText])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121119183901

Steps to reproduce:

I tried to create an email. The creation window opens correctly. The first receipient can be entered. When trying to add a second (by pressing tab) TB crashes.


Actual results:

I tried to enter a second receipient. Name should be taken from local receipient history list or via LDAP. TB crashed with possibility of sending report (done). EMET 3.0 under Win7/64 EE gives a messages that TB is closed because of a DEP mitigation.
(Reporter)

Comment 1

5 years ago
error occurs every time after restarting TB and trying to create an email.
Keywords: crash

Comment 2

5 years ago
Please see the help information at http://support.mozillamessaging.com/en-US/kb/Mozilla-Crash-Reporter#w_viewing-crash-reports and find your crash ID(s), then post them here 

do you use quicktext addon?  Does crashing stop if you start thunderbird in safe mode?
Severity: normal → critical
(Reporter)

Comment 3

5 years ago
Hello!

Report IDs are:
bp-3e454fce-d42a-4d84-a185-6841e2121121
bp-6e2f0dcb-5ae1-40d5-9414-0a1d92121121
bp-92b1c878-caca-46a6-bed7-7c5802121121
The last one also contains my email address.

I just deactivated Quicktext addon and left all other addons enabled and the crash did not occur again. Seems that we found the bad guy.

Peter.

Comment 4

5 years ago
thanks.

triagers, let's leave this bug open until fix for bug 785370 is shipped, so that users are less likely file duplicate bugs
Status: UNCONFIRMED → NEW
Depends on: 785370
Ever confirmed: true
Summary: Thunderbird 17.0 closed by EMET with DEP mitgation while entering address in mail creation window → Thunderbird 17.0 crashed with QuickText addon by EMET with DEP mitgation while entering address in mail creation window
Whiteboard: [leave open]

Updated

5 years ago
Duplicate of this bug: 813928
Duplicate of this bug: 814132
(Reporter)

Comment 7

5 years ago
I updated Quicktext to 0.9.11.5 as this is mentioned as a fixed release on the Quicktext forums and it works.

Peter.

Comment 8

5 years ago
I encountered the same kind of problem; thanks to you all I got it fixed as well. I already used 0.9.11.5 but downloaded and installed a new version; that did the trick for me.
Duplicate of this bug: 831192

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Whiteboard: [leave open] → [addon:QuickText]
You need to log in before you can comment on or make changes to this bug.