X button missing in tabs tray after swiping to close another tab

VERIFIED FIXED in Firefox 20

Status

()

defect
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: bnicholson, Assigned: capella)

Tracking

unspecified
Firefox 20
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox19 affected, firefox20 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
To reproduce, swipe to close the last tab. On the new about:home tab that appears, the X is missing. If you instead close the last tab by hitting the X button, the X button reappears on the new tab as expected.
(Reporter)

Updated

7 years ago
Whiteboard: [mentor=sriram][lang=java]
(Reporter)

Comment 1

6 years ago
The bug is no longer relevant as originally filed since we now hide the tabs tray when the last tab is closed. But a similar issue happens with these STR:
1) Open at least 2 tabs
2) Swipe to close any tab other than the last one

After step 2, the tab that was below the one that was closed will be missing its X button. This is likely due to improperly handling recycled ListView items.
Summary: Swiping to close the last tab doesn't show a tab close button → X button missing in tabs tray after swiping to close another tab
Whiteboard: [mentor=sriram][lang=java]
(Assignee)

Comment 2

6 years ago
Posted patch Patch (v1)Splinter Review
Is it this easy?
Assignee: nobody → markcapella
Status: NEW → ASSIGNED
Attachment #693228 - Flags: review?(bnicholson)
(Reporter)

Comment 3

6 years ago
Comment on attachment 693228 [details] [diff] [review]
Patch (v1)

Passing review to sriram since he's mentoring this one.
Attachment #693228 - Flags: review?(bnicholson) → review?(sriram)
Comment on attachment 693228 [details] [diff] [review]
Patch (v1)

Review of attachment 693228 [details] [diff] [review]:
-----------------------------------------------------------------

This looks good to me.
Please remove the comment. That isn't needed there.
Attachment #693228 - Flags: review?(sriram) → review+
(Reporter)

Comment 5

6 years ago
Also, the closing brace is misaligned, so please correct the indentation.
(Assignee)

Comment 6

6 years ago
Push to TRY server like I always do...
https://tbpl.mozilla.org/?tree=Try&rev=a0e9408b13df
https://hg.mozilla.org/mozilla-central/rev/b757786d6828
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 20

Comment 9

6 years ago
Firefox 20.0a1 (2012-12-20)
Device: Galaxy Nexus
OS: Android 4.1.1

I am not able to reproduce the issue. will this land to Aurora to? or I can set this as VERIFIED FIXED?
(Reporter)

Comment 10

6 years ago
(In reply to Ioana Chiorean from comment #9)
> Firefox 20.0a1 (2012-12-20)
> Device: Galaxy Nexus
> OS: Android 4.1.1
> 
> I am not able to reproduce the issue. will this land to Aurora to? or I can
> set this as VERIFIED FIXED?

I can still reproduce this on Aurora - note that the STR have changed a bit (use the STR in comment 1, not comment 0).

Comment 11

6 years ago
(In reply to Brian Nicholson (:bnicholson) from comment #10)
> (In reply to Ioana Chiorean from comment #9)
> > Firefox 20.0a1 (2012-12-20)
> > Device: Galaxy Nexus
> > OS: Android 4.1.1
> > 
> > I am not able to reproduce the issue. will this land to Aurora to? or I can
> > set this as VERIFIED FIXED?
> 
> I can still reproduce this on Aurora - note that the STR have changed a bit
> (use the STR in comment 1, not comment 0).

I was reproducing it on Aurora too, that's why I've asked. It is verified only on Nightly. Will wait  for it to land in Aurora too. Thank you!

Comment 12

6 years ago
Closing bug as verified fixed, due to Bug 817675, on Nightly 21.0a1 (2013-02-10) and  Aurora 20.0a2 (2013-02-10), using HTC Desire Z (Android 2.3.3).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.