Invite Attendees dialog: lists do not work, only first list member is added

RESOLVED FIXED in 1.9.1

Status

Calendar
Dialogs
--
major
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Werner Huppertz, Assigned: Decathlon)

Tracking

({regression})

Lightning 1.9
1.9.1
regression

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

1 . Using list to enter members of an appointment in lightning
2. removing Members form an appointment


Actual results:

1. only the first name of the list will be entered. 
2. The Member could not be removed - OK - will not work in the dialog


Expected results:

1.The whole list ist normaly entered in the schedule atendee list. 
2. The attendee will removed, after - OK - the schedule will be saved.
(Reporter)

Updated

5 years ago
Severity: normal → major
Component: Untriaged → General
Priority: -- → P1

Comment 1

5 years ago
Might be a duplicate of Bug 815568. Do you agree?
(Reporter)

Comment 2

5 years ago
Yes it is the same behvior. But a second bug is detected, lists do not work, only first list member is added.

Updated

5 years ago
Severity: major → normal
Component: General → Dialogs
Priority: P1 → --
Product: Thunderbird → Calendar
Summary: Lightning Projekt does not work properly after update to 17.0 - and Lightinig 19.0 , Adressbook list only the first member is inserted in a schedule. Members of a appointment can not removed afterwards. → Invite Attendees dialog: lists do not work, only first list member is added
Version: 17 → Lightning 1.9
Werner, are you comfortable with applying patches or testing nightly builds? If so, could you either apply the patch in bug 815568 or wait for tomorrow's nightly builds and test them to see if your issue still exists?

Updated

5 years ago
Duplicate of this bug: 817314

Updated

5 years ago
Duplicate of this bug: 817953

Comment 6

5 years ago
Confirming based on the duplicated reports.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All

Updated

4 years ago
Duplicate of this bug: 828273

Updated

4 years ago
Duplicate of this bug: 828551

Comment 9

4 years ago
The patch mentioned in comment 3 landed in Lightning 2.0. Maybe someone could test if the problem still exists using one of the Thunderbird + Lightning test build combination listed in https://developer.mozilla.org/en-US/docs/Calendar/Calendar_Versions#Development_Snapshots
Severity: normal → major
Keywords: regression

Comment 10

4 years ago
I tried all the following TB+Lightning combinations:
17.0.2 + 1.9
18.0b1 + 2.0b1
19.0b1 + 2.1b1
20.0a2 + 2.2a2
Bug 1 is a problem in all these versions - I type a distribution list name when inviting attendees and press return. Only the first member of the distribution list is added to the attendee list.
Bug 2 - Removing members from an appointment - this worked for me in all the above versions. The OP listed 16.0, so perhaps this issue was fixed in 17.0.2+1.9?
(Assignee)

Comment 11

4 years ago
Created attachment 710226 [details] [diff] [review]
patch - v1

In the code there's a variable with a wrong name.
As far as I can see this patch fixes without other to add.
Assignee: nobody → bv1578
Status: NEW → ASSIGNED
Attachment #710226 - Flags: review?(matthew.mecca)

Comment 12

4 years ago
When I make the 1-line change to calendar-event-dialog-attendees.xml from 710226 (by hand[editing the appropriate line of the Lightning 1.9 addon code in my TB profile) it fixes the issue:
1 . Using list to enter members of an appointment in lightning
So this fix will backporrt very easily, if a Lightning bugfix release is done to go with the Thunderbird 17.0.n official release sequence.
Comment on attachment 710226 [details] [diff] [review]
patch - v1

Looks good, I think we should take this for 1.9.1
Attachment #710226 - Flags: review?(matthew.mecca)
Attachment #710226 - Flags: review+
Attachment #710226 - Flags: approval-calendar-release+
Attachment #710226 - Flags: approval-calendar-beta+
Attachment #710226 - Flags: approval-calendar-aurora+
Whiteboard: [wanted-1.9.x]
Pushed to comm-central - https://hg.mozilla.org/comm-central/rev/6c463991fbfe
Target Milestone: --- → 2.3
comm-aurora - https://hg.mozilla.org/releases/comm-aurora/rev/8496b69a7387
comm-beta - https://hg.mozilla.org/releases/comm-beta/rev/4628e739fc07
Target Milestone: 2.3 → 2.1
comm-esr17 - https://hg.mozilla.org/releases/comm-esr17/rev/48a7e6a5f754
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: 2.1 → 1.9.1
Whiteboard: [wanted-1.9.x]

Comment 17

4 years ago
Hi,

This is bug marked as RESOLVED, but which versions of thunderbird have it resolved?

The problem still happens on 

thunderbird  17.0.7+build1-0ubuntu0.12.04.1

installed today.

Best regards

Comment 18

4 years ago
It is fixed in Lightning 1.9.1 that was released on March 6, 2013. Maybe you are still using Lightning 1.9?

Comment 19

4 years ago
Stefan, you are right. I'm using Lightning 1.9.

Thanks for your comment. I will upgrade and report back.

Comment 20

4 years ago
It is indeed fixed on Lightning 1.9.1 (tested with Thunderbird 17.0.7) Thanks again.
You need to log in before you can comment on or make changes to this bug.