Elm branch should use the whole pool of Win64 builders rather than a subset

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
6 years ago
a month ago

People

(Reporter: armenzg, Assigned: armenzg)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Assignee)

Description

6 years ago
Once we use the whole pool again we should take the subset of slaves and re-image them like the rest of the pool.
(Assignee)

Updated

6 years ago
Depends on: 774910
(Assignee)

Comment 1

6 years ago
After speaking with dustin, we will push the re-imaging of the custom builders later on as we don't currently have a Windows guy.

For now, we will add post-imaging steps for win64 slaves:
https://wiki.mozilla.org/ReleaseEngineering/How_To/Set_Up_a_Freshly_Imaged_Slave#Windows_2008_64-bit_.28MDT_.26_unmanaged.29
which leads to:
https://wiki.mozilla.org/ReferencePlatforms/Win64#Post-reimaging_steps
(Assignee)

Comment 2

6 years ago
Created attachment 688003 [details] [diff] [review]
remove win64-metro platform
Attachment #688003 - Flags: review?(coop)
(Assignee)

Comment 3

6 years ago
Created attachment 688004 [details] [diff] [review]
puppet changes for win64-metro
Attachment #688004 - Flags: review?(coop)
(Assignee)

Comment 4

6 years ago
Comment on attachment 688003 [details] [diff] [review]
remove win64-metro platform

wrong patch
Attachment #688003 - Flags: review?(coop)
(Assignee)

Comment 5

6 years ago
Created attachment 688024 [details] [diff] [review]
remove win64-metro platform
Attachment #688003 - Attachment is obsolete: true
Attachment #688024 - Flags: review?(coop)
(Assignee)

Updated

6 years ago
Blocks: 754399
(Assignee)

Updated

6 years ago
No longer depends on: 774910

Updated

6 years ago
Attachment #688004 - Flags: review?(coop) → review+

Comment 6

6 years ago
Comment on attachment 688024 [details] [diff] [review]
remove win64-metro platform

Review of attachment 688024 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with the nit fixed.

::: mozilla/production_config.py
@@ -12,1 @@
>  MOCK_DL120G7   = ['bld-centos6-hp-%03d' % x for x in range(6,24)] # 5 staging, 17 prod, 17 try

Shouldn't we remove the WIN64_METRO definition from line 11 also?
Attachment #688024 - Flags: review?(coop) → review+
(Assignee)

Updated

6 years ago
Attachment #688024 - Flags: checked-in+

Comment 7

6 years ago
We're getting some exception on the elm builders, wondering if this checkin might be the cause?

remoteFailed: [Failure instance: Traceback (failure with no frames): <class 'twisted.spread.pb.PBConnectionLost'>: [Failure instance: Traceback (failure with no frames): <class 'twisted.internet.error.ConnectionDone'>: Connection was closed cleanly.

https://tbpl.mozilla.org/?noignore=0&tree=Elm
(Assignee)

Comment 8

6 years ago
Created attachment 689303 [details] [diff] [review]
fix list of slaves

The slaves that took the jobs where the known ones:
WIN64_METRO    = ['w64-ix-slave%02i' % x for x in [11,20,42,43]] 

Unfortunately without this patch those 5 slaves would get the jobs assigned but in reality they had no master to talk to.

They were living dead; caught between two realms.

I will shut them down until this patch makes it into production.
Attachment #689303 - Flags: review?(coop)

Comment 9

6 years ago
Comment on attachment 689303 [details] [diff] [review]
fix list of slaves

Review of attachment 689303 [details] [diff] [review]:
-----------------------------------------------------------------

Hrmmm, didn't I suggest this already with the previous patch in comment #6?
Attachment #689303 - Flags: review?(coop) → review+
(Assignee)

Comment 10

6 years ago
Comment on attachment 689303 [details] [diff] [review]
fix list of slaves

I completely missed it :S
Attachment #689303 - Flags: checked-in+
(Assignee)

Updated

6 years ago
Attachment #688004 - Flags: checked-in+
(Assignee)

Comment 11

6 years ago
Created attachment 689723 [details] [diff] [review]
enable bundles for Elm
Assignee: nobody → armenzg
Attachment #689723 - Flags: review?(catlee)

Updated

6 years ago
Attachment #689723 - Flags: review?(catlee) → review+
(Assignee)

Updated

6 years ago
Attachment #689723 - Flags: checked-in+
(Assignee)

Updated

6 years ago
Blocks: 819357
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.