Closed Bug 815801 Opened 7 years ago Closed 7 years ago

Remove all of the site specific user agent overrides as part of backing out bug 588909 [port bug 815743]

Categories

(SeaMonkey :: Preferences, defect)

defect
Not set

Tracking

(seamonkey2.14+ fixed, seamonkey2.15 fixed, seamonkey2.16 fixed, seamonkey2.17 fixed)

RESOLVED FIXED
seamonkey2.17
Tracking Status
seamonkey2.14 + fixed
seamonkey2.15 --- fixed
seamonkey2.16 --- fixed
seamonkey2.17 --- fixed

People

(Reporter: InvisibleSmiley, Assigned: InvisibleSmiley)

References

Details

Attachments

(1 file, 1 obsolete file)

We live in turbulent times. It's really funny to see how Mozilla turns its hundreds of millions of release users into beta testers. But I digress...

Bug 815743, which just landed pretty much everywhere, reverts bug 588909 ("Replace Gecko/<date> with Gecko/<version> in UA string"). Besides changes to configure.in that I cannot really comment on ("Part 1") it removed again all newly introduced prefs for site-specific UA overrides ("Part 2") since obviously there's nothing to override anymore once the default UA is back to normal.

As I said no idea about configure.in (Callek, ewong?). Otherwise on our side we need to revert the changes made in bug 801318 and bug 809517.
Attached patch remove UA overrides (obsolete) — Splinter Review
Attachment #685835 - Flags: review?(iann_bugzilla)
Attachment #685835 - Flags: review?(iann_bugzilla) → review+
(In reply to Jens Hatlak (:InvisibleSmiley) from comment #0)
> As I said no idea about configure.in (Callek, ewong?). Otherwise on our side
> we need to revert the changes made in bug 801318 and bug 809517.

As far as I can see comm-central would need the MOZ_UA_BUILDID change, but not 100% sure.
Comment on attachment 685835 [details] [diff] [review]
remove UA overrides

[Triage Comment]
Needed on c-a and c-b so approving
Will leave build team to decide on c-r
Attachment #685835 - Flags: approval-comm-beta+
Attachment #685835 - Flags: approval-comm-aurora+
Base bug 815743 has been backed out "because of leaks" for now. Thankfully I had already decided to delay landing anything on our side until it has baked a bit on the m-c side of things... Anyway I guess we need to closely monitor the situation and make sure to stay in sync with any actions taken on the core side, esp. wrt. the release branch.
> -pref("general.useragent.complexOverride.moodle", true); // bug 797703
The leak was caused by removing this line. Leave this in but flip it to false.
(In reply to Philip Chee from comment #5)
> > -pref("general.useragent.complexOverride.moodle", true); // bug 797703
> The leak was caused by removing this line. Leave this in but flip it to
> false.

OK, makes sense. Anyone feel free to land the patch with that addressed (I can't for ~10 hours).
Patch with comment 5 addressed
Attachment #685835 - Attachment is obsolete: true
Attachment #686283 - Flags: review+
Attachment #686283 - Flags: approval-comm-beta+
Attachment #686283 - Flags: approval-comm-aurora+
Comment on attachment 686283 [details] [diff] [review]
remove UA overrides v2 [Checkin: Comment 8]

http://hg.mozilla.org/comm-central/rev/2d4a1f0d87e9
Attachment #686283 - Attachment description: remove UA overrides v2 → remove UA overrides v2 [Checkin: Comment 8]
Target Milestone: --- → seamonkey2.17
Comment on attachment 686283 [details] [diff] [review]
remove UA overrides v2 [Checkin: Comment 8]

We need this on SM 2.14.1 as well. The core backout patch landed on all branches including ESR17
Attachment #686283 - Flags: approval-comm-release+
Blocks: 816749
You need to log in before you can comment on or make changes to this bug.