Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Override the UA string for Moodle to get the rich text editor rather than plain textareas (Port Bug 799502).

RESOLVED FIXED in seamonkey2.16

Status

SeaMonkey
Preferences
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Philip Chee, Assigned: Philip Chee)

Tracking

Trunk
seamonkey2.16

SeaMonkey Tracking Flags

(seamonkey2.14 fixed, seamonkey2.15 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
> Steps to reproduce:
> 
> Example site to use can be http://demo.moodle.net/user/edit.php?id=5&course=1 
> where after using demo login as student, the "description" field should be rich 
> text.
> 
> Actual results:
> 
> The textarea which should have progressively enhanced stays as a textarea.
> 
> Expected results:
> 
> It should have shown all the rich text buttons and things.

References:

Bug 799502 - Override the UA string for moodle to get the rich text editor rather than plain textareas.
  Bug 797703 - moodle serves plain textarea instead of rich text editor.
Bug 797363 - Remove aol.com user agent override since mail.aol.com is fixed.
(Assignee)

Comment 1

5 years ago
Created attachment 671113 [details] [diff] [review]
Patch v1.0 Moodle UA Override.

> -pref("general.useragent.override.aol.com", "Gecko/[^ ]*#Gecko/20100101");
This is from Bug 797363 - Remove aol.com user agent override since mail.aol.com is fixed.
Attachment #671113 - Flags: review?(iann_bugzilla)

Comment 2

5 years ago
Comment on attachment 671113 [details] [diff] [review]
Patch v1.0 Moodle UA Override.

r=me though probably needs someone familiar with using Moodle to fully test it.
Attachment #671113 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 3

5 years ago
From Bug 797703 - moodle serves plain textarea instead of rich text editor

1. Go to http://demo.moodle.net/login/index.php
2. Login as student/demo
3. The Description textarea should turn into a rich text editor.
(Assignee)

Comment 4

5 years ago
Comment on attachment 671113 [details] [diff] [review]
Patch v1.0 Moodle UA Override.

Pushed to comm-central:
http://hg.mozilla.org/comm-central/rev/06cde2eba4e8

Base bug landed on mozilla-beta and mozilla-aurora. See Bug 799502 Comment 10.

[Approval Request Comment]
Regression caused by (bug #): Bug 799502.
User impact if declined: plain textarea instead of rich text editor on moodle (worse user experience).
Testing completed (on m-c, etc.): Base bug tested on m-c, this patch tested on c-c.
Risk to taking this patch (and alternatives if risky): reasonably low risk, and the User Agent override for moodle can be disabled via a pref.
String changes made by this patch: none.
Attachment #671113 - Flags: approval-comm-beta?
Attachment #671113 - Flags: approval-comm-aurora?
(Assignee)

Comment 5

5 years ago
> Regression caused by (bug #): Bug 799502.
Actually Bug 588909

Comment 6

5 years ago
Comment on attachment 671113 [details] [diff] [review]
Patch v1.0 Moodle UA Override.

Need to make a branch-safe patch because contains() doesn't exist on beta and got turned off on aurora by bug 793781.
Attachment #671113 - Flags: approval-comm-beta?
Attachment #671113 - Flags: approval-comm-beta-
Attachment #671113 - Flags: approval-comm-aurora?
Attachment #671113 - Flags: approval-comm-aurora-
(Assignee)

Comment 7

5 years ago
Created attachment 672799 [details] [diff] [review]
Patch v1.0 Moodle UA Override. Branch safe patch. Carrying forward r=IanN

Regression caused by (bug #): Bug 588909/Bug 799502.
User impact if declined: plain textarea instead of rich text editor on moodle (worse user experience).
Testing completed (on m-c, etc.): Base bug tested on m-c, this patch tested on c-c.
Risk to taking this patch (and alternatives if risky): reasonably low risk, and the User Agent override for moodle can be disabled via a pref.
String changes made by this patch: none.
Attachment #672799 - Flags: review+
Attachment #672799 - Flags: approval-comm-beta?
Attachment #672799 - Flags: approval-comm-aurora?

Updated

5 years ago
Attachment #672799 - Flags: approval-comm-beta?
Attachment #672799 - Flags: approval-comm-beta+
Attachment #672799 - Flags: approval-comm-aurora?
Attachment #672799 - Flags: approval-comm-aurora+
http://hg.mozilla.org/releases/comm-beta/rev/be7a76ff1608
status-seamonkey2.14: --- → fixed
(Assignee)

Comment 9

5 years ago
Pushed to comm-aurora:
http://hg.mozilla.org/releases/comm-aurora/rev/8bf74bea06a4
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-seamonkey2.15: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.16
Blocks: 815801
You need to log in before you can comment on or make changes to this bug.