Closed Bug 815870 Opened 8 years ago Closed 8 years ago

[bluetooth] No notification on lock screen

Categories

(Firefox OS Graveyard :: Gaia::Bluetooth, defect)

x86
macOS
defect
Not set
normal

Tracking

(blocking-basecamp:-, b2g18+ fixed)

VERIFIED FIXED
blocking-basecamp -
Tracking Status
b2g18 + fixed

People

(Reporter: zfang, Assigned: iliu)

References

Details

(Keywords: late-l10n, Whiteboard: interaction)

Attachments

(1 file)

When receiving a bluetooth request, there's no notification if the screen is locked, only a vibration.
Casey and Evelyn, what's the intended UX here? Is this final?
Flags: needinfo?(kyee)
Whiteboard: interaction
cc. Ian

This is how it should behave.   When you unlock the phone however, you should get the Bluetooth receive file dialogue.
Flags: needinfo?(kyee)
Casey,

I summarize the behavior for fixing the issue according our discussion in mail.

In case of receiving a bluetooth request:
When passcode is enabled:
BT received file notification -> user un-lock screen -> enter passcode -> user taps on notification to open the request -> show confirmation of receiving file dialog

When passcode is not enabled:
BT received file notification -> user un-lock screen -> user taps on notification to open the request -> show confirmation of receiving file dialog

The change is having a notification when BT received file request.
It will turn on the screen and follow our lock screen mechanism with passcode.
The scenario is same with the incoming SMS message.
But user need to tap the notification, then showing the Bluetooth receive file dialogue.

Do you agree with the solution?
blocking-basecamp: --- → ?
Flags: needinfo?(kyee)
Triage: BB-, since user gets a notification and after unlock the screen, user can see the dialog. Nice to fix. tracking-b2g18+
blocking-basecamp: ? → -
tracking-b2g18: --- → +
Assignee: nobody → iliu
Hi Ian,
Makes sense to me.
Flags: needinfo?(kyee)
Comment on attachment 705785 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7771

Show notification message of receiving file confirmation before show the confirmation dialog.
Sync the behavior with SMS app(Incoming message).

Alive,
Could you please help to review my pr?
Thank you.
Attachment #705785 - Flags: review?(alive)
Comment on attachment 705785 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7771

r=me
Attachment #705785 - Flags: review?(alive) → review+
https://github.com/mozilla-b2g/gaia/pull/7771
Since the pr is merged, we can close the issue now.
Thanks for Alive's review effort.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Stas,
I add two new strings in the pull request.

notification-fileTransfer-title=Receive file?
notification-fileTransfer-description=File incoming from another device
Keywords: late-l10n
(In reply to Ian Liu [:ianliu] from comment #10)
> Stas,
> I add two new strings in the pull request.
> 
> notification-fileTransfer-title=Receive file?
> notification-fileTransfer-description=File incoming from another device

Pike or Stas, if the patch is going to master only instead of tef or shira branch, do we need late-l10n review?
Reopening as this does not seem fixed in 2013-02-05-07-02-01 pvt nightly b2g18 build:

- When passcode is not enabled and screen is locked: there is no notification message whatsoever. Even once screen is unlocked.
- When passcode is enabled and screen is locked: No BT received file notification. Unlock the phone, and then there is the notification message asking if we accept the transfer

* Expected results (as per comment 3):

When passcode is not enabled:
BT received file notification -> user un-lock screen -> user taps on notification to open the request -> show confirmation of receiving file dialog

When passcode is enabled:
BT received file notification -> user un-lock screen -> enter passcode -> user taps on notification to open the request -> show confirmation of receiving file dialog
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to delphine from comment #12)
> When passcode is not enabled:
> BT received file notification -> user un-lock screen -> user taps on
> notification to open the request -> show confirmation of receiving file
> dialog
> 
> When passcode is enabled:
> BT received file notification -> user un-lock screen -> enter passcode ->
> user taps on notification to open the request -> show confirmation of
> receiving file dialog

This sounds good to me as a solution.

cc. Neo for any additional comment he may have.
(In reply to delphine from comment #12)
> Reopening as this does not seem fixed in 2013-02-05-07-02-01 pvt nightly
> b2g18 build:
For your mention, the patch was merged in Gaia master. If you want to verify the issue, you should use mozilla-central build. Since the issue is not nominated with "approval‑gaia‑v1", I prefer to close it.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Comment on attachment 705785 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7771

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): No implementation.
User impact if declined: Cannot notify user in screen off mode.
Testing completed: 
Risk to taking this patch (and alternatives if risky): Low

In order to improve interaction for Bluetooth file transferring, I nominate it to "approval-gaia-v1".
Attachment #705785 - Flags: approval-gaia-v1?
If this causes a problem for l10n we can't uplift, can someone confirm that there will be time to get the new string localized?  We don't want to add English-only notifications at this stage.
It's not a problem for Spanish.

CC'ing brazil folks.
Comment on attachment 705785 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7771

Before we talk about uplift, I'd like to make sure the strings are 100% there. Josh?

https://github.com/mozilla-b2g/gaia/pull/7771/files#L1R196 has

+notification-fileTransfer-title=Receive file?
+notification-fileTransfer-description=File incoming from another device
Attachment #705785 - Flags: review?(jcarpenter)
Sorry for the delayed response. Reviewing the strings, I see:

> Title: Accept Bluetooth file transfer?
> Body: {{deviceName}} would like to transfer {{fileName}} ({{fileSize}}).

... for the prompt. And:

> Title: Receive file?
> Body: File incoming from another device

Those seem inconsistent, and I do not think the notification messaging is clear enough. What file? Where is it coming from? By what channel? I recommend something more along the lines of:

> Title: {{deviceName}} wants to Bluetooth transfer a file
> Body: Review the request

Casey, I defer to your judgement on this one
Flags: needinfo?(kyee)
Attachment #705785 - Flags: review?(jcarpenter) → review?(kyee)
Comment on attachment 705785 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/7771

Please re-nominate once this has received full review.
Attachment #705785 - Flags: approval-gaia-v1?
(In reply to Josh Carpenter [:jcarpenter] from comment #19)
> > Title: {{deviceName}} wants to Bluetooth transfer a file
> > Body: Review the request

Let's drop "Bluetooth" since we already have the icon.

Title: {{deviceName}} wants to transfer a file.
Body: Review the request.
Flags: needinfo?(kyee)
For the modification, I have to highlight that it will make the truncated issue easily in title line. 

Such as:
"rudy's unagi1 wants to tra...  8m ago"

I remember that we have a discussion about the space-width of title. If UX feel available for the situation, I'll give the patch soon.

Need info Casey again.
Flags: needinfo?(kyee)
Duplicate of this bug: 835239
OEM suggested to have this fix. tef? here.
blocking-b2g: --- → tef?
(clearing tef? as bug 835239 does not seem like a critical partner request for v1.0.1 at this time)
blocking-b2g: tef? → ---
Uplifted commit 78c7bade341d464412d72477e3de6062433c28cf as:
v1-train: ef00d50a992ea9e2013093ce861135abfad346af
Duplicate of this bug: 848629
Title: {{deviceName}} 
Body: Review transfer request.

The full screen prompt display the filename and size, is that correct?
Flags: needinfo?(kyee)
(In reply to Casey Yee [:cyee] from comment #28)
> Title: {{deviceName}} 
> Body: Review transfer request.

Let's modify the notification message in Bug 850978.

> 
> The full screen prompt display the filename and size, is that correct?

Yes, the prompt display the deviceName, fileName, and fileSize.

> Title: Accept Bluetooth file transfer?
> Body: {{deviceName}} would like to transfer {{fileName}} ({{fileSize}}).
Attachment #705785 - Flags: review?(kyee)
we use the new build version. It also can not receive any notification if the screen is locked. we must unlock screen and it has a request.
build information:
gaia commit:
3e7dda8 Merge pull request #9142 from asutherland/land-drafts-backend-v1.0.1
gecko commit:
d7a6db4 Bug 860892 - IPC failure handling in CompositorChild and ShadowLayers. r=jmuizelaar, a=tef+
(In reply to Firefox_Mozilla from comment #30)
> we use the new build version. It also can not receive any notification if
> the screen is locked. we must unlock screen and it has a request.
> build information:
> gaia commit:
> 3e7dda8 Merge pull request #9142 from asutherland/land-drafts-backend-v1.0.1
> gecko commit:
> d7a6db4 Bug 860892 - IPC failure handling in CompositorChild and
> ShadowLayers. r=jmuizelaar, a=tef+

https://github.com/mozilla-b2g/gaia/commit/ef00d50a992ea9e2013093ce861135abfad346af
Because of the fixing patch is not landed in v1.0.1. Please reference comment 25 for the reason. In my opinion, I would like the fixing to land in v1.0.1. It will help an user to catch the notification in screen off mode.
Gaia:     0f1f1ab0ab31a1df8a780baa048b5e7b2854205d
  B-D     2013-08-15 06:32:03
Gecko:    http://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/bd0864949c0f
BuildID   20130815042201
Version   18.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.