Closed Bug 818363 Opened 7 years ago Closed Last year

crash in mozilla::MediaPluginHost::CreateDecoder @ _ZN7android12DRMExtractor11getMetaDataEv

Categories

(Core :: Audio/Video: Playback, defect, P5, critical)

ARM
Android
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox20 --- affected
firefox21 --- affected
fennec + ---

People

(Reporter: alex_mayorga, Unassigned)

References

Details

(Keywords: crash, reproducible, Whiteboard: [native-crash][leave open])

Crash Data

Attachments

(3 files, 1 obsolete file)

This bug was filed from the Socorro interface and is 
report bp-d8c9d07d-4158-430b-8ed2-55aad2121205 .
=============================================================
alogcat from around the crash.
What device is this? If it's a sony ericsson device it may be a variant of bug 817478. That bug only fixes ICS (Android 4.0.x) so may need similar for Gingerbread which this device seems to have.
Component: General → Video/Audio
Product: Firefox for Android → Core
Hardware: All → ARM
Summary: crash in @0x0 → crash in mozilla::MediaPluginHost::CreateDecoder @ _ZN7android12DRMExtractor11getMetaDataEv
Whiteboard: [native-crash]
Version: unspecified → Trunk
(In reply to Chris Double (:doublec) from comment #2)
> What device is this? If it's a sony ericsson device it may be a variant of
> bug 817478. That bug only fixes ICS (Android 4.0.x) so may need similar for
> Gingerbread which this device seems to have.

This is from a Sony Ericsson MK16a with Android 2.3.4
http://popcornjs.org triggers this crash on load.
Keywords: reproducible
I can also reproduce on Sony Ericsson ST18i (Xperia Ray) with Android 2.3.4.

https://crash-stats.mozilla.com/report/index/1e2dc9f7-a6e3-4f37-abd0-8be732130219
Reproducible on the Sony Xperia Play (Android 2.3.4) by force-enabling stage-fright and visiting  http://people.mozilla.com/~kbrosnan/tmp/829454/829454.mp4
tracking-fennec: --- → ?
I've requested a Sony Xperia Play for testing.
tracking-fennec: ? → +
I confirm I see this on the Xperia Play if I force enable libstagefright.
Bug 860599 will hopefully be the fix for this bug.
Depends on: 860599
Assignee: nobody → chris.double
This bug is only apparent if the user forces libstagefright decoding on using about:config, right? The device in question is blocklisted on gingerbread. Is it actually occurring on non-force enabled devices?
(In reply to Chris Double (:doublec) from comment #10)
> This bug is only apparent if the user forces libstagefright decoding on
> using about:config, right? 
No. In 21.0 Beta Samsung devices are allowed on Gingerbread, and in 20.0 it happens on JB with Sony devices.
Anyway, it's a low volume crash.
(In reply to Scoobidiver from comment #11)
> No. In 21.0 Beta Samsung devices are allowed on Gingerbread, 

For some reason I thought this was only Sony devices. Is there a list of affected devices?
(In reply to Chris Double (:doublec) from comment #12)
> Is there a list of affected devices?
With so few crashes, you can check them manually: https://crash-stats.mozilla.com/report/list?signature=%400x0+|+_ZN7android12DRMExtractor11getMetaDataEv
In 21.0, it's only Samsung SGH-T989.
Attachment #739402 - Flags: review?(bjacob)
Attachment #739402 - Flags: review?(bjacob) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/81535ab3be45
Whiteboard: [native-crash] → [native-crash][leave open]
Attached patch Removes SGH-T989 from blocklist (obsolete) — Splinter Review
This removes the Samsung TGH-T989 from the blocklist now that bug 860599 is done.
Attachment #769586 - Attachment is obsolete: true
Attachment #797060 - Flags: review?(bjacob)
Attachment #797060 - Flags: review?(bjacob) → review+
Status: NEW → ASSIGNED
Is this still an issue?
filter on [mass-p5]
Priority: -- → P5
Assignee: cajbir.bugzilla → nobody
Component: Audio/Video → Audio/Video: Playback
Closing because no crash reported since 12 weeks.
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.