Mark All Read is very slow (Atleast from keyboard shortcut)

VERIFIED FIXED

Status

VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Roger.Martensson, Assigned: sspitzer)

Tracking

({perf})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
It is very slow to Mark All as Read in newsgroups.
(Not tested with Mail because I usually delete my mail =))

Build ID: 2001051920
Newsserver: news.mozilla.org
I'm seeing this on CVS pulled at 1600 UTC today, 20th May. Linux, kernel 2.4.5.
It took about 20s on a PIII 450 to mark some 40 messages in newsgroup
uk.religion.christian

Updated

18 years ago
Keywords: perf

Updated

18 years ago
QA Contact: esther → fenella

Comment 2

18 years ago
Not good - I wonder if we're committing the db or newsrc too frequently.

Comment 3

18 years ago
Confirm this bug using these builds.
Linux (2001-05-21-08 trunk)
Win32 (2001-05-21-11 trunk)
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
For the last few weeks using nightlies on Win2K, I've noticed this little quirk:
 If you go to a newsgroup, grab a bunch of messages, and then Mark All Read, it
takes a long time.  However, if you grab all your messages, go to ANOTHER
newsgroup, and then go back to the first one, Mark All Read works instantly. 
(This happens whether used from keyboard shortcut or menu item.)
*** Bug 85983 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
Posting from n.p.m.performance & n.p.m.mail-news 

Jiri Znamenacek wrote:
>
> subscibe to several big newsgroups and for various reasons I always download 
> all headers. Marking 1500 of headers as read take up ~30 seconds (not speaking 
> about newsgroups with >10000 messages ;-). During this time Mozilla itself is 
> completely cut off and computer running it is not very useable at all. Tested 
> with some late nightly build on W2k and Linux.
> 
>     Jirka 
>
>  PS: On the other hand - Mozilla Mail and pine are the only mail clients
>      I use ^_^ > 

Comment 7

18 years ago
someone should test this again.. it may not be a bug anymore.
In a current linux cvs build "Mark newsgroup read" is suddenly close to
instantanous :)) Great performance boost.

Comment 8

18 years ago
We rewrote the frontend for that in the folder_outliner, so maybe we fixed this
bug.  If so, that's great news I suppose. :)

Comment 9

18 years ago
*** Bug 95313 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
Marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 11

18 years ago
this is fixed for me.  1200 newsgroup messages marked read in under 2 secs from
the keyboard.  Thanks!

Comment 12

18 years ago
Win32 (2001-08-21-11 trunk)
Linux (2001-08-21-06 trunk)
Mac (2001-08-21-08 trunk)
This bug is gone.
Status: RESOLVED → VERIFIED

Comment 13

18 years ago
*** Bug 96208 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.