Closed Bug 818841 Opened 8 years ago Closed 8 years ago

Regression: SVG mask crops text and paths incorrectly

Categories

(Core :: SVG, defect)

17 Branch
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Tracking Status
firefox18 - ---
firefox19 - ---

People

(Reporter: tobias.weiss, Assigned: jwatt)

References

Details

(Keywords: regression, testcase)

Attachments

(2 files)

Attached image example1_path.svg
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0
Build ID: 20121128204232



Actual results:

Just open the attached file in FF 17.0.1. The first example shows about a quarter of the real symbol (a bed) although the mask is just a thin rectangle not touching the symbol at all.

When opening the second example, you don't see anything in FF 17.0.1. It's a simple text ("My Text") in the middle of the SVG.

Both examples work just fine in FF 16, Chrome and even IE9 (on Windows7).
Component: Untriaged → SVG
Product: Firefox → Core
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/688734575830
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120802041638
Bad:
http://hg.mozilla.org/mozilla-central/rev/074fb996dfd7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120802062038
Pushlog
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=688734575830&tochange=074fb996dfd7


Regression window(m-c)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a799b5bff84c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120801155239
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b077c43a4306
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20120801163038
Pushlog
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a799b5bff84c&tochange=b077c43a4306

Suspected: Bug 776054
Blocks: 776054
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Is this related to or a dupe of bug 797507?
OS: Windows 7 → All
Hardware: x86_64 → All
While this regression is unfortunate, please re-nominate if we believe that this will impact a significant number of SVGs in the wild.
Fixed by bug 806432.
Status: NEW → RESOLVED
Closed: 8 years ago
Depends on: 806432
Resolution: --- → FIXED
Verified fixed FF 19b4 Win 7, Ubuntu 12.04 and Mac OS X 10.7.5
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.