Closed Bug 819028 Opened 7 years ago Closed 6 years ago

[Win7] crash in gfxWindowsPlatform::UpdateRenderMode @ CResource::InvalidAlignment (d3d11.dll, after installing KB2670838) with Asus Gamer OSD

Categories

(Core :: Graphics, defect, critical)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 812683
Tracking Status
firefox18 - ---
firefox20 + affected
firefox21 --- affected

People

(Reporter: kairo, Unassigned)

References

Details

(Keywords: crash, qawanted, steps-wanted, Whiteboard: [startupcrash])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-8c1151ca-eebc-4313-892b-501052121206 .
============================================================= 

Top frames:

0 		@0x2827ff4 	
1 	d3d11.dll 	CResource<ID3D11Resource>::InvalidAlignment 	
2 	d3d11.dll 	CContext::EmptyOutAllAPIAndDDIBindPoints 	
3 	d3d11.dll 	CDevice::LLOBeginLayerDestruction 	
4 	d3d11.dll 	CBridgeImpl<ILayeredLockOwner,ID3D11LayeredDevice,CLayeredObject<CDevice> >::LLO 	
5 	d3d11.dll 	NDXGI::CDevice::LLOBeginLayerDestruction 	
6 	d3d11.dll 	CBridgeImpl<ILayeredLockOwner,ID3D11LayeredDevice,CLayeredObject<NDXGI::CDevice> 	
7 	d3d11.dll 	NOutermost::CDevice::LLOBeginLayerDestruction 	
8 	d3d11.dll 	TComObject<NOutermost::CDevice>::FinalRelease 	
9 	d3d11.dll 	TComObject<NOutermost::CDevice>::~TComObject<NOutermost::CDevice> 	
10 	d3d11.dll 	TComObject<NOutermost::CDevice>::`vector deleting destructor' 	
11 	d3d11.dll 	TComObject<NOutermost::CDevice>::Release 	
12 	d3d11.dll 	CLayeredObject<CDevice>::CContainedObject::Release 	
13 	d3d11.dll 	CDevice::ID3D10Device1_Release_Thk 	
14 	xul.dll 	nsRefPtr<nsCSSStyleSheet>::assign_with_AddRef 	obj-firefox/dist/include/nsAutoPtr.h:846
15 	xul.dll 	gfxWindowsPlatform::UpdateRenderMode 	gfx/thebes/gfxWindowsPlatform.cpp:474
16 	xul.dll 	gfxWindowsPlatform::gfxWindowsPlatform 	gfx/thebes/gfxWindowsPlatform.cpp:365
17 	xul.dll 	gfxPlatform::Init 	gfx/thebes/gfxPlatform.cpp:290
18 	xul.dll 	gfxPlatform::GetPlatform 	gfx/thebes/gfxPlatform.cpp:237

This is a startup crash that appeared now that we got symbols for the new d3d11.dll that comes with the IE10 preview for Win7. This might be connected with bug 812683.
OS: Windows NT → Windows 7
Bas -
Assignee: nobody → bas
whoops.

Bas - can you take a look at this bug? We want to make sure it's an issue with Microsoft's latest d3d11.dll, and to come up with the information that we should provide MS when we perform outreach.
Joe let me know that Bas is out this week. Hopefully Jim or Brian can help us out, although I know Brian may still be engaged on B2G.
Assignee: bas → jmathies
Summary: crash in gfxWindowsPlatform::UpdateRenderMode @ CResource::InvalidAlignment → crash in gfxWindowsPlatform::UpdateRenderMode @ CResource::InvalidAlignment (D3D11 from IE10 preview for Win7)
Marcia - I think you're likely in the best position to try to reproduce on our side. We'd specifically like to test Firefox after installing the IE10 preview for Win7.
QA Contact: mozillamarcia.knous
FWIW, I have the IE10 preview and have not experienced this crash on Win7.
The last few comments in Bug 812683 mention nvidia drivers, so I am wondering if all of these crashes are in some way related to that Nvidia update issue.  Bug 823077 is another one I filed that seems to have similar symptoms and has a smaller correlation to 9.18.13.1070 as well.
Not tracking for FF18 , considering we are very close to the release & there has been no resolution on this issue.

CCing Bas here to help with the needed reachout to Microsoft here (comment #3)to resolve the issue in Fx19 timeframe.
This looks like an a Microsoft or Driver bug? It's hard to say for sure though, one thing I can say is that on my NVidia Machine, with the IE10 preview installed I'm not seeing this issue.
It's similar to bug 812683.
Summary: crash in gfxWindowsPlatform::UpdateRenderMode @ CResource::InvalidAlignment (D3D11 from IE10 preview for Win7) → [Win7] crash in gfxWindowsPlatform::UpdateRenderMode @ CResource::InvalidAlignment (d3d11.dll, after installing KB2670838)
This and bug 812683 seem to both be with D3D11.dll 6.2 and on Win7 only.
I updated my Nvidia drivers via Windows Update (Windows 7) and that fixed the problem. Both Firefox 19.0 and Internet Explorer 9 were crashing upon loading and Firefox was reporting d3d11.dll as a possible cause.
Duplicate of this bug: 848120
Only at #29 on 20.0b5 for now, but #9 on 19.0.2, and probably will be that high once 20 hits release as well. I saw that bug 812683 is tracking already, so Im nominating this as well, given that it's yet another KB2670838 problem.
Tracking to keep this in our pool of win update known issues.
Hi.
I uninstalled KB2670838 and Firefox worked again.

I think in the future Mozilla Firefox should warn users about malicious updates from Windows (and others.)
This issue seems to be declining, the driver update mentioned in bug 812683 comment #69 could be related.
This is slowly decreasing but had a recent report of it on #firefox on IRC. Details of the KB2670838 is here: support.microsoft.com/kb/2670838
Blocks: KB2670838
Dropping qawanted since we've had no success reproducing this internally and instances of this crash appear to be declining. Please re-add if something actionable comes to light.
Keywords: qawanted
This (and also bug 812683) has dropped significantly about a week ago in Firefox 20 data and now only this signature has between a third and half of the volume it had before. I'm not aware of any Windows Update or driver release around the 14th that could have caused this.
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #20)
> This (and also bug 812683) has dropped significantly about a week ago in
> Firefox 20 data and now only this signature has between a third and half of
> the volume it had before. I'm not aware of any Windows Update or driver
> release around the 14th that could have caused this.

I wonder if more and more people are removing KB2670838 from their systems and opting not to reinstall it.
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #21)
> I wonder if more and more people are removing KB2670838 from their systems
> and opting not to reinstall it.

I doubt that would have created such a sudden and significant drop.
See the values below - those are from my explosiveness reports for Firefox 20.* and are volume in crashes per 1M ADI for this signature:

2013-04-21   35.551
2013-04-20   36.187
2013-04-19   28.790
2013-04-18   33.000
2013-04-17   32.545
2013-04-16   33.788
2013-04-15   32.999
2013-04-14   51.248
2013-04-13   66.838
2013-04-12   80.552
2013-04-11  106.897
2013-04-10   94.829
2013-04-09   98.827
2013-04-08   83.713
2013-04-07  125.947
2013-04-06  121.347
2013-04-05   99.089
2013-04-04   77.003
2013-04-03  112.066
2013-04-02  102.500

Unless there's a good reason why a ton of our users would suddenly uninstall this KB on the 2-3 days where it significantly dropped, I don't think that's the reason.
Given that this is on the high side in early 21.0 release data, here's a bit of data on installations:

breakpad=> SELECT version,signature,COUNT(*) as crashes,COUNT(DISTINCT client_crash_date - install_age  * interval '1 second') as installations FROM reports WHERE product='Firefox' AND signature LIKE '%::InvalidAlignment%' AND date_processed BETWEEN '2013-05-10' AND '2013-05-16' GROUP BY version,signature;
  version   |                                                     signature                                                      | crashes | installations 
------------+--------------------------------------------------------------------------------------------------------------------+---------+---------------
[...]
 20.0.1     | CResource<ID3D11Resource>::InvalidAlignment(D3D11_BOX const*)                                                      |    1590 |          1019
[...]
 21.0       | CResource<ID3D11Resource>::InvalidAlignment(D3D11_BOX const*)                                                      |     682 |           278
[...]
It's #49 crasher in 20.0.1 and #4 in 21.0.
Keywords: topcrash
Keeping in mind there was Patch Tuesday last week which coincided with Fx21's release, it will be good to see if MS had any related update here ? This was a top-crash with the FX20 release as well , it would  be interesting to know if the crash-rate in FX21 is higher compared to earlier releases as this is a known issue and without STR there is nothing much we can do right now.
(In reply to bhavana bajaj [:bajaj] from comment #25)
> without STR there is nothing much we can do right now.
A startup crash is not STR related but user's configuration related (HW, OS, Firefox profile).
The latest available correlations dated from May 10 in 20.0.1 (bug 867342) and show a connection to ASUS D3D10 drivers:
    100% (281/281) vs.   1% (1229/136061) atkdx11disp.dll (7.14.10.305)
Summary: [Win7] crash in gfxWindowsPlatform::UpdateRenderMode @ CResource::InvalidAlignment (d3d11.dll, after installing KB2670838) → [Win7] crash in gfxWindowsPlatform::UpdateRenderMode @ CResource::InvalidAlignment (d3d11.dll, after installing KB2670838) on Asus computers
Assignee: jmathies → nobody
Suggestion from Scoobidiver:
If you have an Asus computer with Windows 7, you should try to:
1. find the atkdx11disp.dll DLL
2. launch Firefox to see whether it crashes at startup. In case it does, check whether removing atkdx11disp.dll fixes the issue.
------
Adding qawanted in case QA has access to an Asus computer with Windows 7 on it. If yes, see if we can correlate the existence of this DLL to the startup crash.
Keywords: qawanted
We just had a user stop by #firefox.de on IRC with the following crash signatures:

bp-263b40e9-0267-4de0-8a11-9c6812130526
bp-4adefa6b-8340-47a4-bba4-823cf2130526
bp-0da46f01-7e0f-4e2b-9efd-f32402130526

All show this bug as related.

His Firefox starts in safe mode and works fine after disabling hw-acceleration.
It is not however a Asus Laptop, but a Fujitsu Siemens PC with a NVidia GPU:

DirectWrite aktiviert 	false (6.2.9200.16492)
Geräte-ID 	0x1040
GPU #2 aktiv 	false
GPU-beschleunigte Fenster 	0/1 Basic
Karten-Beschreibung 	NVIDIA GeForce GT 520
Karten-RAM 	1023
Karten-Treiber 	nvd3dum nvwgf2um,nvwgf2um
Treiber-Datum 	2-9-2013
Treiber-Version 	9.18.13.1407
Vendor-ID 	0x10de
WebGL-Renderer 	Google Inc. -- ANGLE (NVIDIA GeForce GT 520 )
AzureCanvasBackend 	skia
AzureContentBackend 	none
AzureFallbackCanvasBackend 	cairo
(In reply to Thomas B. Rücker [account dormant] from comment #28)
> It is not however a Asus Laptop, but a Fujitsu Siemens PC with a NVidia GPU:
It has atkdx11disp.dll 7.14.10.305 as loaded DLL (see http://systemexplorer.net/file-database/file/atkdx11disp-dll).
(In reply to Milan Sreckovic [:milan] from comment #27)
> Adding qawanted in case QA has access to an Asus computer with Windows 7 on
> it. If yes, see if we can correlate the existence of this DLL to the startup
> crash.

Marcia, as QA Contact for this bug can you please look into this?
It's #22 browser crasher in 21.0 and has been replaced as a top crasher by bug 854176.
Keywords: topcrash
MS has released an update, http://support.microsoft.com/kb/2834140 which updates d3d11.dll, this might or might not fix the various issues related to KB2670838 update.
This seems to be dropping further since Patch Tuesday, so MS might have caught this one with that update.
An user of the italian forum have this problem with Firefox 21/22, all its crashes redirect to this bug:
http://forum.mozillaitalia.org/index.php?topic=58756.msg394805#msg394805
He can't even start the Profile Manager.
All works disabling hardware acceleration or installing the new drivers, but, this is the strange thing, he must reinstall drivers every time he restart computer.
(In reply to Sandro Della Giustina from comment #34)
> he must reinstall drivers every time he restart computer.
He should try to uninstall the Asus driver that contains atkdx11disp.dll.
(In reply to Scoobidiver from comment #35)
> (In reply to Sandro Della Giustina from comment #34)
> > he must reinstall drivers every time he restart computer.
> He should try to uninstall the Asus driver that contains atkdx11disp.dll.


Thank you very much, now I'll suggest him to uninstall it.
I don't know if this could helps, but, thanks to @Scoobidiver that have suggested to remove that .DLL, the user have solved this problem uninstalling a software distributed by Asus called Gamer OSD.
Summary: [Win7] crash in gfxWindowsPlatform::UpdateRenderMode @ CResource::InvalidAlignment (d3d11.dll, after installing KB2670838) on Asus computers → [Win7] crash in gfxWindowsPlatform::UpdateRenderMode @ CResource::InvalidAlignment (d3d11.dll, after installing KB2670838) with Asus Gamer OSD
No need to keep two bugs for the same issue.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 812683
You need to log in before you can comment on or make changes to this bug.