Closed Bug 819340 Opened 7 years ago Closed 4 years ago

"Include messages...in Global Search Results" won't stay checked for Trash folder. Moving a message to trash or deleting message resets the folder pref.

Categories

(Thunderbird :: Search, defect)

17 Branch
x86_64
Windows 7
defect
Not set

Tracking

(thunderbird37 fixed, thunderbird_esr3137+ verified)

RESOLVED FIXED
Thunderbird 38.0
Tracking Status
thunderbird37 --- fixed
thunderbird_esr31 37+ verified

People

(Reporter: tim.long, Assigned: rkent)

References

Details

(Keywords: regression, regressionwindow-wanted, Whiteboard: [regression:TB17.0a1/16.0a2])

Attachments

(1 file)

User Agent: Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 6.1; WOW64; Trident/5.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; IPH 1.1.21.4019)

Steps to reproduce:

Right-click Trash folder ->Properties -> check "Include message in this folder in Global Search results"-> Ok


Actual results:

Run Global search, Trash message results are included.  Keeping TB open, wait maybe about an hour, run Global search, Trash folder messages are no longer included.  

Doing right-click Trash folder ->Properties shows that "Include message in this folder in Global Search results" is no longer checked.  


Expected results:

Option should stay checked.  

Note: Trash folder is big, 35404 msgs and 1.7GB on disk.  Repair folder runs to completion but doesn't help.
I can confirm that bug with Thunderbid 17.0 (Linux). It seems that it is the fact of deleting a message (moving a message to the trash) which checkout this option.
Confirming on TB 17.0.2 (Win7) that deleting a message from the Inbox causes the Include in Global Search cehckbox on Trash folder to become unchecked.
same for me - after updating from v10 esr to v17 esr (centos x86_64).

any time a file is moved to the trash folder (or a sub folder of trash), it clears the 'include this folder in global search results' option on the folder to which the message is moved.
Duplicate of this bug: 853848
Assuming bug 562708 ever worked, then this is a regression. So, you had this "enabled" running in version X and it's broken in version Y?
Please supply both X and Y.

Being late Friday afternoon I should have written this earlier in the day - I swear was able to reproduce this using version 17.0.4 and 15, but now I am unable to do so.

Not also there may be multiple problems. That is, even if the setting sticks, you might find that the folder did not get indexed.  I say this because when I tested in a profile that previously had gloda disabled it took hours until I saw the Trash folder get indexed. Even though I had been in the folder multiple times. And even though I have it set to not autosync, i.e. none of the accounts are downloading message bodies. So indexing should have been super-quick.

NOTE at some time in the past month using trunk I encountered an addon, glodaqulla or filtquilla I think, broke saving of these settings. so testing in safe mode is advisable
Depends on: 562708
Flags: needinfo?(tim.long)
(In reply to Wayne Mery (:wsmwk) from comment #5)
> Assuming bug 562708 ever worked, then this is a regression. So, you had this
> "enabled" running in version X and it's broken in version Y?
> Please supply both X and Y.
> 

i am using thunderbird on a centos system, which uses the esr packages.
global search within trash folder was working just fine in v10 esr (it looks like the last version before the upgrade was 10.0.12).
after updating to v17 esr (currently 17.0.3), the problem appeared - the 'include messages.. ' box will not remain checked, and clears every time an item is moved to the trash folder.

> Being late Friday afternoon I should have written this earlier in the day -
> I swear was able to reproduce this using version 17.0.4 and 15, but now I am
> unable to do so.
> 
> Not also there may be multiple problems. That is, even if the setting
> sticks, you might find that the folder did not get indexed.  I say this
> because when I tested in a profile that previously had gloda disabled it
> took hours until I saw the Trash folder get indexed. Even though I had been
> in the folder multiple times. And even though I have it set to not autosync,
> i.e. none of the accounts are downloading message bodies. So indexing should
> have been super-quick.
> 
> NOTE at some time in the past month using trunk I encountered an addon,
> glodaqulla or filtquilla I think, broke saving of these settings. so testing
> in safe mode is advisable

have tested in safe mode, and the behaviour remains the same - the check box clears after an item is moved to the trash.

when the box is checked back in, the search does appear to be working just fine within the trash folder - the contents appear in searches within a minute.

hope that's of some use!
Apologies for not getting back to you sooner. I don't recall the last version in which the checkbox "stayed checked".  The version I saw the issue in was 17.0.2. 

It had been broken for a while, I'd guess at least 3 months maybe even longer.
Flags: needinfo?(tim.long)
Thunderbird 17.0.8 (Mac OS X) has the problem also. I can confirm, that no Thunderbird restart is necessary to loose the checked item just wait.
I tried to reproduce it, it needs something like 15 minutes to forget the check. 
It doesn't forget the check while restarting thunderbird.
Could you test to find the regression range?  It will be  a big help.

Let's assume that it works in version 10. Starting with version 11.0.1 https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/11.0.1/  can you find the first version where it fails? 
https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/  lists them. If 11.0.1 works, try a version midpoint to 17, like version 15.0. And so on.
Flags: needinfo?(tim.long)
Flags: needinfo?(r.rigby)
Flags: needinfo?(mwillig77)
Whiteboard: [regression:TB?]
(In reply to Wayne Mery (:wsmwk) from comment #9)
> Could you test to find the regression range?  It will be  a big help.
> 
> Let's assume that it works in version 10. Starting with version 11.0.1
> https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/11.0.1/  can
> you find the first version where it fails? 
> https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/  lists them.
> If 11.0.1 works, try a version midpoint to 17, like version 15.0. And so on.

hi wayne, just done some quick testing.

version 15.0.1 is o.k. - the 'include messages.. ' box remains checked on the trash folder after deleting a message/moving a message to trash.

the next version i could find, 16.0.b1 displays the issue - after moving an item to the trash folder, the check box is cleared.

so, it appears the problem appeared between version 15.0.1 and version 16.0.b1.

hope that's of some use.

thanks,

richard
Flags: needinfo?(r.rigby)
Excellent start. 
The next step is to determine where in the version 16 cycle.
To accomlish this, one needs to use "daily" builds.
FIRST, backup your thunderbird profile, in case something goes bad

two good starting choices to try:
16.0a2 https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2012/07/2012-07-26-04-20-08-comm-aurora/
16.0a1 https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2012/07/2012-07-01-03-05-37-comm-central/
Flags: needinfo?(r.rigby)
Flags: needinfo?(tim.long)
Removing myself, sorry.  We switched over to Postbox and I can't get approval to work on this anymore.
(In reply to Wayne Mery (:wsmwk) from comment #11)
> Excellent start. 
> The next step is to determine where in the version 16 cycle.
> To accomlish this, one needs to use "daily" builds.
> FIRST, backup your thunderbird profile, in case something goes bad
> 
> two good starting choices to try:
> 16.0a2
> https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2012/07/2012-07-
> 26-04-20-08-comm-aurora/
> 16.0a1
> https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2012/07/2012-07-
> 01-03-05-37-comm-central/

hi wayne, really sorry about the delay in getting back to this.
finally found some time today, and went through testing the nightly builds.

all of the nightly builds for 16.0a2 (right up to https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2012/08/2012-08-27-04-20-00-comm-aurora/thunderbird-16.0a2.en-US.linux-x86_64.tar.bz2) tested o.k. - moving items to the trash folder did not clear the 'include in global search' box.

so i double checked, and the problem definitely exists in 16.0b1. just to be double sure, i check both the us and gb versions:

https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/16.0b1/linux-x86_64/en-GB/thunderbird-16.0b1.tar.bz2
https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/16.0b1/linux-x86_64/en-US/thunderbird-16.0b1.tar.bz2

if the time stamps on the files are accurate, that narrows it down to between the last alpha release on the 27th august, and the beta release on 29th august.

hope that's all of some use, but let me know if you would like me to test anything else, and i'll try to be more prompt with my replies in the future.

thanks,

richard
Flags: needinfo?(r.rigby)
Confirmed. Same here (TB 24.0 on Win7x64) - the check box becomes unchecked after an item is moved to the trash.
This also happens with Mozilla/5.0 (X11; Linux i686; rv:24.0) Gecko/20100101 Thunderbird/24.2.0
just updated to v24.3.0 esr this morning (centos x86_64), and as far as i can see, this now seems to be fixed for me - at least the box seems to stay checked when i delete items/move items into trash.

thanks,

richard
not for me, unfortunately, with 24.3.0 on Win7x64. still the same, reproducible problem.
Also still reproducible with TB 24.3.0 on Mac OS 10.9.1.
seems like i spoke to soon...
thought things were working, at some point the bug has re-appeared (thunderbird has not been updated/changed), and the search checkbox will not remain ticked.

will update if things change again.
For those who need functionality now, try creating a Garbage folder.  Redirect trash there in your account settings.  New folders like this will keep their 'include in global search' setting.  This solution will work while we wait for a fix on the good 'ole Trash folder.
To me, this problem is not limited to the trash folder, maybe because my trash is named 'Gelöschte Objekte'. The 'include in global search' tag is unchecked of any folder (inbox, sent, custom folder xy) anytime a message is deleted. This is on TB 24.3.3, Fedora 20. This is maybe another bug, but related and maybe help. I can't remember if this was ever working since the start of global search.
Problem exists in Windows 8 and Thunderbird 24.4.0
Yeah, I have this issue too :(
Please fix it!!!
Still happens on v.24.4.0 for Mac OS :(
I was able to reproduce via delete message, or moving message to trash. Regression hunting...

works http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2012/08/2012-08-24-03-05-32-comm-central/ thunderbird-17.0a1.en-US.win32.installer.exe
fails http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2012/08/2012-08-25-03-05-43-comm-central/ hunderbird-17.0a1.en-US.win32.installer.exe

regression range http://hg.mozilla.org/comm-central/pushloghtml?startdate=2012-08-24%2003:05:00&enddate=2012-08-25%2003:05:00

but I suspect bug 783947 which 
a) changes code in this area checkin https://hg.mozilla.org/comm-central/rev/1058c80dbe3c aka https://bugzilla.mozilla.org/attachment.cgi?id=653924&action=diff which falls in regression range http://hg.mozilla.org/comm-central/pushloghtml?startdate=2012-08-23+03%3A05%3A00&enddate=2012-08-24+03%3A05%3A00
b) also landed in auroa, and thus matches richard's comment 10 findings regarding 16.0b1 having the bug
Blocks: 783947
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(mwillig77)
Summary: "Include..in Global Search" won't stay checked for Trash folder → "Include messages...in Global Search Results" won't stay checked for Trash folder. Moving a message to trash or deleting message resets the folder pref.
Whiteboard: [regression:TB?] → [regression:TB17.0a1/16.0a2]
also affects junk folder
I've wanted Global Searches to include Trash folder FOR YEEEARS!  I was told that it wasn't supposed to and so I had given up on it but at the time I had said that it should be something the user can decide.
Today, I got to wondering if there was a way to make it work yet and I came across this post.  I learned that there was the option by going to the Trash Properties and checking the box to include it!  YIPEE!
I tested mine by deleting something in the Inbox and then checking the Trash Properties again and mine is staying selected so I guess the original issue of this thread has been fixed (I'm on 31.2.0).  I even restarted TB.
Thanks all, now my global searches include the Trash!!!
Unfortunately, the box doesn't stay checked. I'm hoping that someone will change the code so that once I check that box it stays checked. Now you have to re-check it each time you start Thunderbird.
(In reply to openmindtherapy from comment #29)
> Unfortunately, the box doesn't stay checked. I'm hoping that someone will
> change the code so that once I check that box it stays checked. Now you have
> to re-check it each time you start Thunderbird.

Hmmm.  Sorry to hear that openmindtherapy.  It works fine on my computer.  I just checked and it is still marked plus I did some test searches to verify it was truly working.  My computer has been restarted numerous times since I marked the folder to be included.
Well I just upgraded to 31.2.0 and it appears to stay checked now so perhaps the problem is solved!!
I take back what I said earlier. Today when I booted my computer the box for the trash folder was no longer checked. What version of windows are you running? I'm running windows 8. Can that have anything to do with it?
I don't know.  It could be.  Mine is still checked.  I'm W7 Pro w/ SP1.(In reply to openmindtherapy from comment #32)
> I take back what I said earlier. Today when I booted my computer the box for
> the trash folder was no longer checked. What version of windows are you
> running? I'm running windows 8. Can that have anything to do with it?

I don't know.  It could be.  Mine is still checked.  I'm W7 Pro w/ SP1.
I am still fighting this issue after latest update 31.3.0 
Are there any other things to consider on why this may be happening ?
Update testing on Window Vista using TB 31.3.0
Tested:
Edit > Find > Search messages
Select the account name
Select to search sub folders.
Select 'match all of the following'
Subject - contains - name/text that I know is only in the Deleted folder.
click on 'Search'

Results show two messages in the Deleted folder.

So confirm this method of search includes Deleted/TRash folder.
--------------------------------
If I use the Global search box in the 'Mail Toolbar'.
Select account
type text I know is only in the deleted folder.
Select option: Messages mentioning text input
No results returned.
So this method of search does not include the Deleted/Trash folder.
@Anje, perfect example how to reproduce it. Thanks for that. That's exactly the problem here, you cannot search inside Trash when doing a Global search.
This issue is very annoying. The amount of time to repair the folder and reclick the box to search trash is quite annoying. Someone please look into this.
Seemed like it should be an easy fix, so I checked it out. Reset occurs here:

1 glodaSetFolderIndexingPriority(aFolder = [xpconnect wrapped nsIMsgFolder @ 0x5d28070 (native @ 0xd23d800)], aPriority
= -1) ["resource:///modules/gloda/index_msg.js":1828]
    this = [object Object]
2 glodaResetFolderIndexingPriority(aFolder = [xpconnect wrapped nsIMsgFolder @ 0x5d28070 (native @ 0xd23d800)]) ["resour
ce:///modules/gloda/index_msg.js":1880]
    this = [object Object]
3 gloda_indexer_OnItemIntPropertyChanged(aFolderItem = [xpconnect wrapped nsIMsgFolder @ 0x5d28070 (native @ 0xd23d800)]
, aProperty = FolderFlag, aOldValue = 532756, aNewValue = 268968212) ["resource:///modules/gloda/index_msg.js":2804]
    this = [object Object]
4 FolderDisplayWidget_doCommand(aCommandName = 7) ["chrome://messenger/content/folderDisplay.js":1780]
    this = [object Object]
5 DefaultController.doCommand(command = "cmd_delete", aTab = [object Object]) ["chrome://messenger/content/mail3PaneWind
owCommands.js":640]
    this = [object Object]
6 mailTabType_doCommand(aCommand = "cmd_delete", aTab = [object Object]) ["chrome://messenger/content/mailTabs.js":785]
    this = [object Object]
7 doCommand(aCommand = "cmd_delete") ["chrome://messenger/content/tabmail.xml":1450]
    this = [object XULElement]
8 goDoCommand(aCommand = "cmd_delete") ["chrome://global/content/globalOverlay.js":96]
    this = [object ChromeWindow]
9 oncommand(event = [object XULCommandEvent]) ["chrome://messenger/content/messenger.xul":1]
    this = [object XULElement]

This is indeed caused by changes in bug 783947. Testing a fix now.
Now the hard part: coming up with a reviewer. I'll try jcranmer. It's a pretty small change, but could also wait until TB 38 is in aurora.
Assignee: nobody → rkent
Status: NEW → ASSIGNED
Attachment #8563712 - Flags: review?(Pidgeot18)
Comment on attachment 8563712 [details] [diff] [review]
Only reset indexing priority if folder type changes.

Review of attachment 8563712 [details] [diff] [review]:
-----------------------------------------------------------------

I'm assuming your analysis as to why this occurring is valid.
Attachment #8563712 - Flags: review?(Pidgeot18) → review+
Comment on attachment 8563712 [details] [diff] [review]
Only reset indexing priority if folder type changes.

Pushed to comm-central https://hg.mozilla.org/comm-central/rev/f09967e16bd3

[Approval Request Comment]
Regression caused by (bug #): 783947
User impact if declined: minor, user cannot select trash and junk for gloda indexing
Testing completed (on c-c, etc.): just started
Risk to taking this patch (and alternatives if risky): small

[Triage Comment]

This simple bug fix should be pushed to the next beta, then to esr31 if no issues are uncovered.
Attachment #8563712 - Flags: approval-comm-esr31?
Attachment #8563712 - Flags: approval-comm-beta+
Pushed https://hg.mozilla.org/releases/comm-beta/rev/8a0c1e39ec46
Target Milestone: --- → Thunderbird 38.0
Comment on attachment 8563712 [details] [diff] [review]
Only reset indexing priority if folder type changes.

https://hg.mozilla.org/releases/comm-esr31/rev/5088537f4450

Low risk, has landed in a beta cycle with no known issues.
Attachment #8563712 - Flags: approval-comm-esr31? → approval-comm-esr31+
i have just updated to thunderbird 31.6, and this now all seems to be fixed.

excellent stuff. thank you.
wonderful, thanks! (about time!)
WOOOHOOO!  Yipee!  It's been a long time waiting!  Awesome news.
looks to me like everything here is FIXED :)
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.