Folder preference for gloda indexing does not work for trash/junk/outbox folders (not retained)

VERIFIED FIXED in Thunderbird 3.3a1

Status

VERIFIED FIXED
9 years ago
6 years ago

People

(Reporter: rkent, Assigned: standard8)

Tracking

Trunk
Thunderbird 3.3a1
Bug Flags:
wanted-thunderbird +

Thunderbird Tracking Flags

(thunderbird3.1 .3-fixed)

Details

(Whiteboard: [gs], URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Per http://getsatisfaction.com/mozilla_messaging/topics/search_trash_folder_with_new_index_search_in_tb3_howto there is demand for enabling gloda indexing on the trash folder. But when I tried the new folder preference (using a TB 3.1 nightly) it does not stick:

STR:

1) In folder pane, get the folder properties for the trash pane
2) check to enable "Include messages in this folder in Global search results"
3) press OK to save folder
4) display folder properties again

expected: "Include messages ... " is checked
actual: "Include messages ... " is not checked.
(Reporter)

Updated

9 years ago
Version: 3.0 → Trunk

Comment 1

9 years ago
I am definitely looking forward to seeing this *work*

Junk and Trash are two boxes where things wind up by accident sometimes. Having the option to search them is hugely valuable.

Comment 2

8 years ago
This is also a problem for our users; they search for things and can't understand why Tbird can't find them even though other clients can.  Definitely need to be able to search in Trash at least!
(Assignee)

Comment 3

8 years ago
Andrew, any ideas what is going on where?
status-thunderbird3.1: --- → wanted
Flags: wanted-thunderbird+
(Assignee)

Updated

8 years ago
Summary: folder preference for gloda indexing does not work for trash → folder preference for gloda indexing does not work for trash (not retained)

Comment 4

8 years ago
Please add an option to support indexing of the Trash folders, even if it may need to be enabled through the config editor.
(In reply to comment #4)
> Please add an option to support indexing of the Trash folders, even if it may
> need to be enabled through the config editor.

Option is present right click on the trash and look into properties.
(Assignee)

Updated

8 years ago
Summary: folder preference for gloda indexing does not work for trash (not retained) → Folder preference for gloda indexing does not work for trash/junk/outbox folders (not retained)
(Assignee)

Updated

8 years ago
Assignee: nobody → bugzilla
OS: Windows XP → All
Hardware: x86 → All
(Assignee)

Comment 6

8 years ago
Created attachment 463550 [details] [diff] [review]
Proposed fix

There's two parts to this patch.

1) First there's a correction to the UI - the gloda checkbox wasn't being hidden when gloda was disabled or for the outbox.

Turns out that for the gloda disabled part the code was being hit, but then hideShowControls() was overriding the action. So I've moved that action above where the gloda overrides are done, and then I've added queue and newsgroup folder types to definitely make sure we disable on those.

2) resetFolderIndexingPriority was being called on a folder when the gloda box on the properties dialog was being checked. However, for Trash and Junk, this meant it was being rest to "never". I've therefore added a parameter to resetFolderIndexingPriority to allow indexing on special folders - i.e. if its the trash or junk it will be set to the default priority rather than never.

This then seems to work correctly for indexing if the user wants to enable it.
Attachment #463550 - Flags: review?(bugmail)
Comment on attachment 463550 [details] [diff] [review]
Proposed fix

sure
Attachment #463550 - Flags: review?(bugmail) → review+
Duplicate of this bug: 585186
(Assignee)

Comment 9

8 years ago
Checked in: http://hg.mozilla.org/comm-central/rev/65708cb363ab
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Target Milestone: --- → Thunderbird 3.2a1
(Assignee)

Comment 10

8 years ago
Comment on attachment 463550 [details] [diff] [review]
Proposed fix

We should consider this for 3.1.3.
Attachment #463550 - Flags: approval-thunderbird3.1.3?
(Assignee)

Updated

8 years ago
Attachment #463550 - Flags: approval-thunderbird3.1.3? → approval-thunderbird3.1.3+
(Assignee)

Comment 11

8 years ago
Checked in: http://hg.mozilla.org/releases/comm-1.9.2/rev/1caea43c3d03
status-thunderbird3.1: wanted → .3-fixed

Comment 12

8 years ago
I posted the link for 3.1.3pre in http://gsfn.us/t/nrge to get feedback
Whiteboard: [gs]
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.9) Gecko/20100825 Thunderbird/3.1.3
Status: RESOLVED → VERIFIED

Updated

6 years ago
Blocks: 819340
You need to log in before you can comment on or make changes to this bug.