Closed Bug 820628 Opened 7 years ago Closed 7 years ago

[Trusted UI] Trying to login into persona with get api and clicking input field for enter your email - unnecessary white blob appears

Categories

(Core Graveyard :: Identity, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 818575

People

(Reporter: jsmith, Unassigned)

Details

Attachments

(2 files)

Attached image White Blob Of Doom
Build:

Device - Unagi
Date - 12/10/2012 Mozilla Beta
Prefs - Identity is prefed on

Steps:

1. Go to marketplace
2. Select to login
3. Select the enter your email address text field

Expected:

The keyboard should come up with the persona dialog being responsive to a smaller dialog.

Actual:

See screenshot. It looks like the dialog isn't handling responsive design to when a dialog becomes smaller too well.
Summary: [Trusted UI] Don't resize the trusted UI prompt when the keyboard appears → [Trusted UI] Trying to login into persona with get api and clicking input field for enter your email - unnecessary white blob appears
Blocks: 811528, 820059
Apparently this appears to reproduce very consistently with slow network connections - and can even happen with window.open as well.
blocking-basecamp: --- → ?
Attached file Window Open Logcat
Here's what the logcat looks like from window.open
Interesting piece found from logcat:

12-11 16:52:01.669: E/GeckoConsole(9017): [JavaScript Error: "SyntaxError: unterminated regular expression literal" {file: "https://static.login.persona.org/v/b51acfc298/production/en/dialog.js" line: 2 column: 60 source: "ME:/\[name=['"]*((?:[\w\u00c0-\uFFFF\-]|\\.)+)['"]*\]/,ATTR:/\[\s*((?:[\w\u00c0-\uFFFF\-]|\\.)+)"}]
(In reply to Jason Smith [:jsmith] from comment #3)
> Interesting piece found from logcat:

Interesting indeed... do you know if this is related to the white blob? I can't imagine how, but maybe... (Note that this is the same code we serve in the popup and trusted UI, and I believe this issue only occurs in the trusted UI.)
I had gotten the same thing as Jason.  I think it's a gonk issue not an identity issue.

bug 818575?
In comment 5, I mean gecko issue not gonk issue.
(In reply to Ben Adida [:benadida] from comment #4)
> (In reply to Jason Smith [:jsmith] from comment #3)
> > Interesting piece found from logcat:
> 
> Interesting indeed... do you know if this is related to the white blob? I
> can't imagine how, but maybe... (Note that this is the same code we serve in
> the popup and trusted UI, and I believe this issue only occurs in the
> trusted UI.)

Let me fix the title. I can actually reproduce this in a window.open pop-up and a trusted UI.

(In reply to Naoki Hirata :nhirata from comment #5)
> I had gotten the same thing as Jason.  I think it's a gonk issue not an
> identity issue.
> 
> bug 818575?

Maybe? Let retest with a clean flashed build.
Summary: [Trusted UI] Trying to login into persona with get api and clicking input field for enter your email - unnecessary white blob appears → Trying to login into persona with get api and clicking input field for enter your email - unnecessary white blob appears
fwiw, note that that is served from login.persona.org; we are currently serving b2g include.js from notoriousb2g.personatest.org.  So strictly speaking, this isn't citing b2g identity code.

Still, login.persona.org code should work in a separate browser tab when b2g identity is preffed off (causing identity to be executed entirely in the shim), but native identity has a slightly different include.js file.

We've been discussing this in irc; :jrgm tested that url and verfied the checksum was correct and the js was valid.
Summary: Trying to login into persona with get api and clicking input field for enter your email - unnecessary white blob appears → [Trusted UI] Trying to login into persona with get api and clicking input field for enter your email - unnecessary white blob appears
Naoki is dead on - it's a dupe of bug 818575 - I just confirmed this behavior.

The cache corruption issue I'm hitting looks like a separate issue.
Status: NEW → RESOLVED
blocking-basecamp: ? → ---
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 818575
No longer blocks: 820059
No longer blocks: 811528
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.