[UX] Issues with site specific permissions / preferences

RESOLVED WONTFIX

Status

()

Firefox
Preferences
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: Florian Bender, Assigned: Florian Bender)

Tracking

({uiwanted})

18 Branch
All
Mac OS X
uiwanted
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

5 years ago
I encountered a few UX issues when working with about:permissions. 

0. There is no way to navigate away from the permission manager page other than closing it. Either show the navigation bar (this is preferable) or show at least a few buttons (like the current extension manager does). 

1. Pressing [Del] on the keyboard should delete the currently selected entry.
 
2. Pressing "Forget about this website" (or however it is called in en) should select the next entry instead of "All websites" (beware of the case when you are deleting "blabla.tld" and the next entry is "www.blabla.tld" – the latter on is delted, too!).

3. The list of websites should be sorted alphabetically (and ignoring "www." while doing so). 

4. The list does not display all entries it could. E. g. delete a few entries from the list, reload the permission manager page, and the list is filled up with "new" pages until a certain threshold. 

5. The in-content site specific prefs page has the title "Permissions manager" (translated from German), this implies that this view is only about permissions for sites. However, deleting an entry means deleting a website from history. Additionally, every site I ever visited is listed in the permissions manager regardless of whether they have the default permissions or not. 


Regarding 4 and 5: 

The scope of the site preferences page is unclear. 

It is either about website permissions, in which case only the websites I've set custom prefs for should be listed (and if you visit the prefs manager from a site which has the default settings, e. g. from the Site Identity panel, add the entry on the fly). This keeps the list short and sane (and more usable). 

Or it is kind of a central control panel for anything site-specific – in this case the info provided should be much more verbose (like the "site info" link form the context menu) AND the pref panel should be clearly marked as such. Plus, there should be links to see the history entries for this page, whether it is bookmarked and what tags are set for it, as well as buttons to reset any custom prefs, clear the history, etc.
(Assignee)

Updated

5 years ago
Blocks: 573176
Component: Untriaged → Preferences
(Assignee)

Comment 1

5 years ago
Extending the dependency tree with other UX issues, somehow morphing this into a meta bug. 

Is there any design document / proposal for the site permission manager? I do have some ideas for a redesign / reimplementation, so before writing them down I'd like to know about prior work or plans. :Boriss, you were mentioned in other bugs, so I thought you can tell me something about that. :)
Blocks: 838554
Depends on: 681496, 661830, 661831, 658423
Keywords: uiwanted
Summary: [UX] Issues with site specific preferences → [UX] Issues with site specific permissions / preferences
(Assignee)

Comment 2

5 years ago
Somehow my needinfo? failed …
Flags: needinfo?(jboriss)
(Assignee)

Updated

5 years ago
Blocks: 588689
(Assignee)

Comment 3

4 years ago
Since Philipp recently worked on some in-content pages, he might have a say on this … please see above!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jboriss) → needinfo?(philipp)
I don't think there's a design document for this.
All the points raised in comment #0 are valid, but I suspect that this won't receive any love in the short term given how hidden (yet complex) it is.
So Florian, if you'd like to take a stab at it, that would be highly appreciated :)
Flags: needinfo?(philipp)
(Assignee)

Comment 5

4 years ago
OK, I will have a stab at this. Will take a couple of weeks, though.

If anybody else wants to take a look at this (or provide input), feel free to take or comment.
Assignee: nobody → fb+mozdev
FWIW, it's not clear that about:permissions is the permissions UI we want and will ever be finished and exposed to users. The whole approach of listing all possible hosts and expecting users to wade through that list is somewhat flawed. I think something along the lines of what we did in bug 885366 is more user friendly.

The bottom line is that working on this UI may not be the best way to spend your time (and reviewers' time, frankly).
(Assignee)

Comment 7

4 years ago
Yeah, that's about what I found/thought (see comment 0). My plan is to devise a new concept instead of improving the old one. 

This will be based on the new in-content preferences, though I might wait on a redesign of the addon manager first.
I don't think anything in comment 0 addresses the fundamental flaws with this UI. Basically, I don't think we should have a permission manager that makes users juggle with a list of domains, be it domains with modified permissions or domains they've visited. There are problems with subdomains (some permissions are whole-domain-specific, some are only stored for eTLD+1) that make dealing with such a list hard even for advanced users. On top of that, it's well-known that many users don't understand domains and completely rely on search engines, bookmarks and similar assistance to go to sites. Therefore, exposing site-specific preferences in the site identity panel seems more user friendly.
(Assignee)

Comment 9

4 years ago
Site prefs in the identity panel are certainly the way to go for most use cases. But there is value in having an overview of sites for certain kinds of permissions, e.g. notifications. 

I'll try to come up with an interactive mock-up (no patches) and we can see where we go from there. Sounds reasonable? Again, this will take some time.
about:permissions has been removed in bug 933917.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX

Updated

2 years ago
No longer blocks: 838554
You need to log in before you can comment on or make changes to this bug.