bump mozdevice to version 0.18 and release to m-c

RESOLVED FIXED in Firefox 19

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: ahal, Assigned: ahal)

Tracking

Trunk
mozilla20
Points:
---

Firefox Tracking Flags

(firefox19 fixed, firefox20 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
We need the changes from https://github.com/mozilla/mozbase/commit/93701293b5fa5ea538faec9d7f3ba6abcdf4ac48 to clean up b2g automation
(Assignee)

Updated

6 years ago
Version: 18 Branch → Trunk

Comment 2

6 years ago
Comment on attachment 693908 [details] [diff] [review]
Patch 1.0 - update mozdevice

assuming a green try run, looks good to me
Attachment #693908 - Flags: review?(jhammel) → review+
(Assignee)

Comment 3

6 years ago
B2G try is completely backed up, but the xpcshell tests passed. I think this is sufficient testing for B2G as all the harnesses are run nearly identically and xpcshell makes use of most of the code paths affected by this patch.

Comment 4

6 years ago
wfm
https://hg.mozilla.org/mozilla-central/rev/3905e1085c13
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
It looks like this landed on mozilla-aurora also, but not beta, possibly causing (or not solving) some beta-specific problems: bug 686245.
Comment on attachment 693908 [details] [diff] [review]
Patch 1.0 - update mozdevice

[Approval Request Comment]
Bug caused by (feature/regressing bug #): This is a roll-up of various improvements to mozdevice
User impact if declined: talos ts failures on beta - bug 686245
Testing completed (on m-c, etc.): on m-c and m-a since Dec 20
Risk to taking this patch (and alternatives if risky): Affects test infra
String or UUID changes made by this patch: None
Attachment #693908 - Flags: approval-mozilla-beta?
Comment on attachment 693908 [details] [diff] [review]
Patch 1.0 - update mozdevice

Test only and shouldn't affect builds, so approving.
Attachment #693908 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/c514a140e0fc
status-firefox19: --- → fixed
status-firefox20: --- → fixed
You need to log in before you can comment on or make changes to this bug.