Closed Bug 823365 Opened 7 years ago Closed 7 years ago

Add UA overrides for top Spain sites

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g18+)

RESOLVED DUPLICATE of bug 823364
Tracking Status
b2g18 + ---

People

(Reporter: lmandel, Unassigned)

References

Details

Attachments

(1 file)

Note: This bug should remain confidential until Spain has been publicly announced as a target market for B2G.

Attached is a candidate list of 23 of the Alexa top 100 Spain sites for the B2G UA whitelist. This list of 23 sites was determined via screenshot comparison of the sites with the Firefox for Android, Firefox OS, and Android Stock UAs. Sites that are already included in bug 819210 and bug 823364 are omitted here.

Our goal is to create a recommended list of top Spain sites for the UA whitelist.

There are 3 actions:

1. Smoke test each of these sites, preferably on B2G, with a spoofed UA to ensure that with the UA override the site appearance is improved and the site is mostly functional. Non primary function, like a vertically scrollable list of posters/images or function buried deep within the site, should not block a smoke test from passing.

2. Add the UA overrides to Gaia.

3. Open an evangelism bug for each site that is added to the UA override list in order to track the work required to remove a site from the list.

Legend for the attachment:
(Android UA) = This site requires the Android stock UA to get mobile content
(better content with Android UA) = This site receives mobile content with the Fennec UA but better mobile content with the Android stock UA
(nsfw) = not safe for work (this is an adult site)
I have added these to the user-agent override investigation spreadsheet for tracking.
Depends on: 822551
blocking-basecamp: ? → -
tracking-b2g18: --- → +
This is a requirement by product. Top sites won't work. Back into triage it goes.
blocking-basecamp: - → ?
tracking-b2g18: + → ---
I have added these to the user-agent override investigation spreadsheet for tracking.
blocking-basecamp: ? → -
(In reply to David Scravaglieri [:scravag] from comment #4)
> The target market is Brasil, we don't block on this.

No. Chris Lee confirmed that the target market isn't just Brazil. There's other involved here. That's the point of why we filed bugs for these UA overrides - they represent each market to our understanding. Into triage it goes again.
blocking-basecamp: - → ?
Jason, any bugs that are post C3, but still valid for v1.0, will no longer use blocking-basecamp flag. instead, it is replaced by tracking-b2g18 flag.   We'll want these override bugs for non-brazil to get tracking-b2g18+'d.
blocking-basecamp: ? → ---
tracking-b2g18: --- → ?
(In reply to Tony Chung [:tchung] from comment #5)
> Jason, any bugs that are post C3, but still valid for v1.0, will no longer
> use blocking-basecamp flag. instead, it is replaced by tracking-b2g18 flag. 
> We'll want these override bugs for non-brazil to get tracking-b2g18+'d.

Wrong. Last time I checked, triage is still going on. So that argument doesn't make sense to me.
blocking-basecamp: --- → ?
blocking-basecamp: ? → ---
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 823364
Group: mozilla-corporation-confidential
You need to log in before you can comment on or make changes to this bug.