Last Comment Bug 825264 - Unable to connect to Facebook Messenger right now
: Unable to connect to Facebook Messenger right now
Status: RESOLVED WONTFIX
:
Product: Firefox
Classification: Client Software
Component: SocialAPI: Providers (show other bugs)
: 17 Branch
: All All
: -- major with 5 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 825767 872413 942574 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-12-28 10:26 PST by kleagkou
Modified: 2014-08-05 19:05 PDT (History)
21 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description kleagkou 2012-12-28 10:26:32 PST
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20100101 Firefox/17.0 Iceweasel/17.0.1
Build ID: 20121201094343

Steps to reproduce:

Nothing at all , I just open Iceweasel ( Debian Rebranded firefox) and I am loged on facebook 


Actual results:

Iceweasel says notification error that cannnoct connect to facebook messenger


Expected results:

to show me the friends that are currently online
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-12-28 13:19:21 PST
There an issue on the Facebook side that is causing trouble at the moment, they're working on fixing it.
Comment 2 Jean Austin Rodriguez 2012-12-28 14:40:45 PST
I am experiencing the same issue on Firefox 17.0.1 in Linux. I'm logged in at Facebook but the Messenger indicates that it's not. I tried logging out and logging in, disable-enable Social API several times but nothing happened.
Comment 3 Michael Loney 2012-12-30 19:01:29 PST
I can confirm this as well. Now I am less able to waste my life on that site. A quick fix would be nice. From either Mozilla or Facebook.
Comment 4 Filip Zakrzewski 2013-01-01 17:19:53 PST
*** Bug 825767 has been marked as a duplicate of this bug. ***
Comment 5 alexmcc78 2013-01-02 04:10:10 PST
The same problem for me for the past few days. Removing/re-adding the Facebook integration and deleting cache/cookies makes no difference.

I'm also getting the problem on my work PC, both Firefox 17.0.1. The home pc is Windows 8 64-Bit/Work: Windows 7 Pro SP1 32-Bit.

(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #1)
> There an issue on the Facebook side that is causing trouble at the moment,
> they're working on fixing it.

Can you post a link showing Facebook working on it please?
Comment 6 :Gavin Sharp [email: gavin@gavinsharp.com] 2013-01-02 08:11:30 PST
I'm not sure what kind of link you'd like me to paste - we're in direct contact with engineers there who are trying to address the problem. I don't have a recent update, but I know they're working on it.
Comment 7 alexmcc78 2013-01-02 09:21:40 PST
Ah thanks. I didn't realise I was talking directly to the engineers/programmers. Good to hear, thanks.
Comment 8 alexmcc78 2013-01-02 16:15:55 PST
It looks like it's fixed. I've been checking all night and it started working 1-2 hours ago. Hopefully Facebook have fixed it permanently.
Comment 9 Swarnava Sengupta (:Swarnava) 2013-01-02 18:41:18 PST
It is woking fine for me with Firefox latest aurora
Comment 10 Jean Austin Rodriguez 2013-01-05 05:49:17 PST
It's now working on Firefox 17.0.1 on Ubuntu 12.04 LTS.
Comment 11 alexmcc78 2013-01-17 10:50:10 PST
This problem has re-occurred and has for the past few days :-(, since Firefox 18 was released.
Comment 12 kurian 2013-08-06 22:45:11 PDT
It broke again yesterday on the latest beta. Deleted cookies and uninstalled the service. Still doesn't work.
Comment 13 kristian.karden 2013-08-07 07:57:41 PDT
This problem persists at least with the Aurora version I'm using (2013-08-05).
Comment 14 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-08-07 11:11:44 PDT
This issue is and always has been an issue on Facebook's end. Unfortunately there is not much we can do about that. I think this is going to be an issue off and on until Facebook puts more effort into ensuring up-time.
Comment 15 alexmcc78 2013-08-19 12:30:41 PDT
Is there a fix for this coming? It's still broken for me :-(
Comment 16 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-08-19 17:23:23 PDT
(In reply to alexmcc78 from comment #15)
> Is there a fix for this coming? It's still broken for me :-(

It's an issue on Facebook's end. I know they are aware of it but I don't know if/when they will fix it.
Comment 17 alexmcc78 2013-08-20 03:33:56 PDT
Thanks. It's normally fixed by now!

I'm unsure how it's because of a Facebook uptime issue when it only seems to break when a new Firefox version is released. I rarely have problems until I upgrade.
Comment 18 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-08-20 11:28:13 PDT
We are currently working on error pages to make it clearer when the service is offline. This should hopefully alleviate this confusion.
Comment 19 Mark Hammond [:markh] 2013-11-27 21:47:28 PST
Back to not working again.
Comment 20 Mark Hammond [:markh] 2013-11-27 21:48:02 PST
*** Bug 942574 has been marked as a duplicate of this bug. ***
Comment 21 alexmcc78 2013-12-06 10:22:57 PST
It's been 2 weeks now. I'm guessing Facebook/Mozilla aren't going to fix it this time? As a Firefox feature, it's in part Mozilla's responsibility to be contacting Facebook.
Comment 22 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-12-10 16:16:52 PST
(In reply to alexmcc78 from comment #21)
> It's been 2 weeks now. I'm guessing Facebook/Mozilla aren't going to fix it
> this time? As a Firefox feature, it's in part Mozilla's responsibility to be
> contacting Facebook.

Facebook was made aware of this a while ago. Unfortunately there is nothing more we can do on our end.
Comment 23 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-12-10 16:18:35 PST
*** Bug 872413 has been marked as a duplicate of this bug. ***
Comment 24 alexmcc78 2013-12-18 13:06:50 PST
Does this work for anyone now? In case it's a problem at my end (has happened before) or are Facebook simply not going to fix it now?

It's been broken for weeks.
Comment 25 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-12-18 13:10:44 PST
(In reply to alexmcc78 from comment #24)
> Does this work for anyone now? 

I just tried and it still does not work on my end.
Comment 26 alexmcc78 2013-12-18 13:12:50 PST
Thanks. I may uninstall it soon, if it's not working :-(.

I've since installed the Facebook Messenger app for Windows. Which works fine but Facebook no longer offer for download (thankfully I have the executable).

It's not half as useful though, the way the Facebook Messenger for Firefox works across tabs is so handy.
Comment 27 AJ Fite 2014-01-06 21:43:56 PST
Mine just reconnected moments ago and it seems to be working again
Comment 28 Martin Pecka 2014-01-07 00:55:02 PST
(In reply to AJ Fite from comment #27)
> Mine just reconnected moments ago and it seems to be working again

I can't confirm on Firefox 26.0.
Comment 29 alexmcc78 2014-01-07 01:24:33 PST
Is it still working for you?

On Firefox 26.0 it's still no different for me. Facebook Chat still isn't connecting. I removed Facebook Messenger for Firefox, deleted all cookies related to Facebook, restarted and reinstalled Facebook Messenger for Firefox. No joy.
Comment 30 AJ Fite 2014-01-07 12:31:25 PST
It was working for about 15 minutes right around when I posted that comment, then ceased functioning again.  It was a glorious 15 minutes.

Firefox 28.0a2 (Ubuntu PPA Version) on Ubuntu Trusty 14.04 64bit
Comment 31 alexmcc78 2014-01-13 16:51:39 PST
I'd given up hope and remarkably it started working again for me a couple of days ago. It hasn't work since the 24th of November!

The three notification buttons still don't work (it never loads friend request/message/notifications) but it's the Chat Sidebar I care about and finally it's working.

For now!
Comment 32 AJ Fite 2014-08-05 17:55:49 PDT
This bug should be closed as the Facebook Messenger extension has been discontinued

Note You need to log in before you can comment on or make changes to this bug.