Escape no longer stops animated GIFs

RESOLVED WONTFIX

Status

()

Firefox
General
RESOLVED WONTFIX
5 years ago
a year ago

People

(Reporter: Paul, Unassigned)

Tracking

20 Branch
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [workaround: use https://addons.mozilla.org/en-US/firefox/addon/superstop/ ], URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:20.0) Gecko/20121229 Firefox/20.0

Steps to reproduce:

1. Load a page containing an animated GIF, or just the GIF itself.  Here's a suitably amusing one: http://imgur.com/KkgvR
2. Press Escape on the keyboard.


Actual results:

Nothing.


Expected results:

All animated GIFs on the page should stop, the expected behaviour since circa Navigator 1.
(Reporter)

Comment 1

5 years ago
Additionally, an animated GIF on a page is still loading, and the load is interrupted with Escape or clicking the Stop button, the GIF is removed, potentially breaking page layout. The expected behaviour is for the partially loaded image to remain as is.
The is a intended change from bug 614304.
ESC is now the same as hitting the stop button and the stop button doesn't stop animated images
Blocks: 614304
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Component: Untriaged → General
Resolution: --- → WONTFIX
(Reporter)

Comment 3

5 years ago
Thank you for the clarification. Animation produces significant load on my limited hardware (for some reason, Firefox uses triple the cycles to render animated GIFs as Chromium), but thanks to Gavin's add-on I can restore the old functionality via Shift+Escape

  https://addons.mozilla.org/en-US/firefox/addon/superstop/
You can also change the option for animated images http://kb.mozillazine.org/Firefox_:_Tips_:_Animated_Images
Duplicate of this bug: 826814

Comment 6

5 years ago
(In reply to Matthias Versen [:Matti] from comment #2)

> ESC is now the same as hitting the stop button

This has always been the case.
More precisely, Esc now only has an effect when the stop button is visible. The stop button is only visible while the main page is loading.

Comment 8

5 years ago
The Esc key should be returned the ability to stop animation of gif images after a page is done loading.
(Reporter)

Comment 9

5 years ago
This was discussed above and in bug 614304. I created this ticket, but after reading the explanations I understand the reasoning behind the change. More often, people are going to be using web-based apps that want to trap the Escape key, and the old functionality breaks the page as soon as Escape is hit. We can't have Escape acting differently, because it violates the Law of Least Astonishment.

However, you can restore the previous functionality on the little-used Shift+Escape key combination by installing this add-on:

  https://addons.mozilla.org/en-US/firefox/addon/superstop/

Updated

5 years ago
Duplicate of this bug: 830560

Comment 11

5 years ago
(In reply to mozilla.org from comment #9)
> This was discussed above and in bug 614304. I created this ticket, but after
> reading the explanations I understand the reasoning behind the change.

As dagger said in that ticket, it is possible to associate pressing the Esc key ONLY with stopping image animation. This wouldn't break any apps. The extension you mentioned stops animation AND network activity.
(Reporter)

Comment 12

5 years ago
Yes, it would be possible, and that would be new functionality which would still introduce the unexpected edge case behaviour of animations stopping when the user pressed Escape but expected this to be trapped by the web app.

Gavin's add-on hooks into the old BrowserStop() method; it is trivial to modify the add-on to bind to Escape and call dagger's suggested method by modifying lines 22 and 23 of bootstrap.js as follows:

    // key.setAttribute("modifiers", "shift");
    key.setAttribute("oncommand", "stop(STOP_CONTENT);");

Please understand that there are few Firefox developers, and 300 tickets filed each day; since we have a way for power users to get this functionality now, I suggest we let the developers get back to actually developing.

Updated

5 years ago
Duplicate of this bug: 832833

Updated

5 years ago
Duplicate of this bug: 857664
Duplicate of this bug: 861124

Comment 16

5 years ago
(In reply to Matthias Versen [:Matti] from comment #2)
> The is a intended change from bug 614304.
> ESC is now the same as hitting the stop button and the stop button doesn't
> stop animated images

The stop button *used* to be able to stop animated GIFs 

@mozilla.org@prolinux.com
I 100% disagree with letting website devs trap the ESC key.  FF used to be about the users, not the hype of "web apps".

IMHO, this bug should be reopened.  I don't see stopping network requests with ESC as a bug. Nor do I see it even working for modal dialogs (since they are both nonstandard, and often employed as "inescapable"). 

At least get some feedback on this and don't chalk it up to 'just the power users' complaining.  Notice the 2 new duplicate bugs as of April 2013.

I was tempted to file another, but I want to respect they system here.
(Reporter)

Comment 17

5 years ago
Oh great, now my email address is going to get scraped by spambots.  :-/

Firefox also used to be about adding features using add-ons, and this is a good candidate. Even many power users don't know about Escape's former functionality; the ones who do can get it back quite simply. I would also prefer if we could somehow keep it as standard, but you can't hold back the tide.

Comment 18

5 years ago
@Comment 17 
My apologies at posting your email like that.  I would edit it out but do not see a way.

Add-ons are great, but they are no replacement for features users have enjoyed for years (a decade?).  IIRC Netscape had the same way to stop GIFs as does IE (still).

The browser needs to be the guardian between the user and the devs.  We know what happened when window.open() was abused so often.  We know that allowing the back button to be overridden is abused.  I don't see the need to offer keyboard trapping to websites as a primary concern. 

As a dev myself (other types of software), I believe users should always come first.

My main argument again is simply this:

IMHO, this bug should be reopened.  I don't see stopping network requests with ESC as a bug. Nor do I see it even working for modal dialogs (since they are both nonstandard, and often employed as "inescapable"). 

At least get some feedback.

Updated

5 years ago
Blocks: 864065
(Reporter)

Comment 19

5 years ago
OK, here's some feedback.

I ran the following poll in a private, invite-only forum for IT professionals, mostly programmers. The participants were by definition power users. I welcome you to run the exact same poll among your peers.

"Did you know that some web browsers stop animated GIFs when you press the Escape key?"
1. YES, I knew this
2. NO, I thought Escape just stopped page load
3. NO, I didn't know the Escape key did these things

The 10 respondents answered as follows:
1. 1 vote
2. 2 votes
3. 7 votes

I was surprised at how few people know about this functionality, but the inescapable conclusion is that we're looking at fringe functionality. The participants represent perhaps 1% of the population, so only about 1 in 1000 users will even know Escape can be used to stop GIF animation. We few, we happy few can get the functionality back by installing an add-on; and Jim-Bob Farmer and Vim Hacker won't be upset when an online spreadsheet stops working entirely any time they reflexively press Escape.

Comment 20

5 years ago
The Esc key should be returned the ability to stop animation of gif images after a page is done loading.

Comment 21

5 years ago
aren't their other options to close dialogs? can't stopping a gif be done in a different way the? if keyboard-only functionality is hard to discover then why not remove every keyboard-only functionality in firefox? 

i was told that esc stopped gif animations in firefox 1 day and thought it was cool... there's even some games based on it like 

http://shouldtotally.ytmnd.com/

now pages actually don't work. instead of esc maybe-stopping a gif animation maybe-somebody doesn't want stopped with esc that only exists in theory

Comment 22

5 years ago
what I want to know is... if keyboard-only functionality is so hard to discover, why do we have to worry about what happens when people discover it?

surely if it's so hard to discover, we don't need to worry so much about the consequences, and vice versa

yet the bug uses both those points as strong arguments to remove functionality

Comment 23

5 years ago
I would like this restored. I've been using this functionality since, if I'm remembering correctly, Win3.1.  Too many flash things on the screen? ESC and they stop.  Then there got to be too many, so I just animation_mode disabled them. Recently I turned them back on with the anidisabled plug in to see what the state of the web is.

I got used to hitting ESC to stop too many animations. All of a sudden it doesn't work? I'm not installing another plugin to use a different keystroke to do what was already working. 

I'm a heavy web user AND a web dev. I've never once implemented an escape trapper, nor encountered any page anywhere, ever, that traps the escape key for critical functionality. About the only thing I've ever seen is ESC to close a lightbox-style popup-- but it doesn't clash with ESC-to-stop in any way.

If there is a webdev who is "used" to trapping the esc key, you should smack them down hard and now. It's bad enough Mozilla lets Twitter trap the F5 key. It shouldn't be Mozilla's job to protect webdevs who try to do bad things that they shouldn't. And if they don't know they shouldn't, they should learn.

ESC-to-stop, not ESC because some poor webdev wants to use it.
Whiteboard: [workaround: use https://addons.mozilla.org/en-US/firefox/addon/superstop/ ]

Comment 24

5 years ago
Dancing gif animations are NOT pro-user and help them in nothing. On the contrary, they serve to annoy, and they are often used by spammy advertisers. Do you REALLY want to take the latters' side? 
The reason I didn't switch to Chrome is only this ONE. I am sure there are many out there who will be dissed, not only me. Conducting some unscientific survey and refusing to undo this is not my idea of collaborative development. 
I implore you to listen to the sane voices that have spoken up here, and let this long-standing feature not only remain, but extend the functionality to cover the newly created menace, the Flash animation. Just see how many people use the flash-block'ing add-ons. Doing this with ESC key will be a logical extension for the functionality

Comment 25

5 years ago
I'm still using Firefox 19 because of this and I will not upgrade until this functionality is returned. I refuse to use the workaround because my habit of pressing Esc to stop GIFs is over 18 years old because I've been pressing Esc to stop GIFs since at LEAST Windows 95.

I see the status of this bug is "RESOLVED WONTFIX". I wish I could put into words how I feel about this. All I know is, I just sit here letting out a huge sigh at this status. Is it no longer about the users? Are you hoping to cause people to switch to other browsers? Saying that you won't fix it sounds to me like you just don't want to do any work. Dagger said that it's possible, so why won't you do it? Is he wrong? Do you think that there's only a small number of Firefox users who use Esc for stopping GIFs? Even if so, do we no longer matter? I thought that ALL of the users mattered here. I mean, what's the deal here? If it's possible, then do it!

It's not just about this functionality: it's the principle. You're not willing to do something that is apparently possible and obviously wanted by many of your users! If you keep it this way, then you won't have to release many more versions of Firefox to actually notice that you're losing users; I'm already thinking about switching to a different browser because of this and I know I'm not alone. This looks to me like a desire for a bad reputation that would take years to undo. I mean, how many more versions are you going to release before you give us what we're asking for here? Even if you do give this back to us, how do we know that you're not going to do something else that we don't like and then refuse to fix it? This isn't the way it's supposed to be, and it's not the way that it USED to be either! This is more like a Microsoft mentality!

Now we have Firefox 21 and Esc still doesn't stop animated GIFs. So, I guess you just don't care what your users think: it's all about you now or something. I mean, it has to be, otherwise Esc would be stopping GIFs again. Or is dagger wrong? Is it actually NOT possible? Or is the existence of Superstop the reason why you won't fix it? I see the other reasons and I agree that they are lame and don't apply to the majority of users. I've NEVER had a time where pressing Esc did more than just stopping a GIF. Yeah, NEVER, and it sounds to me like this is the way it is for the majority of users who use Esc to stop GIFs.

No, I'm not going to make any change that prevents GIFs from animating in the first place. I only stop GIFs when I find them to either be irritating or distracting. Otherwise, I don't stop them.

Anyway, again: if dagger is right that it's possible to bring back this functionality, then why won't you do it? The reasons given already aren't good enough for me as I already explained. I don't know of anyone who has ever had a problem due to pressing Esc to stop a GIF.

Comment 26

5 years ago
I've suspected for some time, and am becoming more certain, that Firefox, as other browsers, has been developed sufficiently — to a point at which there is not much that is left to do for many developers, particularly those in the UI team. But because they like the feeling of having power and control, they come up with ideas and shove them into people's throats, no matter how bad the ideas are.

I think the only devs that should continue working on Firefox are those who work on performance and security. The rest should find other things to do. Otherwise, they just keep ruining what used to be a good browser.
Bug 614304 explains in detail the very real user problems that led to this change. That unfortunately had side effects of breaking this particular functionality, but since maintaining this functionality would involve more work, and since it is desired by such a minuscule percentage of our users, the add-on is seen as the most cost-effective alternative. I'm sorry that you were part of that minority that is deeply affected, but hopefully you can appreciate that it becomes difficult for a software project at our scale to make _any_ changes without negatively impacting some users.

Comment 28

5 years ago
Then I'll either be staying with Firefox 19 or switching to a different browser. I will also be spreading the word about this.

Comment 29

5 years ago
Actually, I have a suggestion: give us the ability to toggle it either in Options, or in about:config. I mean, the default setting would be to have Esc behaving as it is now in Firefox 20 and above, but in Options or in about:config, we would have the ability to toggle it back to the way it used to be.

Can this be done and can it be ready for the next Firefox release?
https://addons.mozilla.org/en-US/firefox/addon/superstop/
http://forums.mozillazine.org/viewtopic.php?t=72994

1. Install SuperStop.
2. Install keyconfig and re-map Shift+Esc to Esc.
3. Problem solved.

Comment 31

5 years ago
(In reply to Matthew Turnbull [Bluefang] from comment #30)
> https://addons.mozilla.org/en-US/firefox/addon/superstop/
> http://forums.mozillazine.org/viewtopic.php?t=72994
> 
> 1. Install SuperStop.
> 2. Install keyconfig and re-map Shift+Esc to Esc.
> 3. Problem solved.

Nice. That worked. Thank you! I already had keyconfig but I didn't think of trying this for some reason.

Note to everyone else: keyconfig will say that Esc is already used by Stop but that it might work anyway. It's right: it does!

When you go looking for Shift+Esc in keyconfig, it's listed under "superstop-key" (all lowercase).

Comment 32

5 years ago
I was hitting ESC to stop animated GIFs back in 1995.

This is expected, long-standing functionality.

Why does it feel like Mozilla project is breaking things more often than fixing them lately?

Comment 33

5 years ago
(In reply to John Flynn from comment #32)
> I was hitting ESC to stop animated GIFs back in 1995.
> 
> This is expected, long-standing functionality.
> 
> Why does it feel like Mozilla project is breaking things more often than
> fixing them lately?

I have felt the same way ever since Firefox 3.0.5. See these bugs that I submitted:

https://bugzilla.mozilla.org/show_bug.cgi?id=498546

https://bugzilla.mozilla.org/show_bug.cgi?id=665396

Here we are at Firefox 21.0 and this is still not fixed, but I'm not surprised. There are days when I wish I could still be using 3.0.4.

Anyway, did you try the solution posted above by Matthew Turnbull [Bluefang]?

Comment 34

5 years ago
Gentlemen, I am trying to read
http://recreation.kcg.gov.tw/
but as its http://recreation.kcg.gov.tw/style/front001/images/theme_top_13.gif (as of today, look soon before it is gone!) OK, I'll attach it.
is blinking and I am 50 years old,
I naturally reach for the RIGHT MOUSE MENU for some button to stop the blinking but cannot find any.
Of course if there was such a button I would probably have to toggle it a few times to get the split second when the words appear.

Anyway I think Firefox _without and add-ons_ needs to a way to hand accessibility back to the user.
P.S., I didn't really read much of the above.

Comment 35

5 years ago
Created attachment 764122 [details]
A gif that blinks at exactly the rate to cause pain when trying to read it

Older users need a way to stop this blink in its tracks!
Older users don't want to mess with add-ons.

Comment 36

5 years ago
(In reply to jidanni from comment #35)
> Created attachment 764122 [details]
> A gif that blinks at exactly the rate to cause pain when trying to read it
> 
> Older users need a way to stop this blink in its tracks!
> Older users don't want to mess with add-ons.

Here's the proven solution:

1. Install SuperStop: https://addons.mozilla.org/en-US/firefox/addon/superstop
2. Install Keyconfig: http://mozilla.dorando.at/keyconfig.xpi (more information: http://forums.mozillazine.org/viewtopic.php?t=72994) 
3. Open Keyconfig
4. Look for "superstop-shortcut" and then select it
5. Click in the text box where you see "Shift+Esc"
6. Press Esc (so don't type it)
7. Keyconfig will say "This shortcut is already used by Stop. It might still work, though". This is correct: it does!
9. Click OK
10. Click Apply
11. Click Close

Now all you have to do is press Esc to stop animated GIFs.

Comment 37

5 years ago
(In reply to twocables from comment #36)
OK thanks but I want it on the Right Click Menu and not requiring a plugin, so created bug 884614. Thanks anyway.

Comment 38

5 years ago
But (In reply to jidanni from comment #37)
> (In reply to twocables from comment #36)
> OK thanks but I want it on the Right Click Menu and not requiring a plugin,
> so created bug 884614. Thanks anyway.

But it's not a bug. There is nothing you can add to the context menu (the right-click menu) to stop animating GIFs. The only way to do it is by doing as I said so that all you have to do is simply press Esc.

Alternatively, install Active Stop Button so that all you have do is click the stop button:

https://addons.mozilla.org/en-US/firefox/addon/active-stop-button/

The only way to get anything remotely close to what you want is by using at least one extension. I recommend doing as I said earlier so that all you have to do is simply press Esc to stop animating GIFs. I find that to be far easier and faster than using my mouse to navigate to where I need to go in order to stop it. I mean, I don't have to move my mouse in order to press Esc. I just press it and I'm done. So, that's what I recommend. However, if you insist on this being something you can do with your mouse, then get Active Stop Button.

Again, this is not a bug.

Comment 39

5 years ago
To clarify: what you submitted is a bug. It's a feature request.

Comment 40

5 years ago
(In reply to twocables from comment #39)
> To clarify: what you submitted is a bug. It's a feature request.

Sigh. I meant it's NOT a bug. It's a feature request.

Comment 41

5 years ago
since this wont be fixed...

anyone has an alternative browser with similiar functionality and most important, the [ESC]-stops-gifs function?

right now i'm stuck with firefox 19 :S

Comment 42

5 years ago
(In reply to genbatzu from comment #41)
> since this wont be fixed...
> 
> anyone has an alternative browser with similiar functionality and most
> important, the [ESC]-stops-gifs function?
> 
> right now i'm stuck with firefox 19 :S

No, but here's how to get Firefox 20+ back to Esc-only for stopping GIFs:

1. Install SuperStop: https://addons.mozilla.org/en-US/firefox/addon/superstop
2. Install Keyconfig: http://mozilla.dorando.at/keyconfig.xpi (more information: http://forums.mozillazine.org/viewtopic.php?t=72994) 
3. Open Keyconfig
4. Look for "superstop-shortcut" and then select it
5. Click in the text box where you see "Shift+Esc"
6. Press Esc (so don't type it)
7. Keyconfig will say "This shortcut is already used by Stop. It might still work, though". This is correct: it DOES work!
9. Click OK
10. Click Apply
11. Click Close

It will be 100% back to normal after this.
Duplicate of this bug: 894895

Comment 44

5 years ago
Users should not be relegated to an add-on to re-implement a feature that has been around since Netscape.
Duplicate of this bug: 894895
Duplicate of this bug: 894895

Comment 47

5 years ago
I have decided to DOWNGRADE my firefox to version 14.0.1 .. thanks, http://www.oldapps.com/firefox.php?old_firefox=7981

If and when you guys again start "having my back" and reinstate this functionality, I will upgrade again. 

How I wish the "next big thing" comes soon and wipes this browser off the screens, so these guys will again start thinking "how do I make USERS happy?". Right now  they are so focused on pleasing junk web-sites and spam advertisers. It's a very regressive development, and quite unfortunate
This change was driven purely from concern for our users. It's not just "spam websites" who use WebSockets and XHR, those technologies are fundamental to a large number of popular web applications (like Gmail and Facebook). The small portion of people who really care about GIF-pausing have plenty of recourse, thanks to Firefox's awesome add-ons ecosystem (see comment 3).

Comment 49

5 years ago
(In reply to gk_2000 from comment #47)
> I have decided to DOWNGRADE my firefox to version 14.0.1 .. thanks,
> http://www.oldapps.com/firefox.php?old_firefox=7981
> 
> If and when you guys again start "having my back" and reinstate this
> functionality, I will upgrade again. 
> 
> How I wish the "next big thing" comes soon and wipes this browser off the
> screens, so these guys will again start thinking "how do I make USERS
> happy?". Right now  they are so focused on pleasing junk web-sites and spam
> advertisers. It's a very regressive development, and quite unfortunate

You can use the latest version by following these easy instructions below. The result will be that this functionality will be returned to being Esc-only for stopping animated GIFs instead of Shift+Esc for just the SuperStop extension alone:

 Install SuperStop: https://addons.mozilla.org/en-US/firefox/addon/superstop
2. Install Keyconfig: http://mozilla.dorando.at/keyconfig.xpi (more information: http://forums.mozillazine.org/viewtopic.php?t=72994) 
3. Open Keyconfig
4. Look for "superstop-shortcut" and then select it
5. Click in the text box where you see "Shift+Esc"
6. Press Esc (so don't type it)
7. Keyconfig will say "This shortcut is already used by Stop. It might still work, though". This is correct: it DOES work!
9. Click OK
10. Click Apply
11. Click Close

If you don't want to do this, then use Firefox 19 and then don't upgrade because Firefox 20 was the version that took Esc away for stopping animated GIFs. Still, this will only take a minute or two of your time and then you'll be glad that you did it.

Comment 50

5 years ago
The reason why people don't accept "install and configure an extension in 11 easy steps" is:

1) People use more or are responsible for more than one computer. Just off the top of my head: my work, my home, my wife's, my wife's work, both my parents, 3 in laws. 

2) Each time I need to try to remember the extension name, and look up up the convoluted configuration instructions

3) Hope and pray that the extension doesn't silently break during FF's many updates

3a) If it does, go back to #1

4) Hope and pray the extension author doesn't randomly change things

I'm fine doing this to EXTEND Firefox and/or ADD-ON a new function. But to have to do it to return a standard function that has always been part of the codebase, and is STILL a standard feature of every other browser out there? Come on, how can anyone possibly think this is a reasonable solution?

Here's a better solution:  Why doesn't Mozilla take this extension and absorb it into the code base, complete with the configuration?

Comment 51

5 years ago
(In reply to Lorne from comment #50)
> The reason why people don't accept "install and configure an extension in 11
> easy steps" is:

Just a minute now. Hang on. It doesn't SEEM like 11 steps when you do it, especially if you're NOT computer-illiterate. It literally takes about 2-3 minutes of your time at the most, unless you go slowly. If you go slowly, then it might take 4-5 minutes of your time. That's just 30-60 seconds longer than a commercial break.

(In reply to Lorne from comment #50)
> 1) People use more or are responsible for more than one computer. Just off
> the top of my head: my work, my home, my wife's, my wife's work, both my
> parents, 3 in laws.

Once you do it one time, you'll know what you're doing the 2nd time, the 3rd time, the 4th time, etc. and it'll quickly seem like a piece of cake. It did for me, and I feel that it's worth it. ;) Thanks to do this Lorne, I can stop animated GIFs by simply pressing Esc. I love it! Yes, I could have complained about it and posted several reasons why I won't do it and why it won't work (and why I shouldn't have to, etc.), but no. No, no, no. Hell no. I wasn't about to do that because getting back this functionality was SIGNIFICANTLY more important to me than wasting my time on that. Yeah, that's right: it's a waste of time. The amount of time you took to post this, you could have done this on all of your computers by now and then the only thing you'd have to post is "Hey it works! Thank you!" Yeah.


(In reply to Lorne from comment #50)
> 2) Each time I need to try to remember the extension name, and look up up
> the convoluted configuration instructions

Save the instructions to a USB flash drive. Or, print them. Or, send yourself an e-mail with this bugzilla page linked in it so that you can access it from any computer. I mean, be creative. Come on.

Y'know, you're making this out to be far more difficult and time-consuming than it really is. Have you even tried to do it one time yet? If so, then what did you think?


(In reply to Lorne from comment #50)
> 3) Hope and pray that the extension doesn't silently break during FF's many
> updates
> 3a) If it does, go back to #1

That's easy:

1. Open Tools > Options
2. Switch to the Advanced tab
3. Switch to the "Update" sub-tab
4. Choose either "Check for updates, but let me choose whether to install them", or "Never check for updates".

Or, use this about:config tweak to disable Add-on compatibility checking:

1. Right-click inside of about:config
2. Choose New > Boolean
3. For the Boolean value's name, copy/paste "extensions.checkCompatibility.22.0" for Firefox 22. Or, replace "22.0" with whatever version you have. Note: always keep ".0" as ".0", even if your version number is "xx.1" or something.
4. Choose a value of 'False'


(In reply to Lorne from comment #50) 
> 4) Hope and pray the extension author doesn't randomly change things

That's not going to happen with these Extensions. That would be very stupid of them because then everyone would end up hating them for screwing everything up. Besides, SuperStop and Keyconfig are too simple for this to be of any concern.


(In reply to Lorne from comment #50) 
> I'm fine doing this to EXTEND Firefox and/or ADD-ON a new function. But to
> have to do it to return a standard function that has always been part of the
> codebase, and is STILL a standard feature of every other browser out there?
> Come on, how can anyone possibly think this is a reasonable solution?

That's easy: if you want to keep using Firefox and not be forced to keep using version 19 just to have this functionality (if you want to use the latest versions of Firefox and also have this functionality), then this is what you do. Is it really THAT big of a deal? Good grief. How many other extensions exist that give Firefox a functionality that most people think that it should have? Yes, yes, I know: this is a functionality that we USED to have. Yeah, well, I have just one thing to say about that: bug 614304.


(In reply to Lorne from comment #50) 
> Here's a better solution:  Why doesn't Mozilla take this extension and
> absorb it into the code base, complete with the configuration?

Because someone already gave them a reason to NOT spend time doing that. Why should they do it when they don't HAVE to? That's valuable time that they could be spending on something else.

Instead of being so damn stubborn (and frustratingly so, I might add), just install SuperStop and Keyconfig, and then use keyconfig to change Shift+Esc to Esc for "Stop". After that, you'd be done and you'd have what you want. It's not difficult, convoluted, or time-consuming. Again, that's 3 steps:

1. Install SuperStop
2. Install keyconfig
3. Go into keyconfig and change Shift+Esc to Esc for "Stop"

Done.

Or, I can make become just 2 steps:

1. Install SuperStop and Keyconfig
2. Go into keyconfig and change Shift+Esc to Esc for "Stop".

Done.

I mean really, this isn't difficult. The only reason I posted 11 steps is to make SURE that even someone who is completely computer-illiterate can do it IF THEY REALLY WANTED TO. If I didn't "dummy it down" like that, then I would have the risk of computer-illiterate people not knowing what to do next at certain points. Most of those steps are no-brainers to people who know what they're doing. Most of those steps would make such people say, "Thanks, Captain Obvious". However, not everyone knows what they're doing, and therefore, I had to make sure to cover every last step that you'd take when you do this. In order to do that, I had to do it slowly myself to in order to make sure I didn't leave anything out.

So, stop complaining and just do it. You will be happy and glad that you did. Or, is getting this functionality back not important to you?

Comment 52

5 years ago
Correction needed. I apologize.

Here's what needs to be corrected. It's the part in all caps below (it's intentionally in all caps so that it sticks out for this correction) that reads, "Thanks to do this Lorne". It *SHOULD read "Thanks to this Lorne," so that it smoothly says, "Thanks to this Lorne, I can stop animated GIFs by simply pressing Esc. I love it!"

>Once you do it one time, you'll know what you're doing the 2nd time, the 3rd >time, the 4th time, etc. and it'll quickly seem like a piece of cake. It did >for me, and I feel that it's worth it. ;) THANKS TO DO THIS LORNE, I can stop >animated GIFs by simply pressing Esc. I love it! Yes, I could have complained >about it and posted several reasons why I won't do it and why it won't work >(and why I shouldn't have to, etc.), but no. No, no, no. Hell no. I wasn't >about to do that because getting back this functionality was SIGNIFICANTLY more >important to me than wasting my time on that. Yeah, that's right: it's a waste >of time. The amount of time you took to post this, you could have done this on >all of your computers by now and then the only thing you'd have to post is "Hey >it works! Thank you!" Yeah.

I apologize for not doing a better job of proofreading this before submitting it.

Comment 53

5 years ago
Oh you have to be kidding me. Click "wrap" on my comment above, comment #52. I know exactly what I did wrong too.

Comment 54

5 years ago
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #48)
> This change was driven purely from concern for our users. It's not just
> "spam websites" who use WebSockets and XHR, those technologies are
> fundamental to a large number of popular web applications (like Gmail and
> Facebook). The small portion of people who really care about GIF-pausing
> have plenty of recourse, thanks to Firefox's awesome add-ons ecosystem (see
> comment 3).

I must thank you for mentioning version 19. By far the most helpful reply.
The principle of this matter is, a default functionality taken for granted should be allowed to remain. Pressing escape isn't rocket science, even for the lamest of users - and saying that only advanced hacks do it is just naive.

Do you really want to survey this? then restore the functionality, log this key-event and take the frequency stats. I bet that far too many than "few" use this. 
Even otherwise, it's far too cool a functionality to be taken from our hands

You don't exactly mention what "concern about users" drove you to this extreme step. I dont see how this functionality could harm a user
(Reporter)

Comment 55

5 years ago
Original reporter here. I did survey this (comment 19), as you are aware, since you refer to it in your first comment (three months ago!). Results: nine out of ten *power users* didn't even know about the escape GIF functionality.

Meanwhile the BetterStop add-on simply works, I have it mapped to Shift-Esc since I do accept that technology changes and that web developers will use escape for site functionality.
 https://addons.mozilla.org/en-US/firefox/addon/betterstop/

It's time to accept that the old functionality isn't coming back. I encourage you to likewise let go of this bitterness and embrace change. If that means for you using another browser, I'm sure the people who get copied on all these messages will not be unhappy about that.

Comment 56

5 years ago
Since #51 misses the point, here it is in condensed form:

1) Mozilla removes a common feature
2) It takes an extension and time to restore * number of supported computers
3) That is apparently an acceptable solution, so rather than not forcing users to do this anymore, instead it becomes #2 * the number of times this keeps happening, again and again and again and again.

And to take this from general to specific, I still haven't ever encountered a site ever that uses ESC for functionality. Ever.

Comment 57

5 years ago
(In reply to Matthias Versen [:Matti] (currently busy) from comment #4)
> You can also change the option for animated images
> http://kb.mozillazine.org/Firefox_:_Tips_:_Animated_Images

     In the Location Bar type about:config and hit Enter
    Type "anim" in the Filter field (to quickly find the needed preference)
    Double-click the image.animation_mode line and edit it to one of the following: 

        none — will prevent image animation 
        once — will let the image animate once 
        normal (default) — will allow it to play over and over 


This is for the benefit of anyone who landed here for the same issue. Sorry I noticed this late. Thanks, Matthias. Now, there is some rest from this peskiness

Comment 58

5 years ago
Sigh. I did NOT miss the point. Y'know, by saying that I missed the point, you're calling me stupid and I REALLY don't like that. Would you?! Do you realize that this is the thanks that you have given me for trying to help you? Yeah. You're welcome. heh

So, forget it. I can't help someone who doesn't want to be helped. I can see now that the only reason you came here is to complain (which, as you can see, is an absolute waste of your time and energy). You'd rather cry about this instead of doing what you know you'd rather do, which is getting this functionality back somehow - and some of us are giving you an extremely easy way to get it back. If you would just try it, then you might see why I keep pushing. Prove me wrong. Shut me up by trying it and then tell me how horrible of a solution it is. You won't be ABLE to because you'll be happy that you finally did it because then you'll be able to press Esc again to stop animated GIFs. I mean, THAT'S WHAT YOU WANT! SO DO IT ALREADY!

The problem is, I know you won't do it. Like I said: you're stubborn. You'd rather sit there and spend your time whining about this than spending it installing Superstop and Keyconfig (and then changing Shift+Esc to Esc for "Stop"). Oh man, that's too much work. I shouldn't have to do that. Blah, blah, blah. Cry me a river. So apparently, complaining about it is making you happier than getting back this functionality. So hey, fine; whatever floats your boat, dude. Or, whatever turns your crank. lol

I did my part and now the ball is in your court. What you do with it is your business. If I were you, then I would just do what is being recommended so that you can have this functionality back. That way you can forget about it and move forward. Or is your ego so big that you can't do that? Does the world revolve around you now? It doesn't revolve around me or anyone *I* know, so I dunno: maybe it revolves around you. Who knows? I haven't met you yet! Yeah, I know how ridiculous that sounds, but it's ridiculous for a very good reason.

Anyway, what would you rather have from the following two choices?


1. Absolutely no way to get this functionality back, as in: IT'S ABSOLUTELY IMPOSSIBLE. Like, no one can figure it out because Mozilla made it impossible because they said "Screw all of you. This is the way we want it".

2. An easy way to get it back.


Uh, I'd rather have choice #2. It's a no-brainer in this situation. It means that there's absolutely no GOOD reason to complain. So, how about you? What's your choice? 1 or 2? No, don't you dare give me choice #3 that Mozilla gives it back to us somehow or that they never took it away in the first place because again: see bug 614304. Also, you had better not tell me again that I don't get it or that I'm missing the point or something else that's rude because I'll be honest with you: I WAS **** WHEN I UPGRADED FROM FIREFOX 19 TO 20 BECAUSE OF THIS. Oh yeah, that's right: I was ****. I raged. If you don't believe me, then look up my post about it on Overclock.net. I went back to Firefox 19 and told several people to avoid Firefox 20. Then I posted a bug to complain about it. What was the result? Someone told me about Superstop + keyconfig and then I was happy again. Did I fight it and complain that I had to do that? A little. Who wouldn't? However, I realized immediately that I didn't want to be stuck at Firefox 19, so I swallowed my pride, shoved my ego to the side VERY hard, and installed SuperStop and keyconfig. I'm extremely glad that I did it, and I guarantee that you would be too if you would do it.

So, why you won't do this is WAY BEYOND ME, but dude: do you realize that the amount of time and energy you spent complaining and whining about this could have been spent doing this solution at lest a couple of dozen times or more? How about the amount of time that you have spent reading my posts, including this one? I mean, seriously: why are you so stubborn? Get over it. It's just a frickin' web browser. Not only that, but this is the way it is now, so just tell your ego to shut up and let you install Superstop and keyconfig so that you can be happy again. I mean, really. How much longer are you going to drag this on for? You're just spinning your wheels and Mozilla doesn't care. All of their developers will just tell you the same damn thing that I'm telling you: you can either install these extensions, or you can keep complaining about it. I made MY choice and look at me, I'm happy that I made it. Every time I want to stop an animated GIF, all I have to do is tap Esc and I'm done. It's no big deal. Why should I complain and cry that I had to install two TINY extensions just to get this functionality back? Oooo, my ego can't take it! It fights back so hard! Screw my ego. I'm far more mature and intelligent than it. It's called "your inner child". Tell it that children should be seen and not heard because right now, your ego is in charge and it's making you unhappy. I mean, you don't look very happy to me. So set your ego aside, install these extensions, enjoy having the functionality back, and then tell your ego that it's safe to come out now.

Oh hey, did you know that keyconfig is useful for far more than just this functionality?

I need a break.

Comment 59

5 years ago
Omg, now there's BetterStop. Thank you, mozilla.org@prolinux.com (from Comment #55).

See, Lorne? Now it's just 1 step. So, what's it gonna be? Continue complaining, or install BetterStop? "Oh, but I shouldn't have to do that! This is an outrage!" lol

Comment 60

5 years ago
@twocables: You really are missing the point. It's a default feature present since the beginning of time that was removed forcefully. Writing essays to convince anyone is proof that it's not that straightforward.

I will not debate the merit of this decision, I miss it once a month but I guess it doesn't fit the OS-in-a-browser direction.

The point is: When you remove features like this one, make sure you leave an obscure preference to toggle it back to how it used to be [1]. Leave it there for a year or two and then you can remove it completely. You could even go on and say "hey, only 0.00001% of our users turn the browser.esc_stops_gifs pref on".

[1]: Good example: Tabs on top, you could keep them on the bottom of the address bar for a few versions until it was removed. Bad example: The removal of the status bar & the removal of the download progress (until it was fixed 2 years later).
You don't need to speculate about our motivations, they're clearly mentioned in the bug that made the change (bug 614304). Bug 614304 comment 0 and bug 614304 comment 14 do a good job of explaining why the key was causing harm to users of websites that use XHR and WebSockets.

Bugzilla is not the right place to debate the pro/cons of a change after the fact, or to lobby for/against changes we've already shipped. I'm going to restrict the comments on this bug to users with editbugs privileges. If you encounter a related issues that aren't yet reported, you can file a new bug. If you have constructive comments or new data, you can email firefox-dev (https://wiki.mozilla.org/Firefox/firefox-dev).
Restrict Comments: true

Comment 62

5 years ago
It seemed like an unintentional regression at first, but now it's the way it is. Is that correct, Gavin?

Updated

3 years ago
See Also: → bug 392866
You need to log in before you can comment on or make changes to this bug.