Last Comment Bug 826002 - Consider blocklisting Adobe Reader XI on OS X
: Consider blocklisting Adobe Reader XI on OS X
Status: RESOLVED FIXED
:
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: All Mac OS X
: -- normal (vote)
: ---
Assigned To: Jorge Villalobos [:jorgev]
: Anthony Hughes (:ashughes) [GFX][QA][Mentor]
:
Mentors:
Depends on:
Blocks: 825198
  Show dependency treegraph
 
Reported: 2013-01-02 12:08 PST by Steven Michaud [:smichaud] (Retired)
Modified: 2016-03-07 15:30 PST (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Steven Michaud [:smichaud] (Retired) 2013-01-02 12:08:48 PST
Acrobat Reader XI no longer supports loading PDF files "inline" in Firefox on OS X.  But the error conditions this triggers are very unfortunate.  See bug 825198.

Much better to blocklist Acrobat Reader XI on OS X -- presuming that this will cause Firefox to fail over to prompting the user to download the PDF file (instead of trying to load it into a browser page).
Comment 1 Jorge Villalobos [:jorgev] 2013-01-02 13:10:49 PST
We currently have all versions up to 10.1.3 softblocked on Mac OS X: https://etherpad.mozilla.org/plugin-blocks

Which versions do you want blocked? How old are they?
Comment 2 Tyler Downer [:Tyler] 2013-01-02 13:12:48 PST
Blocking all Reader plugins will be pretty horrible (and are you wanting a hardblock or CTP block?) unless we have something else that users can fall back on. For alot of PDF's, yes, they will just download, but inline PDF's can be weird. Can we hold off on doing this until we hear from Adobe if they will release an update to fix this, or we have PDF.js on release?
Comment 3 Steven Michaud [:smichaud] (Retired) 2013-01-02 13:41:37 PST
(In reply to comment #2)

What currently happens with Adobe Reader XI on the Mac is really bad -- see bug 825198.  It'd certainly be better to blocklist it than not, even though it's the current version.  Presuming, of course, that blocklisting it will make FF behave as if it's been disabled (and prompt the user to download the PDF file).

I suggest this is true even of inline PDFs (though I wasn't able to find any examples to test with).

Even if Adobe does change its mind (which I suspect isn't likely), Adobe Reader XI version 11.0.0 (the first release) is already out, and they can't change *that* version.

Somebody please CC someone appropriate from Adobe.
Comment 4 Steven Michaud [:smichaud] (Retired) 2013-01-02 13:45:14 PST
> Which versions do you want blocked?

At least the current Adobe Reader XI version, which is 11.0.0.

I suspect we'll only need to do this on the Mac.  But someone should check this plugin's behavior on Windows.

> How old are they?

http://en.wikipedia.org/wiki/Adobe_Reader#Version_11.0
Comment 5 Steven Michaud [:smichaud] (Retired) 2013-01-02 13:49:02 PST
Note that we're already blocklisting 10.1.3, and started doing that when it was the current version.  See bug 747073 and bug 750387.
Comment 6 Steven Michaud [:smichaud] (Retired) 2013-01-02 13:51:43 PST
As best I can tell we don't need to blocklist 10.1.4.  See bug 747073 comment #20 and bug 811085 comment #5.
Comment 7 Tyler Downer [:Tyler] 2013-01-02 13:53:08 PST
If Adobe will release an update we should consider waiting to release a block until they update, as all 11.0.0 users will be updated to 11.0.1.
Comment 8 Steven Michaud [:smichaud] (Retired) 2013-01-02 14:12:39 PST
Here are some examples of embedded PDFs.  I mention them because they weren't easy to find.

http://acroeng.adobe.com/wp/?page_id=161
Comment 9 bhavana bajaj [:bajaj] 2013-01-02 16:59:42 PST
Adding qawanted here to help confirm plugin behavior on other OS's as mentioned in comment# 4 ?
Comment 10 Alex Keybl [:akeybl] 2013-01-03 08:47:41 PST
(In reply to Tyler Downer [:Tyler] from comment #7)
> If Adobe will release an update we should consider waiting to release a
> block until they update, as all 11.0.0 users will be updated to 11.0.1.

If the QA request in Comment 9 confirms that bug 825198 impacts all or nearly all configurations using Adobe Reader XI on Mac, then we'll move forward with a block regardless given the disabled behavior in https://bugzilla.mozilla.org/show_bug.cgi?id=825198#c3.
Comment 11 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-01-03 14:28:23 PST
(In reply to bhavana bajaj [:bajaj] from comment #9)
> Adding qawanted here to help confirm plugin behavior on other OS's as
> mentioned in comment# 4 ?

What is the request of QA here? Is it just testing Adobe Reader 11 on Windows, Mac, and Linux to see whether the PDFs in comment 8 load in-line? What are you trying to determine here?
Comment 12 Steven Michaud [:smichaud] (Retired) 2013-01-03 14:43:08 PST
(In reply to comment #11)

Comment #4 talks about testing Adobe Reader XI on other platforms than Mac.  Practically speaking this is limited to Windows, since Adobe Reader XI is only available for OS X and Windows.  For myself, I'd just like to see if Adobe Reader XI supports loading PDF files inline on Windows.

Comment #10 talks about testing on OS X.  For myself I'd say it's enough to confirm (or disconfirm) what I say at bug 825198.

Most references you can find online to PDF files are to the files directly.  But comment #8 references some examples of embedded references to PDF files.  I'd suggest you test with both.

Note that the Adobe Reader XI installer for OS X says (on its Read Me page) that the "browser plug-in" is only for Safari.
Comment 13 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-01-03 15:32:41 PST
Thanks Steven. The results of my testing follows.

Testcase:
1. Install Firefox and start with a new profile
2. Install Adobe Reader 11.0
3. Load all the embedded PDFs from http://acroeng.adobe.com/wp/?page_id=161
4. Load all the direct PDFs from the first page of results from http://www.google.ca/?q=pdf

Summary of Results:
Embedded and direct PDFs load in-line with Reader on Windows but do not on Mac. On Mac the user is prompted with a dialog which prevents loading the PDF in-line.

Windows 8:
----------
Firefox 18.0b7: Embedded PDFs open in-line using Reader, Direct PDFs open in-line using Reader
Firefox 19.0a2: Embedded PDFs open in-line using Reader, Direct PDFs open in-line using PDF.js
Firefox 20.0a1: Embedded PDFs open in-line using Reader, Direct PDFs open in-line using PDF.js
Direct PDFs load in-line with Reader if you change the default handler to Adobe Reader NPAPI plugin in Firefox.

Windows 7:
----------
Firefox 18.0b7: Embedded PDFs open in-line using Reader, Direct PDFs open in-line using Reader
Firefox 19.0a2: Embedded PDFs open in-line using Reader, Direct PDFs open in-line using PDF.js
Firefox 20.0a1: Embedded PDFs open in-line using Reader, Direct PDFs open in-line using PDF.js
Direct PDFs load in-line with Reader if you change the default handler to Adobe Reader NPAPI plugin in Firefox.

Mac OSX 10.7:
-------------
Firefox 18.0b7: Embedded and Direct PDFs do not display in-line, instead an Adobe pop-up appears stating "Reader cannot show documents in this browser". Clicking OK on the dialog loads the page without the PDF content. Leaving the dialog up for a minute sometimes results in a plugin content NPAPI crash. This dialog only shows once in a user session (you'll need to restart to see it again). A side-effect is that Direct PDFs just render as a blank page (the user is not given an option to download the file and open externally).

Firefox 19.0a2: Embedded PDFs show the same behaviour as above (Adobe pop-up, no inline display). Direct PDFs load in-line with PDF.js. Switching the default PDF handler to the Adobe NPAPI plugin displays the same behaviour as Firefox 18.0b7.

Firefox 20.0a1: Embedded PDFs show the same behaviour as above (Adobe pop-up, no inline display). Direct PDFs load in-line with PDF.js. Switching the default PDF handler to the Adobe NPAPI plugin displays the same behaviour as Firefox 18.0b7.

Ubuntu 12.04:
-------------
Could not be tested because the latest version of Reader is 9.5.1.

Please let me know if this is not sufficient data to move ahead with your block.
Comment 14 Jorge Villalobos [:jorgev] 2013-01-07 09:36:05 PST
The block has been staged: https://addons-dev.allizom.org/en-US/firefox/blocked/p255. It is limited to Mac OS X, and version 11.0.0 of the plugin.

Please verify that it fixes the problems on Mac OS.
Comment 15 Steven Michaud [:smichaud] (Retired) 2013-01-08 14:40:17 PST
Adobe Reader XI v 11.0.1 was just released, but has the same problem.

So we should probably blocklist that version, too.
Comment 16 Jorge Villalobos [:jorgev] 2013-01-08 14:50:13 PST
The staged block has been updated.
Comment 17 Steven Michaud [:smichaud] (Retired) 2013-01-08 14:57:09 PST
> Adobe Reader XI v 11.0.1 was just released, but has the same problem.

Oops, I goofed on the version number.  It's actually "11.0.01".
Comment 18 Benjamin Smedberg [:bsmedberg] 2013-01-09 06:02:45 PST
Why don't we just block all versions of the plugin until they notify us that they have fixed the issue?
Comment 19 Jorge Villalobos [:jorgev] 2013-01-09 06:19:49 PST
(In reply to Steven Michaud from comment #17)
> Oops, I goofed on the version number.  It's actually "11.0.01".

Updated.

(In reply to Benjamin Smedberg  [:bsmedberg] from comment #18)
> Why don't we just block all versions of the plugin until they notify us that
> they have fixed the issue?

Depends on whether we want a delay when blocking new faulty versions, or a delay when unblocking the new good version, since this is a major block and needs staging and QA when modified. My expectation was that Adobe would fix this quickly, but maybe I'm mistaken.
Comment 20 Benjamin Smedberg [:bsmedberg] 2013-01-09 06:26:48 PST
I don't expect Adobe to fix this quickly, if they ever choose to fix it.
Comment 21 Jorge Villalobos [:jorgev] 2013-01-09 07:11:00 PST
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #20)
> I don't expect Adobe to fix this quickly, if they ever choose to fix it.

In that case, shouldn't we look into other solutions, like a fix on our side or the hotfix add-on?
Comment 22 Benjamin Smedberg [:bsmedberg] 2013-01-09 07:48:56 PST
There is no fix. Adobe does not support or test the plugin in Firefox (see http://www.adobe.com/products/reader/tech-specs.html for supported system requirements) and we should just hardblock the plugin. Between pdf.js and saving the PDF and opening using Preview/Acrobat Reader, I don't think this is a problem.
Comment 23 Tyler Downer [:Tyler] 2013-01-09 08:43:13 PST
Have we even contacted adobe even to discuss this? Expect Major backlash from users if we block. PDF.js is 6 weeks away, and for some inline pdf's on websites, saving it to your pc isn't fail proof.
Comment 24 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-01-09 14:16:45 PST
Before I put any time and resources into testing what we have staged, I'd like to confirm that what we have staged is what we want to push live.
Comment 25 Steven Michaud [:smichaud] (Retired) 2013-01-09 14:51:08 PST
(In reply to comment #23)

As I've already said above, for most people blocking will actually present a better experience than not blocking.  When we block, people who follow direct links to PDF files (the vast majority of PDF file references) will simply be prompted to download the file.

We're already blocking Adobe Reader 10.1.3, and (as I also mentioned) we started doing this when that version was current.  (Now 10.1.4 has been released, which does support loading PDF files inline in Firefox, so we don't block that.)
Comment 26 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-01-09 16:33:24 PST
Results look good for staged blocklist...

Firefox 18 w/Adobe Reader 11.0.0:
* confirmed blocklisted
* PDFs open in Preview.app
* Reader can be re-enabled via Add-ons Manager
* Reader warns about "unsupported browser" for in-line PDFs

Firefox 18 w/Adobe Reader 11.0.01:
* confirmed blocklisted
* PDFs open in Preview.app
* Reader can be re-enabled via Add-ons Manager
* Reader warns about "unsupported browser" for in-line PDFs

Firefox 18 w/Adobe Reader 10.1.4
* confirmed not blocklisted
* PDFs open in-line with Adobe Reader when handler set
* PDFs open in Preview.app when handler set

Firefox 19b1 w/Adobe Reader 11.0:
* confirmed blocklisted
* PDFs open in-line with PDF.js
* Reader can be re-enabled via Add-ons Manager
* Reader warns about "unsupported browser" for in-line PDFs

Firefox 19b1 w/Adobe Reader 11.0.01:
* confirmed blocklisted
* PDFs open in-line with PDF.js
* Reader can be re-enabled via Add-ons Manager
* Reader warns about "unsupported browser" for in-line PDFs

Firefox 19b1 w/Adobe Reader 10.1.4:
* confirmed not blocklisted
* PDFs open in-line with Adobe Reader when handler set
* PDFs open in-line with PDF.js when handler set
Comment 27 Jorge Villalobos [:jorgev] 2013-01-10 14:26:50 PST
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #22)
> There is no fix. Adobe does not support or test the plugin in Firefox (see
> http://www.adobe.com/products/reader/tech-specs.html for supported system
> requirements) and we should just hardblock the plugin. Between pdf.js and
> saving the PDF and opening using Preview/Acrobat Reader, I don't think this
> is a problem.

Alex, are we okay with extending the block to include 11.0.* instead of 11.0.01?
Comment 28 Alex Keybl [:akeybl] 2013-01-10 15:04:18 PST
(In reply to Jorge Villalobos [:jorgev] from comment #27)
> (In reply to Benjamin Smedberg  [:bsmedberg] from comment #22)
> > There is no fix. Adobe does not support or test the plugin in Firefox (see
> > http://www.adobe.com/products/reader/tech-specs.html for supported system
> > requirements) and we should just hardblock the plugin. Between pdf.js and
> > saving the PDF and opening using Preview/Acrobat Reader, I don't think this
> > is a problem.
> 
> Alex, are we okay with extending the block to include 11.0.* instead of
> 11.0.01?

Let's keep this block to only released versions for now. Adobe's system requirements suggest that they support the ESR (https://www.adobe.com/products/reader/tech-specs.html), which is currently on Firefox 17. Bug 825198 suggests that Firefox 17 is also affected.

I'll perform outreach, so that they hopefully fix in 11.0.02.
Comment 29 Alex Keybl [:akeybl] 2013-01-10 15:08:21 PST
(In reply to Alex Keybl [:akeybl] from comment #28)
> (In reply to Jorge Villalobos [:jorgev] from comment #27)
> > (In reply to Benjamin Smedberg  [:bsmedberg] from comment #22)
> > > There is no fix. Adobe does not support or test the plugin in Firefox (see
> > > http://www.adobe.com/products/reader/tech-specs.html for supported system
> > > requirements) and we should just hardblock the plugin. Between pdf.js and
> > > saving the PDF and opening using Preview/Acrobat Reader, I don't think this
> > > is a problem.
> > 
> > Alex, are we okay with extending the block to include 11.0.* instead of
> > 11.0.01?
> 
> Let's keep this block to only released versions for now. Adobe's system
> requirements suggest that they support the ESR
> (https://www.adobe.com/products/reader/tech-specs.html), which is currently
> on Firefox 17. Bug 825198 suggests that Firefox 17 is also affected.
> 
> I'll perform outreach, so that they hopefully fix in 11.0.02.

I've just sent email to Adobe, will let everybody know when I hear back (so we know what to do about 11.0.02).
Comment 30 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2013-01-10 15:12:46 PST
Dropping qawanted given the testing request has been fulfilled.
Setting myself as QA Contact so I keep this on my radar to test however we decide to proceed.
Comment 31 Alex Keybl [:akeybl] 2013-01-15 10:07:27 PST
The Adobe Reader team is looking into bug 825198, so let's not block the unreleased 11.0.02. We can move forward with blocking all earlier versions.
Comment 32 Jorge Villalobos [:jorgev] 2013-01-15 10:57:12 PST
The block is now live: https://addons.mozilla.org/en-US/firefox/blocked/p252. Please verify in an hour or so.
Comment 33 juan becerra [:juanb] 2013-01-15 12:49:20 PST
Verified in production. The plugin is disabled and when I try to open an inline PDF document using the link in comment #13 I am told the plugin is disabled. If I try to open a PDF document from the IRS site I am prompted to open with Preview or to save.

Note You need to log in before you can comment on or make changes to this bug.